4 Replies - 17836 Views - Last Post: 04 May 2009 - 02:24 PM

#1 boredom  Icon User is offline

  • D.I.C Head

Reputation: 0
  • View blog
  • Posts: 63
  • Joined: 03-January 09

Tomcat Running but Not responding

Post icon  Posted 30 April 2009 - 04:09 AM

My Tomcat 6 is running on port 8080. I have set a password also during installation. I gave the correct path of JDK during Tomcat Installation. But Now when I try to see the tomcat running in Browser. It does not respond.
I type http://localhost:8080 . The page progresses but nothing is being displayed. I know that Tomcat is running as I can see in the services or in the task bar.
Can anyone tell me why does it take so long for tomcat to respond, Virtually it is not responding.
The IE window in the status bar shows waiting for http://localhost:8080/...


Thanks

This post has been edited by boredom: 30 April 2009 - 04:10 AM


Is This A Good Question/Topic? 0
  • +

Replies To: Tomcat Running but Not responding

#2 pbl  Icon User is offline

  • There is nothing you can't do with a JTable
  • member icon

Reputation: 8324
  • View blog
  • Posts: 31,857
  • Joined: 06-March 08

Re: Tomcat Running but Not responding

Posted 30 April 2009 - 03:06 PM

Do you know that you are in a Java forum ?
Moved to WebServer and Hosting... may be they can help

This post has been edited by pbl: 30 April 2009 - 03:09 PM

Was This Post Helpful? 0
  • +
  • -

#3 AfterBurner66  Icon User is offline

  • D.I.C Head

Reputation: 16
  • View blog
  • Posts: 116
  • Joined: 02-August 08

Re: Tomcat Running but Not responding

Posted 30 April 2009 - 05:20 PM

View Postboredom, on 30 Apr, 2009 - 03:09 AM, said:

My Tomcat 6 is running on port 8080. I have set a password also during installation. I gave the correct path of JDK during Tomcat Installation. But Now when I try to see the tomcat running in Browser. It does not respond.
I type http://localhost:8080 . The page progresses but nothing is being displayed. I know that Tomcat is running as I can see in the services or in the task bar.
Can anyone tell me why does it take so long for tomcat to respond, Virtually it is not responding.
The IE window in the status bar shows waiting for http://localhost:8080/...


Thanks

First of all, you must make a simple reboot in Windows to be sure that your problem is not due to a random windows condition,where computer is not responding quickly or is not responding at all.
After this simple step,there is a question:do you have another server or service on your computer that runs on the same port(8080)?If this is the case you must stop this, to give Tomcat the freedom to run.
If there isn't such a thing,do you have IIS running on your machine?Because IIS generates errors and problems to other servers, in spite of that is running on port 80.
If this is not the case, do you have Windows XP SP2 or Vista?You probably have to configure Windows firewall to allow Tomcat to run or if you have another firewall on your machine, the same holds true.
I run Tomcat on Windows XP for a long time and usually there is no problem, if CATALINA_HOME is correct and the above conditions are all met.
Hope this helps ;)
Was This Post Helpful? 0
  • +
  • -

#4 boredom  Icon User is offline

  • D.I.C Head

Reputation: 0
  • View blog
  • Posts: 63
  • Joined: 03-January 09

Re: Tomcat Running but Not responding

Posted 04 May 2009 - 04:22 AM

View PostAfterBurner66, on 30 Apr, 2009 - 04:20 PM, said:

View Postboredom, on 30 Apr, 2009 - 03:09 AM, said:

My Tomcat 6 is running on port 8080. I have set a password also during installation. I gave the correct path of JDK during Tomcat Installation. But Now when I try to see the tomcat running in Browser. It does not respond.
I type http://localhost:8080 . The page progresses but nothing is being displayed. I know that Tomcat is running as I can see in the services or in the task bar.
Can anyone tell me why does it take so long for tomcat to respond, Virtually it is not responding.
The IE window in the status bar shows waiting for http://localhost:8080/...


Thanks

First of all, you must make a simple reboot in Windows to be sure that your problem is not due to a random windows condition,where computer is not responding quickly or is not responding at all.
After this simple step,there is a question:do you have another server or service on your computer that runs on the same port(8080)?If this is the case you must stop this, to give Tomcat the freedom to run.
If there isn't such a thing,do you have IIS running on your machine?Because IIS generates errors and problems to other servers, in spite of that is running on port 80.
If this is not the case, do you have Windows XP SP2 or Vista?You probably have to configure Windows firewall to allow Tomcat to run or if you have another firewall on your machine, the same holds true.
I run Tomcat on Windows XP for a long time and usually there is no problem, if CATALINA_HOME is correct and the above conditions are all met.
Hope this helps ;)


Hi These are not the issues.
Anyway I would like to know what does error code 0 signify in Tomcat. I got this error code when trying to start Tomcat through services.msc.
Also is there any specific way to set path in Tomcat 6.0, or setting path is not needed in Tomcat 6.o
Thanks
Was This Post Helpful? 0
  • +
  • -

#5 KYA  Icon User is offline

  • g++ jameson.cpp -o beverage
  • member icon

Reputation: 3093
  • View blog
  • Posts: 19,139
  • Joined: 14-September 07

Re: Tomcat Running but Not responding

Posted 04 May 2009 - 02:24 PM

If you installed it correctly, you should have gotten a welcome page or equivalent on localhost:8080

I had to use Tomcat for a college class last semester, these links might helpyou:

Installing Tomcat
Testing Tomcat
Deployment with Tomcat
Was This Post Helpful? 0
  • +
  • -

Page 1 of 1