Ruby/Ruby On Rails basics not working

the tutorials I checked out and followed are not working out

Page 1 of 1

6 Replies - 7883 Views - Last Post: 02 July 2009 - 02:01 PM Rate Topic: -----

#1 JkinsonA  Icon User is offline

  • New D.I.C Head

Reputation: 0
  • View blog
  • Posts: 21
  • Joined: 01-April 09

Ruby/Ruby On Rails basics not working

Posted 21 June 2009 - 05:42 AM

Hey guys,

To give a brief explanation I am new to ruby and tried out some tutorials, anyways I managed to get the server running as localhost:3000 which displayed the usual and expected web page

then lets say I executed the command

"ruby script\generate controller hello"

and then under the views folder created hello.rhtml and inserted "Hello World" and when I go to localhost:3000/hello I get the following error

Quote

"We're sorry, but something went wrong.

We've been notified about this issue and we'll take a look at it shortly."


I believe the error code is 500

I really want to learn ruby and if I cant overcome this obstacle I cannot advance

Your help is very much appreciated :)

Regards,
JkinsonA

Is This A Good Question/Topic? 0
  • +

Replies To: Ruby/Ruby On Rails basics not working

#2 MitkOK  Icon User is offline

  • D.I.C Regular
  • member icon

Reputation: 32
  • View blog
  • Posts: 403
  • Joined: 09-August 07

Re: Ruby/Ruby On Rails basics not working

Posted 21 June 2009 - 05:54 AM

1. Take a look at log/development.log file.

2. Get a good book, reading your post I can say that you have no idea what you're doing.
Was This Post Helpful? 0
  • +
  • -

#3 JkinsonA  Icon User is offline

  • New D.I.C Head

Reputation: 0
  • View blog
  • Posts: 21
  • Joined: 01-April 09

Re: Ruby/Ruby On Rails basics not working

Posted 21 June 2009 - 06:07 AM

View PostMitkOK, on 21 Jun, 2009 - 04:54 AM, said:

1. Take a look at log/development.log file.

2. Get a good book, reading your post I can say that you have no idea what you're doing.


Hey, thanks alot for your reply, it actually helped alot

I noticed that the error was something to do with the permissions for the log file

Here is a screenshot which will tell you what is wrong

http://img221.images...us/i/there.jpg/

I am not sure how to fix this problem and guidance would be very much appreciated

:)

This post has been edited by JkinsonA: 21 June 2009 - 06:12 AM

Was This Post Helpful? 0
  • +
  • -

#4 MitkOK  Icon User is offline

  • D.I.C Regular
  • member icon

Reputation: 32
  • View blog
  • Posts: 403
  • Joined: 09-August 07

Re: Ruby/Ruby On Rails basics not working

Posted 21 June 2009 - 06:19 AM

As you can see, the permission caused a warning, but the real problem is that you don't have SQLite Ruby library :

Quote

no such file to load -- sqlite3.


So, just install the gem

$ gem install sqlite3-ruby


The problem is that this will build native extensions and Windows really sucks as ruby/rails dev environment.

This post has been edited by MitkOK: 21 June 2009 - 06:20 AM

Was This Post Helpful? 0
  • +
  • -

#5 JkinsonA  Icon User is offline

  • New D.I.C Head

Reputation: 0
  • View blog
  • Posts: 21
  • Joined: 01-April 09

Re: Ruby/Ruby On Rails basics not working

Posted 21 June 2009 - 06:36 AM

View PostMitkOK, on 21 Jun, 2009 - 05:19 AM, said:

As you can see, the permission caused a warning, but the real problem is that you don't have SQLite Ruby library :

Quote

no such file to load -- sqlite3.


So, just install the gem

$ gem install sqlite3-ruby


The problem is that this will build native extensions and Windows really sucks as ruby/rails dev environment.


Heya, thanks alot for your input

though there is another problem, and I am hating vista even more than I kinda did, and unfortunately I dont have Ubuntu installed here so I cant work using Ubuntu instead

anyways here is the latest problem, it cant seem to install the library

http://img81.imagesh...us/i/thank.jpg/

Your help is very much appreciated :)

REgards,
JkinsonA
Was This Post Helpful? 0
  • +
  • -

#6 MitkOK  Icon User is offline

  • D.I.C Regular
  • member icon

Reputation: 32
  • View blog
  • Posts: 403
  • Joined: 09-August 07

Re: Ruby/Ruby On Rails basics not working

Posted 21 June 2009 - 12:29 PM

Search for installing SQLite under Windows :)
Was This Post Helpful? 0
  • +
  • -

#7 Kerplope  Icon User is offline

  • New D.I.C Head
  • member icon

Reputation: 2
  • View blog
  • Posts: 14
  • Joined: 22-September 08

Re: Ruby/Ruby On Rails basics not working

Posted 02 July 2009 - 02:01 PM

I had the sample problem installing sqLite 3 basically you want to grab the sqlitedll-3_6_16.zip from the Precompiled Binaries For Windows within http://www.sqlite.org/download.html and drop the extracted files into your ruby/bin directory. Also make sure you restart your server, you may also need to restart your computer.

Good Luck.

This post has been edited by Kerplope: 02 July 2009 - 02:01 PM

Was This Post Helpful? 1

Page 1 of 1