Flash .swf file loses quality when displayed in HTML page

I've made a .swf movie which has perfect quality viewed on my PC,

Page 1 of 1

3 Replies - 2715 Views - Last Post: 04 September 2009 - 09:57 AM

#1 possum87  Icon User is offline

  • New D.I.C Head

Reputation: 0
  • View blog
  • Posts: 3
  • Joined: 04-September 09

Flash .swf file loses quality when displayed in HTML page

Post icon  Posted 04 September 2009 - 03:35 AM

(I use Flash CS4)

I've made a flash banner which I want on my website. The quality was a bit crap so I searched around and found hundreds of places giving advice on improving quality, and I've followed some of these.
The quality of the images in the banner is top notch - when viewed on my PC. As soon as I upload it to my website, it goes to hell. The images become grainy and pixelated (although not as bad they were before the changes).

The images I use are all .PNG, imported into flash and NOT resized. They are all placed at whole number coordinates (x = 1 y= 1).
None of them are rotated or edited in any way.

The steps I've taken to improve quality:

I've gone to each individual image and set it to 'Lossless PNG'
I've unticked 'allow smoothing'.
I've ticked 'allow smoothing'. <-- This removes the pixelated edges but leaves the images slightly 'fuzzy' and soft looking.

Ive changed publish settings for;

Jpeg quality to 100.
Enable Jpeg unblocking.
Unticked 'compress movie'.


This is the code I use to call the .swf file. It starts playing automatically, and in High quality.

<a href="{U_INDEX}" title="{L_INDEX}" id="logo"><object classid="clsid27CDB6E-AE6D-11CF-96B8-444553540000" codebase="http://active.macromedia.com/flash2/cabs/swflash.cab#version=5,0,0,0" width="880" height="302">
<param name="movie" value="{T_THEME_PATH}/asmo.swf" />
<param name="play" value="true" />
<param name="quality" value="high" />
<param name="allowScriptAccess" value="never" />
<embed src="{T_THEME_PATH}/asmo.swf" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/shockwave/download/index.cgi?P1_Prod_Version=ShockwaveFlash" width="880" height="302" play="true" loop="true" quality="high" allowscriptaccess="never"></embed>
</object></a>
<p style="display: none;"><a href="#start_here">{L_SKIP}</a></p>


I'm at a total loss as to why, when the .swf is perfect quality on my PC, it loses quality on a webpage...


Any help is much appreciated.

Is This A Good Question/Topic? 0
  • +

Replies To: Flash .swf file loses quality when displayed in HTML page

#2 thehat  Icon User is offline

  • awake ? web();
  • member icon

Reputation: 106
  • View blog
  • Posts: 951
  • Joined: 28-February 08

Re: Flash .swf file loses quality when displayed in HTML page

Posted 04 September 2009 - 09:42 AM

Could be a stupid question, but are you specifying the correct dimensions in your object tag? Also, have you tried taking the anchor tag away?
Was This Post Helpful? 0
  • +
  • -

#3 possum87  Icon User is offline

  • New D.I.C Head

Reputation: 0
  • View blog
  • Posts: 3
  • Joined: 04-September 09

Re: Flash .swf file loses quality when displayed in HTML page

Posted 04 September 2009 - 09:55 AM

View Postthehat, on 4 Sep, 2009 - 08:42 AM, said:

Could be a stupid question, but are you specifying the correct dimensions in your object tag? Also, have you tried taking the anchor tag away?


The dimensions are exactly right, but I'm not sure about the anchor. I didnt realise there was one in there, which part is it?
Was This Post Helpful? 0
  • +
  • -

#4 thehat  Icon User is offline

  • awake ? web();
  • member icon

Reputation: 106
  • View blog
  • Posts: 951
  • Joined: 28-February 08

Re: Flash .swf file loses quality when displayed in HTML page

Posted 04 September 2009 - 09:57 AM

The <a href="{U_INDEX}" title="{L_INDEX}" id="logo"> and corresponding </a>. I'm not sure if it'll help though...
Was This Post Helpful? 0
  • +
  • -

Page 1 of 1