Videos not playing when building .jar

  • (3 Pages)
  • +
  • 1
  • 2
  • 3

37 Replies - 6736 Views - Last Post: 21 April 2012 - 04:06 AM Rate Topic: -----

#31 g00se  Icon User is offline

  • D.I.C Lover
  • member icon

Reputation: 2675
  • View blog
  • Posts: 11,297
  • Joined: 20-September 08

Re: Videos not playing when building .jar

Posted 18 April 2012 - 07:30 AM

I've never tried to play an mpg in Java before, but i have noticed that some multi-media apis in Java are unfortunately file-oriented as opposed to stream-oriented. If that's the case here, it might simply not support media in jars
Was This Post Helpful? 0
  • +
  • -

#32 Lyc  Icon User is offline

  • New D.I.C Head

Reputation: 0
  • View blog
  • Posts: 13
  • Joined: 13-April 12

Re: Videos not playing when building .jar

Posted 19 April 2012 - 03:38 PM

other possible solution ? any other idea ?
Was This Post Helpful? 0
  • +
  • -

#33 g00se  Icon User is offline

  • D.I.C Lover
  • member icon

Reputation: 2675
  • View blog
  • Posts: 11,297
  • Joined: 20-September 08

Re: Videos not playing when building .jar

Posted 19 April 2012 - 04:02 PM

Try to falsify my last contention. If you can show that i'm wrong, i'll take another look at it
Was This Post Helpful? 0
  • +
  • -

#34 Lyc  Icon User is offline

  • New D.I.C Head

Reputation: 0
  • View blog
  • Posts: 13
  • Joined: 13-April 12

Re: Videos not playing when building .jar

Posted 20 April 2012 - 05:08 AM

So you think there is no way how to play movie in jar application without allowing user to open some ? i will try anything but i dont know what and how.
Was This Post Helpful? 0
  • +
  • -

#35 g00se  Icon User is offline

  • D.I.C Lover
  • member icon

Reputation: 2675
  • View blog
  • Posts: 11,297
  • Joined: 20-September 08

Re: Videos not playing when building .jar

Posted 20 April 2012 - 09:33 AM

Try running the app without it being in a jar and see what happens
Was This Post Helpful? 0
  • +
  • -

#36 Lyc  Icon User is offline

  • New D.I.C Head

Reputation: 0
  • View blog
  • Posts: 13
  • Joined: 13-April 12

Re: Videos not playing when building .jar

Posted 20 April 2012 - 02:44 PM

but it not fix my problem if i take jar to another pc
Was This Post Helpful? 0
  • +
  • -

#37 Lyc  Icon User is offline

  • New D.I.C Head

Reputation: 0
  • View blog
  • Posts: 13
  • Joined: 13-April 12

Re: Videos not playing when building .jar

Posted 21 April 2012 - 12:46 AM

i try it play outside the jar but nothing happened no frame no voice no screen
Was This Post Helpful? 0
  • +
  • -

#38 g00se  Icon User is offline

  • D.I.C Lover
  • member icon

Reputation: 2675
  • View blog
  • Posts: 11,297
  • Joined: 20-September 08

Re: Videos not playing when building .jar

Posted 21 April 2012 - 04:06 AM

I can only help further if you post the whole project somewhere
Was This Post Helpful? 0
  • +
  • -

  • (3 Pages)
  • +
  • 1
  • 2
  • 3