Port Forwarding on WRT54G V.4

(I think this goes here...)

Page 1 of 1

3 Replies - 14015 Views - Last Post: 07 August 2008 - 09:08 PM

#1 karasu  Icon User is offline

  • D.I.C Head

Reputation: 1
  • View blog
  • Posts: 50
  • Joined: 19-December 05

Port Forwarding on WRT54G V.4

Posted 26 April 2006 - 05:56 PM

Okay, here's the deal:

I have a windows compie and a linux compie connected to my Linksys WRT54G router. My linux box is a server, and my IP is dynamic, so I have to use the No-IP client.

I installed the client on my linux box, but it only has the Ubuntu base system and development packages installed beacuse it's a server. Now I'm a n00b to linux, and I don't have a clue if No-IP installed correctly, or if it's running.

I read a tutorial on the No-IP site (link) and I gathered that I need to enable port forwarding- however, the tutorial doesn't seem to apply to my router. The only menu I could find in the configuration for the router was under the applications & gaming tab- anyway, I don't have a clue what to do.

Any help is appreciated. Thanks,
Karasu

Is This A Good Question/Topic? 0
  • +

Replies To: Port Forwarding on WRT54G V.4

#2 MarkoDaGeek  Icon User is offline

  • Dirty Technophile
  • member icon

Reputation: 11
  • View blog
  • Posts: 11,158
  • Joined: 13-October 01

Re: Port Forwarding on WRT54G V.4

Posted 26 April 2006 - 08:02 PM

Port forwarding is fairly easy to configure.

Go into your router's admin console, I run a Belkin now so I may be a little rusty but with Linksys I think its 192.168.1.1 ? or its .100

Go into the firewall settings of the router, I believe you want to click on the 'Security' tab and then 'Firewall' and uncheck the box for 'Block Anonymous Internet Requests' then go to the 'Applications & Gaming' tab then 'Port Range Forward'

From here its pretty stright forward, just put in a name for the application and the port range you want to forward and for the IP address put your server's address... Also as a side note, you should set up your server to be a static IP, becuase this will break if it were to get a new IP address from the Linksys DHCP somehow...
Was This Post Helpful? 0
  • +
  • -

#3 karasu  Icon User is offline

  • D.I.C Head

Reputation: 1
  • View blog
  • Posts: 50
  • Joined: 19-December 05

Re: Port Forwarding on WRT54G V.4

Posted 26 April 2006 - 08:40 PM

Alright, I think I'm -finally- close to getting this... this is what's in my networking file on my linux box:

auto eth0
iface eth0 inet static
	   address 192.168.1.10
	   netmask 255.255.255.0
	   network 192.168.1.0
	   broadcast 192.168.1.255
	   gateway 192.168.1.1



This is what I have my router set to:

Application: HTTP 
Ports: 80 ~ 80
Protocol: Both 
IP: 192.168.1.1



But when I go to my No-IP address I get my router configuration page. Know what to do?

Thanks~
K-kun

This post has been edited by karasu: 01 June 2006 - 03:46 PM

Was This Post Helpful? 0
  • +
  • -

#4 drofenvy  Icon User is offline

  • New D.I.C Head

Reputation: 0
  • View blog
  • Posts: 1
  • Joined: 07-August 08

Re: Port Forwarding on WRT54G V.4

Posted 07 August 2008 - 09:08 PM

For your router, you should set the ip to 192.168.1.10. By putting it as 192.168.1.1, you are telling the firewall to forward requests on port 80 to the router's port 80 and not your computer's port.
Was This Post Helpful? 0
  • +
  • -

Page 1 of 1