4 Replies - 396 Views - Last Post: 11 April 2010 - 12:47 PM Rate Topic: -----

#1 angelita  Icon User is offline

  • New D.I.C Head

Reputation: 0
  • View blog
  • Posts: 4
  • Joined: 22-October 09

HELP APPLICATION DID NOT RUN IN NETBEANS

Posted 11 April 2010 - 10:49 AM

HI I ATTACHED THE FILE AND ALSO I PUT THE SOURCE SITE
HTtp://www.falstad.com/circuit/

THIS IS SITE FOR CIRCUIT SIMULATOR WITH ...SOURCE FILES
I TRIED TO RUN IT IN NETBEANS BUT IT RUNS WITH EXCEPTIONS AND DOES NOT EXECUTE AS MUST BE

IT JUST SHOW THE INTERFACE WITH BUTTONS WITHOUT RESPONDING TO THE REACTION
SO PLZ HELP
I WANT TO RUN IT ON NETBEANS
THE APPLICATION USES FILES TO STORE DATA INSTEAD OF DATABASE ..
DO I NEED TO PUT THE TEXT FILES IN PARTICULAR PLACE OR SOMETHING ...HOW I CAN RUN THE APPLICATION

Attached File(s)



Is This A Good Question/Topic? 0
  • +

Replies To: HELP APPLICATION DID NOT RUN IN NETBEANS

#2 japanir  Icon User is offline

  • jaVanir
  • member icon

Reputation: 1010
  • View blog
  • Posts: 3,025
  • Joined: 20-August 09

Re: HELP APPLICATION DID NOT RUN IN NETBEANS

Posted 11 April 2010 - 11:28 AM

you will get much more help if you post your code inside code tags, and attach the error messeges\exceptions you get. (rather than add the file for download).
It would be much easier for us to provide help.
Thanks for helping us help you :)

This post has been edited by japanir: 11 April 2010 - 11:29 AM

Was This Post Helpful? 0
  • +
  • -

#3 angelita  Icon User is offline

  • New D.I.C Head

Reputation: 0
  • View blog
  • Posts: 4
  • Joined: 22-October 09

Re: HELP APPLICATION DID NOT RUN IN NETBEANS

Posted 11 April 2010 - 11:39 AM

THE CODE IS TOOO LONG SO MANY CLASSES
THE CLASSES DO NOT CONTAIN ERRORS BUT IT DOES NOT RUN AS MUST ME

BUT HERE SOME OF EXCEPTION METHODS ITS SEEMS THAT THE SAME PROBLEM


java.lang.ClassNotFoundException: WireElm
        at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
        at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:248)
        at java.lang.Class.forName0(Native Method)
        at java.lang.Class.forName(Class.java:169)
        at sim.CirSim.getClassCheckItem(CirSim.java:572)
        at sim.CirSim.init(CirSim.java:300)
        at sim.Circuit.main(Circuit.java:39)
java.lang.ClassNotFoundException: ResistorElm
        at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
        at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:248)
        at java.lang.Class.forName0(Native Method)
        at java.lang.Class.forName(Class.java:169)
        at sim.CirSim.getClassCheckItem(CirSim.java:572)
        at sim.CirSim.init(CirSim.java:301)
        at sim.Circuit.main(Circuit.java:39)
java.lang.ClassNotFoundException: SwitchElm
        at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
        at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:248)
        at java.lang.Class.forName0(Native Method)
        at java.lang.Class.forName(Class.java:169)
        at sim.CirSim.getClassCheckItem(CirSim.java:572)
        at sim.CirSim.init(CirSim.java:307)
        at sim.Circuit.main(Circuit.java:39)

.
.
.
.




Was This Post Helpful? 0
  • +
  • -

#4 macosxnerd101  Icon User is online

  • Self-Trained Economist
  • member icon




Reputation: 10397
  • View blog
  • Posts: 38,475
  • Joined: 27-December 08

Re: HELP APPLICATION DID NOT RUN IN NETBEANS

Posted 11 April 2010 - 12:43 PM

First, please do not type in all caps, as it is considered TO BE SHOUTING AT US. :)

As for your errors, you are being told that the compiler cannot find the classes in question in the scope they are being referenced.
Was This Post Helpful? 0
  • +
  • -

#5 Luckless  Icon User is offline

  • </luck>
  • member icon

Reputation: 292
  • View blog
  • Posts: 1,146
  • Joined: 31-August 09

Re: HELP APPLICATION DID NOT RUN IN NETBEANS

Posted 11 April 2010 - 12:47 PM

You might want to make sure (in order with macosxnerd's comment) that you have all the classes in the same package or the main class imports the necessary packages. Netbeans is really fickle with this
Was This Post Helpful? 0
  • +
  • -

Page 1 of 1