2 Replies - 10977 Views - Last Post: 17 August 2006 - 12:18 PM Rate Topic: -----

#1 avolel  Icon User is offline

  • New D.I.C Head

Reputation: 2
  • View blog
  • Posts: 42
  • Joined: 24-August 05

ASP .NET Web App Admin

Post icon  Posted 01 August 2006 - 07:16 AM

Can anyone help me fix this error message. I recieve it clicking the security link on the ASP .Net Web Application Administration page.

I'm using VWD Express Edition and it default developer web browser. My web.config file is attached.
I added a rolemanager node, but to no avail. It still did not work.
I went to C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\CONFIG\web.config

and looked for " <add connectionStringName="LocalSqlServer" maxEventDetailsLength="1073741823"", I changed LocalSqlServer to ReportConnectionString which is the name of my connection string. It still didn't work.

Your Help Will Be Greatly Appreciated
Thanks


-------What I added To web.config----------------------------
<roleManager enabled="true" defaultProvider="SqlRoleManager">
<providers>
<add name="SqlRoleManager"
type="System.Web.Security.SqlRoleProvider"
connectionStringName="ReportConnectionString"
applicationName="StatusReport" />
</providers>
</roleManager>
------------------------------------------------------------------------


----------------ERROR MESSAGE---------------------------------
There is a problem with your selected data store. This can be caused by an invalid server name or credentials, or by insufficient permission. It can also be caused by the role manager feature not being enabled. Click the button below to be redirected to a page where you can choose a new data store.

The following message may help in diagnosing the problem: Unable to connect to SQL Server database.
--------------------------------------------------------------------

Attached File(s)



Is This A Good Question/Topic? 0
  • +

Replies To: ASP .NET Web App Admin

#2 sontek  Icon User is offline

  • D.I.C Regular
  • member icon

Reputation: 8
  • View blog
  • Posts: 283
  • Joined: 13-September 01

Re: ASP .NET Web App Admin

Posted 07 August 2006 - 08:31 PM

View Postavolel, on 1 Aug, 2006 - 07:16 AM, said:

Can anyone help me fix this error message. I recieve it clicking the security link on the ASP .Net Web Application Administration page.

I'm using VWD Express Edition and it default developer web browser. My web.config file is attached.
I added a rolemanager node, but to no avail. It still did not work.
I went to C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\CONFIG\web.config

and looked for " <add connectionStringName="LocalSqlServer" maxEventDetailsLength="1073741823"", I changed LocalSqlServer to ReportConnectionString which is the name of my connection string. It still didn't work.

Your Help Will Be Greatly Appreciated
Thanks


-------What I added To web.config----------------------------
<roleManager enabled="true" defaultProvider="SqlRoleManager">
<providers>
<add name="SqlRoleManager"
type="System.Web.Security.SqlRoleProvider"
connectionStringName="ReportConnectionString"
applicationName="StatusReport" />
</providers>
</roleManager>
------------------------------------------------------------------------


----------------ERROR MESSAGE---------------------------------
There is a problem with your selected data store. This can be caused by an invalid server name or credentials, or by insufficient permission. It can also be caused by the role manager feature not being enabled. Click the button below to be redirected to a page where you can choose a new data store.

The following message may help in diagnosing the problem: Unable to connect to SQL Server database.
--------------------------------------------------------------------




You will never have to modify the web.config inside the framework directory, Always work with the web.config inside your actual website.

But one way you could do this is:
<?xml version="1.0"?>
<configuration xmlns="http://schemas.microsoft.com/.NetConfiguration/v2.0">
  <appSettings>
  </appSettings>
  <connectionStrings>
	<!-- Get rid of default Express connection -->
	<remove name="LocalSqlServer"/>
	<add name="LocalSqlServer" connectionString="Database=Test;Server=Server123;User=test;Password=test;" 
		 providerName="System.Data.SqlClient"/>
	</connectionStrings>
  <system.web>
	<roleManager enabled="true" cacheRolesInCookie="false" createPersistentCookie="true">
	  <providers>
		<add applicationName="/" connectionStringName="LocalSqlServer" name="DefaultRoleProvider" type="CustomRoleProvider"/>
	  </providers>
	</roleManager>
	<membership>
	  <providers>
		<add connectionStringName="LocalSqlServer" enablePasswordRetrieval="false" enablePasswordReset="true" 
			 requiresQuestionAndAnswer="true" applicationName="/" requiresUniqueEmail="true" passwordFormat="Hashed" 
			 minRequiredPasswordLength="5" name="CustomMembershipProvider" type="CustomMembershipProvider"></add>
	  </providers>
	</membership>
  </system.web>
</configuration>


This post has been edited by sontek: 07 August 2006 - 08:32 PM

Was This Post Helpful? 0
  • +
  • -

#3 avolel  Icon User is offline

  • New D.I.C Head

Reputation: 2
  • View blog
  • Posts: 42
  • Joined: 24-August 05

Re: ASP .NET Web App Admin

Posted 17 August 2006 - 12:18 PM

View Postsontek, on 7 Aug, 2006 - 08:31 PM, said:

View Postavolel, on 1 Aug, 2006 - 07:16 AM, said:

Can anyone help me fix this error message. I recieve it clicking the security link on the ASP .Net Web Application Administration page.

I'm using VWD Express Edition and it default developer web browser. My web.config file is attached.
I added a rolemanager node, but to no avail. It still did not work.
I went to C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\CONFIG\web.config

and looked for " <add connectionStringName="LocalSqlServer" maxEventDetailsLength="1073741823"", I changed LocalSqlServer to ReportConnectionString which is the name of my connection string. It still didn't work.

Your Help Will Be Greatly Appreciated
Thanks


-------What I added To web.config----------------------------
<roleManager enabled="true" defaultProvider="SqlRoleManager">
<providers>
<add name="SqlRoleManager"
type="System.Web.Security.SqlRoleProvider"
connectionStringName="ReportConnectionString"
applicationName="StatusReport" />
</providers>
</roleManager>
------------------------------------------------------------------------


----------------ERROR MESSAGE---------------------------------
There is a problem with your selected data store. This can be caused by an invalid server name or credentials, or by insufficient permission. It can also be caused by the role manager feature not being enabled. Click the button below to be redirected to a page where you can choose a new data store.

The following message may help in diagnosing the problem: Unable to connect to SQL Server database.
--------------------------------------------------------------------




You will never have to modify the web.config inside the framework directory, Always work with the web.config inside your actual website.

But one way you could do this is:
<?xml version="1.0"?>
<configuration xmlns="http://schemas.microsoft.com/.NetConfiguration/v2.0">
  <appSettings>
  </appSettings>
  <connectionStrings>
	<!-- Get rid of default Express connection -->
	<remove name="LocalSqlServer"/>
	<add name="LocalSqlServer" connectionString="Database=Test;Server=Server123;User=test;Password=test;" 
		 providerName="System.Data.SqlClient"/>
	</connectionStrings>
  <system.web>
	<roleManager enabled="true" cacheRolesInCookie="false" createPersistentCookie="true">
	  <providers>
		<add applicationName="/" connectionStringName="LocalSqlServer" name="DefaultRoleProvider" type="CustomRoleProvider"/>
	  </providers>
	</roleManager>
	<membership>
	  <providers>
		<add connectionStringName="LocalSqlServer" enablePasswordRetrieval="false" enablePasswordReset="true" 
			 requiresQuestionAndAnswer="true" applicationName="/" requiresUniqueEmail="true" passwordFormat="Hashed" 
			 minRequiredPasswordLength="5" name="CustomMembershipProvider" type="CustomMembershipProvider"></add>
	  </providers>
	</membership>
  </system.web>
</configuration>


Thanks Alot for your help.
I got it to work.
Was This Post Helpful? 0
  • +
  • -

Page 1 of 1