7 Replies - 13061 Views - Last Post: 26 September 2010 - 02:18 PM Rate Topic: -----

#1 Dogstopper  Icon User is offline

  • The Ninjaducky
  • member icon

Reputation: 2965
  • View blog
  • Posts: 11,222
  • Joined: 15-July 08

img tags

Posted 24 July 2010 - 06:13 AM

In several (seemingly random) topics, the XML has <img> tags which self-close instead of being properly closed (with a closing tag). My parser won't read them like this:
<avatar><imag src="..." alt="..." /></avatar>



Instead, they need to be like this:
<avatar><imag src="..." alt="..."></img></avatar>



The language having issues is Java

Is This A Good Question/Topic? 0
  • +

Replies To: img tags

#2 skyhawk133  Icon User is offline

  • Head DIC Head
  • member icon

Reputation: 1949
  • View blog
  • Posts: 20,376
  • Joined: 17-March 01

Re: img tags

Posted 24 July 2010 - 07:22 AM

Hmmm, <img /> is a valid way of representing an image, I think most images will actually be that way as the <img> tag isn't like a div that has an open and a close with stuff in between.
Was This Post Helpful? 0
  • +
  • -

#3 Dogstopper  Icon User is offline

  • The Ninjaducky
  • member icon

Reputation: 2965
  • View blog
  • Posts: 11,222
  • Joined: 15-July 08

Re: img tags

Posted 24 July 2010 - 08:22 AM

I was wrong. Most of the image tags are ok, but any page that has the :code: emote fails because this is the XML for that:
<img src="http://static.dreamincode.net/forums/style_emoticons/default/code.gif">



Which is the invalid part.
Was This Post Helpful? 0
  • +
  • -

#4 Valek  Icon User is offline

  • The Real Skynet
  • member icon

Reputation: 544
  • View blog
  • Posts: 1,713
  • Joined: 08-November 08

Re: img tags

Posted 24 July 2010 - 11:41 PM

Is that happening with just the code emote or all smilies? I'd think it's occur with all of them if it's happening at all, since the code emote is run as smilies are.

This post has been edited by Valek: 24 July 2010 - 11:41 PM

Was This Post Helpful? 0
  • +
  • -

#5 Dogstopper  Icon User is offline

  • The Ninjaducky
  • member icon

Reputation: 2965
  • View blog
  • Posts: 11,222
  • Joined: 15-July 08

Re: img tags

Posted 25 July 2010 - 08:34 AM

Actually Valek, smilies are working in my rendition of the post. The XML isn't parsing any page with :code: on it, so I think its just them.
Was This Post Helpful? 0
  • +
  • -

#6 skyhawk133  Icon User is offline

  • Head DIC Head
  • member icon

Reputation: 1949
  • View blog
  • Posts: 20,376
  • Joined: 17-March 01

Re: img tags

Posted 26 July 2010 - 02:40 PM

Weird, yeh, all emoticons are invoked the same way... ummmmmm, I'm at a loss on this one... anyone have any suggestions as to what would fix it?!
Was This Post Helpful? 0
  • +
  • -

#7 Dogstopper  Icon User is offline

  • The Ninjaducky
  • member icon

Reputation: 2965
  • View blog
  • Posts: 11,222
  • Joined: 15-July 08

Re: img tags

Posted 13 September 2010 - 08:35 AM

Alright skyhawk, I have tracked down the error a little farther. It's not the code tags when written using the emoticon (this page shows up fine), but ONLY in the code tags in the rules tags.

Take this post for example: http://www.dreaminco...-file-scanning/

That one won't load correctly, yet this will. I would suggest looking in the BBCode parser for the [ rules] tag. There is an error in the <img> tag there.
Was This Post Helpful? 1
  • +
  • -

#8 Valek  Icon User is offline

  • The Real Skynet
  • member icon

Reputation: 544
  • View blog
  • Posts: 1,713
  • Joined: 08-November 08

Re: img tags

Posted 26 September 2010 - 02:18 PM

Nice catch, Dogstopper! I haven't seen many rules BBCode posts in the PHP forum lately, so I hadn't even thought of it. My own testing kept having it appear correctly, which is why I was baffled.
Was This Post Helpful? 0
  • +
  • -

Page 1 of 1