3 Replies - 3809 Views - Last Post: 28 July 2010 - 11:55 AM Rate Topic: -----

#1 thursdayniac  Icon User is offline

  • D.I.C Regular

Reputation: 6
  • View blog
  • Posts: 255
  • Joined: 26-April 09

Setup Project - Registry Settings

Posted 28 July 2010 - 10:19 AM

I'm trying to write an installer for an outlook add-in that I made. The only problem is that I have no idea how/what to do to change the registry settings/values. I'm using the Setup Project in Visual Studio..
but when I get to the Registry editor I don;t really know what to put where. I have a registry.reg file that came with the template for my project, but I was told I need to manually put the registry values in.
Is this right?
Here's what's in the .reg file:

Windows Registry Editor Version 5.00

Quote

[HKEY_CURRENT_USER\Software\Microsoft\Office\Outlook\SocialConnector\SocialProviders\TestProvider.TestProvider]
"FriendlyName"="plcm"
"Url"="http://www.thissite.com/"

[HKEY_CLASSES_ROOT\TestProvider.TestProvider]
@="TestProvider.TestProvider"

[HKEY_CLASSES_ROOT\TestProvider.TestProvider\CLSID]
@="{2BCC981B-5B31-3A00-B47D-6144F270A9EA}"

[HKEY_CLASSES_ROOT\CLSID\{2BCC981B-5B31-3A00-B47D-6144F270A9EA}]
@="TestProvider.TestProvider"

[HKEY_CLASSES_ROOT\CLSID\{2BCC981B-5B31-3A00-B47D-6144F270A9EA}\Implemented Categories]

[HKEY_CLASSES_ROOT\CLSID\{2BCC981B-5B31-3A00-B47D-6144F270A9EA}\Implemented Categories\{62C8FE65-4EBB-45e7-B440-6E39B2CDBF29}]

[HKEY_CLASSES_ROOT\CLSID\{2BCC981B-5B31-3A00-B47D-6144F270A9EA}\InprocServer32]
@="mscoree.dll"
"ThreadingModel"="Both"
"Class"="TestProvider.TestProvider"
"Assembly"="TestProvider, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null"
"RuntimeVersion"="v2.0.50727"

[HKEY_CLASSES_ROOT\CLSID\{2BCC981B-5B31-3A00-B47D-6144F270A9EA}\InprocServer32\1.0.0.0]
"Class"="TestProvider.TestProvider"
"Assembly"="TestProvider, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null"
"RuntimeVersion"="v2.0.50727"

[HKEY_CLASSES_ROOT\CLSID\{2BCC981B-5B31-3A00-B47D-6144F270A9EA}\ProgId]
@="TestProvider.TestProvider"

[HKEY_CURRENT_USER\Software\Microsoft\Office\Outlook\SocialConnector]
"DebugProviders"=dword:00000001
"ShowDebugButtons"=dword:00000001



What is all this and what do I do with it?

Thanks in advance

Is This A Good Question/Topic? 0
  • +

Replies To: Setup Project - Registry Settings

#2 Searock  Icon User is offline

  • D.I.C Regular
  • member icon

Reputation: 35
  • View blog
  • Posts: 259
  • Joined: 15-September 09

Re: Setup Project - Registry Settings

Posted 28 July 2010 - 11:13 AM

It's a long time I have not used Setup and deployment project, so I am not sure about my answer.

http://msdn.microsof...v=VS.71%29.aspx

http://www.c-sharpco...upProjects.aspx
Was This Post Helpful? 1
  • +
  • -

#3 thursdayniac  Icon User is offline

  • D.I.C Regular

Reputation: 6
  • View blog
  • Posts: 255
  • Joined: 26-April 09

Re: Setup Project - Registry Settings

Posted 28 July 2010 - 11:45 AM

View PostSearock, on 28 July 2010 - 10:13 AM, said:

It's a long time I have not used Setup and deployment project, so I am not sure about my answer.

http://msdn.microsof...v=VS.71%29.aspx

http://www.c-sharpco...upProjects.aspx


Lol.. thanks, I can't believe I never came across something about importing reg files. It worked!
Was This Post Helpful? 0
  • +
  • -

#4 Searock  Icon User is offline

  • D.I.C Regular
  • member icon

Reputation: 35
  • View blog
  • Posts: 259
  • Joined: 15-September 09

Re: Setup Project - Registry Settings

Posted 28 July 2010 - 11:55 AM

I am glad, I could help you. :smile2:
Was This Post Helpful? 0
  • +
  • -

Page 1 of 1