13 Replies - 16764 Views - Last Post: 16 October 2010 - 10:41 AM

#1 antarr.byrd  Icon User is offline

  • D.I.C Head

Reputation: 6
  • View blog
  • Posts: 247
  • Joined: 30-August 09

Xampp, Cannot Access Local host

Posted 07 August 2010 - 05:37 PM

I'm trying to use Xaamp on windows 7 but cannot start apache.

I tried changing the host file in windows/system32/drivers, after looking @ some tutorial. Still a no go. Anyone have an idea. Below is what "host" looks like now.


# Copyright (c) 1993-2009 Microsoft Corp.
#
# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
#
# This file contains the mappings of IP addresses to host names. Each
# entry should be kept on an individual line. The IP address should
# be placed in the first column followed by the corresponding host name.
# The IP address and the host name should be separated by at least one
# space.
#
# Additionally, comments (such as these) may be inserted on individual
# lines or following the machine name denoted by a '#' symbol.
#
# For example:
#
#      102.54.94.97     rhino.acme.com          # source server
#       38.25.63.10     x.acme.com              # x client host

# localhost name resolution is handled within DNS itself.
	127.0.0.1       localhost




Is This A Good Question/Topic? 0
  • +

Replies To: Xampp, Cannot Access Local host

#2 narzy  Icon User is offline

  • New D.I.C Head

Reputation: 0
  • View blog
  • Posts: 5
  • Joined: 03-June 10

Re: Xampp, Cannot Access Local host

Posted 07 August 2010 - 11:45 PM

Most of the time it is due to other programs operating on those ports and blocking XAMPP and WAMP. A couple of the known ones are Skype and Teamviewer. Try disabling or closing programs before starting XAMPP and that should work.
Was This Post Helpful? 0
  • +
  • -

#3 no2pencil  Icon User is online

  • Toubabo Koomi
  • member icon

Reputation: 5316
  • View blog
  • Posts: 27,221
  • Joined: 10-May 07

Re: Xampp, Cannot Access Local host

Posted 07 August 2010 - 11:59 PM

** Topic moved to Web Servers & Hosting **

If you can ping localhost from the command line (or use nslookup to resolve it), then the host file isn't your issue.

Since you just said you tried to change it, can you tell us what you tried to change it to? What you have there is the default setting.
Was This Post Helpful? 0
  • +
  • -

#4 antarr.byrd  Icon User is offline

  • D.I.C Head

Reputation: 6
  • View blog
  • Posts: 247
  • Joined: 30-August 09

Re: Xampp, Cannot Access Local host

Posted 08 August 2010 - 07:53 AM

View Postno2pencil, on 07 August 2010 - 10:59 PM, said:

** Topic moved to Web Servers & Hosting **

If you can ping localhost from the command line (or use nslookup to resolve it), then the host file isn't your issue.

Since you just said you tried to change it, can you tell us what you tried to change it to? What you have there is the default setting.



Well when I checked it, it had something else listed @ 127.0.0.1 , won't say what. Rather not incriminate myself.

I am able to ping localhost w/o anyloss or travel time. I dont use skype or anything like that. Below is the list of running processes atm.


Quote

Image Name PID Session Name Session# Mem Usage
========================= ======== ================ =========== ============
System Idle Process 0 Services 0 24 K
System 4 Services 0 964 K
smss.exe 292 Services 0 1,196 K
csrss.exe 400 Services 0 4,580 K
wininit.exe 484 Services 0 4,576 K
csrss.exe 516 Console 1 5,940 K
services.exe 540 Services 0 9,212 K
lsass.exe 556 Services 0 12,424 K
lsm.exe 564 Services 0 4,216 K
winlogon.exe 652 Console 1 7,044 K
svchost.exe 712 Services 0 9,348 K
svchost.exe 792 Services 0 8,112 K
atiesrxx.exe 860 Services 0 4,324 K
svchost.exe 920 Services 0 22,584 K
svchost.exe 968 Services 0 126,880 K
svchost.exe 1000 Services 0 36,668 K
svchost.exe 728 Services 0 15,784 K
atieclxx.exe 368 Console 1 5,628 K
svchost.exe 1200 Services 0 14,776 K
spoolsv.exe 1340 Services 0 12,568 K
svchost.exe 1368 Services 0 16,004 K
svchost.exe 1472 Services 0 14,692 K
EngineServer.exe 1568 Services 0 724 K
FrameworkService.exe 1620 Services 0 7,456 K
VsTskMgr.exe 1680 Services 0 5,460 K
mfevtps.exe 1740 Services 0 976 K
MotoConnectService.exe 1776 Services 0 4,416 K
naPrdMgr.exe 1804 Services 0 1,548 K
MsDtsSrvr.exe 1936 Services 0 22,244 K
sqlservr.exe 1992 Services 0 74,208 K
sqlservr.exe 1148 Services 0 131,904 K
msmdsrv.exe 1784 Services 0 44,212 K
ReportingServicesService. 2084 Services 0 54,552 K
SQLAGENT.EXE 2532 Services 0 2,768 K
conhost.exe 2544 Services 0 2,984 K
sqlwriter.exe 2576 Services 0 6,332 K
svchost.exe 2596 Services 0 7,484 K
McShield.exe 2640 Services 0 59,056 K
mfeann.exe 2732 Services 0 1,720 K
conhost.exe 2748 Services 0 2,676 K
taskhost.exe 2996 Console 1 7,780 K
dwm.exe 3084 Console 1 27,048 K
explorer.exe 3108 Console 1 44,532 K
MotoConnect.exe 3164 Console 1 15,260 K
ZuneLauncher.exe 3408 Console 1 3,956 K
MagicDisc.exe 3548 Console 1 7,232 K
UdaterUI.exe 3652 Console 1 2,324 K
shstat.exe 3672 Console 1 1,756 K
DivXUpdate.exe 3788 Console 1 14,532 K
Launcher.exe 2488 Console 1 36,192 K
opera.exe 3124 Console 1 186,124 K
fdlauncher.exe 3472 Services 0 3,888 K
SearchIndexer.exe 3516 Services 0 23,940 K
svchost.exe 3264 Services 0 6,024 K
WUDFHost.exe 1820 Services 0 6,232 K
fdhost.exe 4116 Services 0 5,904 K
wmpnetwk.exe 4300 Services 0 4,936 K
conhost.exe 4320 Services 0 2,756 K
svchost.exe 4884 Services 0 14,372 K
WmiPrvSE.exe 5028 Services 0 6,412 K
taskmgr.exe 4764 Console 1 10,260 K
cmd.exe 4896 Console 1 2,960 K
conhost.exe 3620 Console 1 5,608 K
tasklist.exe 5024 Console 1 5,544 K
WmiPrvSE.exe 4572 Services 0 6,224 K

Was This Post Helpful? 0
  • +
  • -

#5 moopet  Icon User is offline

  • binary decision maker
  • member icon

Reputation: 339
  • View blog
  • Posts: 1,185
  • Joined: 02-April 09

Re: Xampp, Cannot Access Local host

Posted 08 August 2010 - 08:42 AM

When you say you cannot start apache, what error is in the apache log? How do you know it doesn't start?
Was This Post Helpful? 0
  • +
  • -

#6 antarr.byrd  Icon User is offline

  • D.I.C Head

Reputation: 6
  • View blog
  • Posts: 247
  • Joined: 30-August 09

Re: Xampp, Cannot Access Local host

Posted 08 August 2010 - 08:49 AM

View Postmoopet, on 08 August 2010 - 07:42 AM, said:

When you say you cannot start apache, what error is in the apache log? How do you know it doesn't start?


It starts then it stop. below is the log

Quote

OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : make_sock: could not bind to address [::]:80
(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : make_sock: could not bind to address [::]:80
(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : make_sock: could not bind to address [::]:80
(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : make_sock: could not bind to address [::]:80
(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : make_sock: could not bind to address [::]:80
(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
httpd.exe: Syntax error on line 484 of C:/xampp/apache/conf/httpd.conf: Syntax error on line 50 of C:/xampp/apache/conf/extra/httpd-vhosts.conf: </VirtualHost> without matching <VirtualHost> section
httpd.exe: Syntax error on line 484 of C:/xampp/apache/conf/httpd.conf: Syntax error on line 50 of C:/xampp/apache/conf/extra/httpd-vhosts.conf: </VirtualHost> without matching <VirtualHost> section
httpd.exe: Syntax error on line 484 of C:/xampp/apache/conf/httpd.conf: Syntax error on line 50 of C:/xampp/apache/conf/extra/httpd-vhosts.conf: </VirtualHost> without matching <VirtualHost> section
httpd.exe: Syntax error on line 484 of C:/xampp/apache/conf/httpd.conf: Syntax error on line 50 of C:/xampp/apache/conf/extra/httpd-vhosts.conf: </VirtualHost> without matching <VirtualHost> section
httpd.exe: Syntax error on line 484 of C:/xampp/apache/conf/httpd.conf: Syntax error on line 50 of C:/xampp/apache/conf/extra/httpd-vhosts.conf: </VirtualHost> without matching <VirtualHost> section
httpd.exe: Syntax error on line 484 of C:/xampp/apache/conf/httpd.conf: Syntax error on line 50 of C:/xampp/apache/conf/extra/httpd-vhosts.conf: </VirtualHost> without matching <VirtualHost> section
httpd.exe: Syntax error on line 484 of C:/xampp/apache/conf/httpd.conf: Syntax error on line 50 of C:/xampp/apache/conf/extra/httpd-vhosts.conf: </VirtualHost> without matching <VirtualHost> section
httpd.exe: Syntax error on line 484 of C:/xampp/apache/conf/httpd.conf: Syntax error on line 50 of C:/xampp/apache/conf/extra/httpd-vhosts.conf: </VirtualHost> without matching <VirtualHost> section
httpd.exe: Syntax error on line 484 of C:/xampp/apache/conf/httpd.conf: Syntax error on line 50 of C:/xampp/apache/conf/extra/httpd-vhosts.conf: </VirtualHost> without matching <VirtualHost> section
httpd.exe: Syntax error on line 484 of C:/xampp/apache/conf/httpd.conf: Syntax error on line 50 of C:/xampp/apache/conf/extra/httpd-vhosts.conf: </VirtualHost> without matching <VirtualHost> section
httpd.exe: Syntax error on line 484 of C:/xampp/apache/conf/httpd.conf: Syntax error on line 50 of C:/xampp/apache/conf/extra/httpd-vhosts.conf: </VirtualHost> without matching <VirtualHost> section

Was This Post Helpful? 0
  • +
  • -

#7 moopet  Icon User is offline

  • binary decision maker
  • member icon

Reputation: 339
  • View blog
  • Posts: 1,185
  • Joined: 02-April 09

Re: Xampp, Cannot Access Local host

Posted 08 August 2010 - 09:34 AM

Well, not being able to bind to the port is generally straightforward.
Type
netstat -a


into a command line and see if anything in the cruft that fills the screen mentions port 80. If you can't see it, try this top tip:
telnet localhost 80


then hit random keys for a couple of seconds and ENTER. If that says the connection was refused, then your machine genuinely isn't running anything on port 80. If it says anything else, like gives you a bunch of messages essentially saying "what the hell were all those random keys for" then something else is using port 80, and it'll probably give its name there and then.
If your version of Windows doesn't come with telnet, then at this point, well, it sucks to be you.
It's possible Windows 7 does something stupid like not letting you bind to "privileged" ports by default. That would be fun. In that case you'd have to run xampp as administrator or change your apache config to specify a different port to run on. If you set it to 8000, say, then you just browse to http://localhost:8000/my_page.html instead of the plain old localhost you used before. No biggie :)

The other errors about syntax in the configuration file are more worrying, but I can't see that file so don't know if they're the cause or just old messages.
Was This Post Helpful? 0
  • +
  • -

#8 antarr.byrd  Icon User is offline

  • D.I.C Head

Reputation: 6
  • View blog
  • Posts: 247
  • Joined: 30-August 09

Re: Xampp, Cannot Access Local host

Posted 08 August 2010 - 10:05 AM

View Postmoopet, on 08 August 2010 - 08:34 AM, said:

Well, not being able to bind to the port is generally straightforward.
Type
netstat -a


into a command line and see if anything in the cruft that fills the screen mentions port 80. If you can't see it, try this top tip:
telnet localhost 80


then hit random keys for a couple of seconds and ENTER. If that says the connection was refused, then your machine genuinely isn't running anything on port 80. If it says anything else, like gives you a bunch of messages essentially saying "what the hell were all those random keys for" then something else is using port 80, and it'll probably give its name there and then.
If your version of Windows doesn't come with telnet, then at this point, well, it sucks to be you.
It's possible Windows 7 does something stupid like not letting you bind to "privileged" ports by default. That would be fun. In that case you'd have to run xampp as administrator or change your apache config to specify a different port to run on. If you set it to 8000, say, then you just browse to http://localhost:8000/my_page.html instead of the plain old localhost you used before. No biggie :)

The other errors about syntax in the configuration file are more worrying, but I can't see that file so don't know if they're the cause or just old messages.



Active Connections

Proto Local Address Foreign Address State
TCP 0.0.0.0:80 myPC-Pc:0 LISTENING
TCP 0.0.0.0:135 myPC-Pc:0 LISTENING
TCP 0.0.0.0:445 myPC-Pc:0 LISTENING
TCP 0.0.0.0:554 myPC-Pc:0 LISTENING
TCP 0.0.0.0:1025 myPC-Pc:0 LISTENING
TCP 0.0.0.0:1026 myPC-Pc:0 LISTENING
TCP 0.0.0.0:1027 myPC-Pc:0 LISTENING
TCP 0.0.0.0:1028 myPC-Pc:0 LISTENING
TCP 0.0.0.0:1029 myPC-Pc:0 LISTENING
TCP 0.0.0.0:1032 myPC-Pc:0 LISTENING
TCP 0.0.0.0:1433 myPC-Pc:0 LISTENING
TCP 0.0.0.0:2383 myPC-Pc:0 LISTENING
TCP 0.0.0.0:2869 myPC-Pc:0 LISTENING
TCP 0.0.0.0:5357 myPC-Pc:0 LISTENING
TCP 0.0.0.0:10243 myPC-Pc:0 LISTENING
TCP 127.0.0.1:1434 myPC-Pc:0 LISTENING

UDP 127.0.0.1:1900 *:*
UDP 127.0.0.1:51294 *:*
UDP 127.0.0.1:53898 *:*
UDP 127.0.0.1:62586 *:*
UDP 127.0.0.1:62587 *:*

This post has been edited by antarr.byrd: 08 August 2010 - 10:08 AM

Was This Post Helpful? 0
  • +
  • -

#9 moopet  Icon User is offline

  • binary decision maker
  • member icon

Reputation: 339
  • View blog
  • Posts: 1,185
  • Joined: 02-April 09

Re: Xampp, Cannot Access Local host

Posted 08 August 2010 - 10:58 AM

TCP 0.0.0.0:80 myPC-Pc:0 LISTENING

means that something is already using port 80.
Was This Post Helpful? 0
  • +
  • -

#10 antarr.byrd  Icon User is offline

  • D.I.C Head

Reputation: 6
  • View blog
  • Posts: 247
  • Joined: 30-August 09

Re: Xampp, Cannot Access Local host

Posted 08 August 2010 - 11:08 AM

View Postmoopet, on 08 August 2010 - 09:58 AM, said:

TCP 0.0.0.0:80 myPC-Pc:0 LISTENING

means that something is already using port 80.



TCP 0.0.0.0:80 0.0.0.0:0 LISTENING 4

4 shows up as system under taskmanager
Was This Post Helpful? 0
  • +
  • -

#11 no2pencil  Icon User is online

  • Toubabo Koomi
  • member icon

Reputation: 5316
  • View blog
  • Posts: 27,221
  • Joined: 10-May 07

Re: Xampp, Cannot Access Local host

Posted 08 August 2010 - 04:02 PM

View Postantarr.byrd, on 08 August 2010 - 08:53 AM, said:

View Postno2pencil, on 07 August 2010 - 10:59 PM, said:

** Topic moved to Web Servers & Hosting **

If you can ping localhost from the command line (or use nslookup to resolve it), then the host file isn't your issue.

Since you just said you tried to change it, can you tell us what you tried to change it to? What you have there is the default setting.



Well when I checked it, it had something else listed @ 127.0.0.1 , won't say what. Rather not incriminate myself.

Incriminating? Hrm, do you know how frustrating it is to try to help someone troubleshoot their system when they've been fucking with it, doing things they either should or shouldn't be doing, & they don't want to fess up with what they are up to?

If you are doing something you can't admit to what you are up to, then I don't know that we should be helping you get a webserver up & running. It's really as simple as that.
Was This Post Helpful? 0
  • +
  • -

#12 antarr.byrd  Icon User is offline

  • D.I.C Head

Reputation: 6
  • View blog
  • Posts: 247
  • Joined: 30-August 09

Re: Xampp, Cannot Access Local host

Posted 08 August 2010 - 04:57 PM

View Postno2pencil, on 08 August 2010 - 03:02 PM, said:

View Postantarr.byrd, on 08 August 2010 - 08:53 AM, said:

View Postno2pencil, on 07 August 2010 - 10:59 PM, said:

** Topic moved to Web Servers & Hosting **

If you can ping localhost from the command line (or use nslookup to resolve it), then the host file isn't your issue.

Since you just said you tried to change it, can you tell us what you tried to change it to? What you have there is the default setting.



Well when I checked it, it had something else listed @ 127.0.0.1 , won't say what. Rather not incriminate myself.

Incriminating? Hrm, do you know how frustrating it is to try to help someone troubleshoot their system when they've been fucking with it, doing things they either should or shouldn't be doing, & they don't want to fess up with what they are up to?

If you are doing something you can't admit to what you are up to, then I don't know that we should be helping you get a webserver up & running. It's really as simple as that.



Well I got it working, somewhat. Got rid of xaamp, installed wamp. Changed to port 8080 and restarted all process! And don't really see how helping me setup up a "virtual" server enable me to do anything mischievous, but thanks everyone.
Was This Post Helpful? 0
  • +
  • -

#13 no2pencil  Icon User is online

  • Toubabo Koomi
  • member icon

Reputation: 5316
  • View blog
  • Posts: 27,221
  • Joined: 10-May 07

Re: Xampp, Cannot Access Local host

Posted 09 August 2010 - 09:13 AM

All you did was change the listening port. Whatever was running on port 80 most likely still is.

View Postantarr.byrd, on 08 August 2010 - 05:57 PM, said:

And don't really see how helping me setup up a "virtual" server enable me to do anything mischievous

When you are already doing something you don't want to admit to, uhm, asking for more help we can only imagine the worst.

At any rate, glad to see you got it working.
Was This Post Helpful? 0
  • +
  • -

#14 SourLemons  Icon User is offline

  • D.I.C Head

Reputation: 4
  • View blog
  • Posts: 65
  • Joined: 02-August 10

Re: Xampp, Cannot Access Local host

Posted 16 October 2010 - 10:41 AM

Why not try open Port :85 instead of :80 .

If the server PC is for your personal use or daily use, I am 100% guaranteed that you are using a lot of programs which blocks :80.

In short, even your ISP "might have" blocked your :80.
If you are desperate, talk to your ISP, there are 3-4 kind of packages.

Home Premium, Professional, Expertise, Business Edition and more..(or maybe NOT)

If you are using Router, type 192.168.1.1 ( router setup page ).

Open port :85.


And, goto your Xampp\apache\conf\httpd.conf

Search for Listen 80 and replace it with :85 , there are 2 occurrence.

Consult Attachment #2.

If you want to reach your localhost, type http://localhost:85/

So, every web domains or sub domains you create in order to host or either configure requires :85/ in the end.[/color]

For example. I don't run a server myself but I do have a XAMPP and a fake sub domain for local use.

HERE!! It will NOT load if my PC is off, but well ..

If you can't view the website, the pic is attached in order to let you see the sample. x0

_We both being an APACHE and XAMPP user, I would like to suggest you to "PASSWORD" protect your phpmyadmin.

It'll be your Best - Handy tool and also your greatest ENEMY with HUGE FLAW.

Post back if you need something, I'll share anything I know about it.

Attached image(s)

  • Attached Image
  • Attached Image

Was This Post Helpful? 1
  • +
  • -

Page 1 of 1