3 Replies - 5434 Views - Last Post: 30 September 2010 - 07:07 AM Rate Topic: -----

#1 McWarrior  Icon User is offline

  • New D.I.C Head

Reputation: 0
  • View blog
  • Posts: 21
  • Joined: 17-April 09

no cursor in textbox using WPF app

Posted 28 September 2010 - 05:52 AM

Hello,

I have a WPF app that is running in Windows XP classic mode using VS 2008; I have a textbox cursor that works perfectly in Windows XP style mode, but when I switch to XP classic mode the cursor disappear and does appear unless there is text in the textbox. Also I have tested this out in Windows server 2003 and 2008 classic mode and the same problem occurs.

This post has been edited by McWarrior: 28 September 2010 - 05:53 AM

Is This A Good Question/Topic? 0
  • +

Replies To: no cursor in textbox using WPF app

#2 Curtis Rutland  Icon User is online

  • (╯□)╯︵ (~ .o.)~
  • member icon


Reputation: 4431
  • View blog
  • Posts: 7,702
  • Joined: 08-June 10

Re: no cursor in textbox using WPF app

Posted 28 September 2010 - 07:19 AM

I don't think it's disappearing, I think it's blending in to the left border. Try increasing the Padding property on the TextBox.
Was This Post Helpful? 0
  • +
  • -

#3 McWarrior  Icon User is offline

  • New D.I.C Head

Reputation: 0
  • View blog
  • Posts: 21
  • Joined: 17-April 09

Re: no cursor in textbox using WPF app

Posted 28 September 2010 - 07:42 AM

I tried that it didn't work. This is what I have

 Padding="5,0,0,0" 


I put a character in the textbox. "d". I can see the cursor blinking on the right side of the d but when I move the cursor on the left side its disappears. Again this is in Windows XP classic mode.

Right now I have 12 textboxes that have that problem. The thing I am doing now is:

txtTitle.text=" ";
txtTitle.Selectionstart = 1;



And with this I can see the cursor again.

This post has been edited by McWarrior: 28 September 2010 - 11:30 AM

Was This Post Helpful? 0
  • +
  • -

#4 McWarrior  Icon User is offline

  • New D.I.C Head

Reputation: 0
  • View blog
  • Posts: 21
  • Joined: 17-April 09

Re: no cursor in textbox using WPF app

Posted 30 September 2010 - 07:07 AM

ok I couldn't edit previous post so I have to double post.

I solved my issue. It was because my textboxes were HorizontallyAligned to the Left and some had default alignment of center. All I had to do was align them to the right and change the margins. Which I had no idea why it happened in the first place.
Was This Post Helpful? 0
  • +
  • -

Page 1 of 1