2 Replies - 2127 Views - Last Post: 29 January 2011 - 08:12 AM

#1 flint0131  Icon User is offline

  • D.I.C Head

Reputation: 0
  • View blog
  • Posts: 84
  • Joined: 12-January 11

iframe won't display

Posted 28 January 2011 - 12:37 AM

I don't know why this :
<!-- making the border 10 won't give him visibility :(/> -->
<iframe frameborder="10" scrolling="no" width="100%" height="200" name="ava"></iframe>


won't display on my browser, I'm using Firefox and my doctype's
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">


Am I using the wrong one? Is iframe deprecated on this doctype?

Is This A Good Question/Topic? 0
  • +

Replies To: iframe won't display

#2 EnvXOwner  Icon User is offline

  • D.I.C Lover
  • member icon

Reputation: 357
  • View blog
  • Posts: 2,319
  • Joined: 10-August 09

Re: iframe won't display

Posted 28 January 2011 - 01:48 PM

Well, you could try using a transitional doctype like so:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">


You probably messed up you height also. Try setting it to 200px or what ever measurement you're using. :)

This post has been edited by EnvXOwner: 28 January 2011 - 01:48 PM

Was This Post Helpful? 2
  • +
  • -

#3 Glorfindal  Icon User is offline

  • Java Enthusiast
  • member icon

Reputation: 23
  • View blog
  • Posts: 538
  • Joined: 31-December 08

Re: iframe won't display

Posted 29 January 2011 - 08:12 AM

Also it doesn't look like you have a "src" attribute set which in some browsers causes nothing to show.
Was This Post Helpful? 1
  • +
  • -

Page 1 of 1