5 Replies - 1952 Views - Last Post: 28 November 2011 - 05:09 AM Rate Topic: -----

#1 sattua  Icon User is offline

  • D.I.C Head

Reputation: 2
  • View blog
  • Posts: 83
  • Joined: 20-March 08

mail, doesn't work.

Posted 02 August 2011 - 09:02 AM

Hi well I am trying to send emails from my cold fusion, it looks simple to do, but It doesn't send the email, i don't know why.

I guess it's easier to ask to you for some way to get the error I'm committing, I mean, when i try to send the email everything looks ok (no error messages), I pretty sure that the mail info I'm using in the coldfusion admin, it's ok.

So my question is, how do I see if the coldfusion has communication with the mail server.

thanks in advance.

Is This A Good Question/Topic? 0
  • +

Replies To: mail, doesn't work.

#2 Craig328  Icon User is offline

  • I make this look good
  • member icon

Reputation: 1926
  • View blog
  • Posts: 3,471
  • Joined: 13-January 08

Re: mail, doesn't work.

Posted 02 August 2011 - 09:04 AM

sattua, what version of CF are you using and do you have access to the CF admin and the server it resides on?

This post has been edited by Craig328: 02 August 2011 - 09:04 AM

Was This Post Helpful? 0
  • +
  • -

#3 sattua  Icon User is offline

  • D.I.C Head

Reputation: 2
  • View blog
  • Posts: 83
  • Joined: 20-March 08

Re: mail, doesn't work.

Posted 02 August 2011 - 09:09 AM

hi, cf 9, but I'm developing this for a CF 6, and yes i have access to both cf admins and mail server
Was This Post Helpful? 0
  • +
  • -

#4 Craig328  Icon User is offline

  • I make this look good
  • member icon

Reputation: 1926
  • View blog
  • Posts: 3,471
  • Joined: 13-January 08

Re: mail, doesn't work.

Posted 02 August 2011 - 09:17 AM

Okay. You'll need to log in to your CF administrator and click on Mail under Server Settings (in CF9).

You'll want to make sure your mail server settings, port and password are all correct. If they are, you'll want to check your Mail Spool settings. Your spool interval should default to 15 seconds (how often the CF server sends accumulated emails to the email server) and make sure your "Spool messages for delivery" is checked. You should also have a button entitled View Undelivered Mail. Check that to see if your messages made it to the spool (and didn't error).

In addition, consider looking at your Mail Logging Settings and set them appropriately to log all mail messages and make sure they'd be logging errors. You can see your mail.log file under Debugging & Logging/Log Files.

Check through all of that and you should get a hint as to what's going wrong.
Was This Post Helpful? 1
  • +
  • -

#5 sattua  Icon User is offline

  • D.I.C Head

Reputation: 2
  • View blog
  • Posts: 83
  • Joined: 20-March 08

Re: mail, doesn't work.

Posted 02 August 2011 - 09:51 AM

Craig328 thanks, very useful
Was This Post Helpful? 0
  • +
  • -

#6 advinsteven  Icon User is offline

  • New D.I.C Head

Reputation: 0
  • View blog
  • Posts: 5
  • Joined: 08-August 11

Re: mail, doesn't work.

Posted 28 November 2011 - 05:09 AM

i really need to use my email today. please can we fix this??
Was This Post Helpful? 0
  • +
  • -

Page 1 of 1