4 Replies - 769 Views - Last Post: 02 November 2011 - 04:15 PM

#1 Rhymer  Icon User is offline

  • D.I.C Regular

Reputation: 23
  • View blog
  • Posts: 282
  • Joined: 21-April 09

W7/XP compatibility and VB6.0

Posted 28 October 2011 - 12:58 PM

I have a Learning Edition of VB6 installed on work XP machine and home W7 machine.

Over time, updates have changed the XP installation.
I can no longer create Package Deployment on the XP although I can make Exe's.

Over time, updates have changed the W7 installation.
Such as fonts are displayed in their own font in the font listing (W7).
Any deployment I can make will not finish install on XP.
I heard there were COM/OLE DLL issues.
Any Exe made from W7 will not run on XP unless it had VB6 IDE installed.

Identical code when compiled in XP will run on XP and W7.
Identical code when compiled in W7 will run only on W7.

Does anyone have a suggestion to this dilemma? (Other than going to Express versions)


Is This A Good Question/Topic? 0
  • +

Replies To: W7/XP compatibility and VB6.0

#2 AdamSpeight2008  Icon User is online

  • MrCupOfT
  • member icon


Reputation: 2257
  • View blog
  • Posts: 9,447
  • Joined: 29-May 08

Re: W7/XP compatibility and VB6.0

Posted 28 October 2011 - 01:21 PM

It's time to move on to .net, vb6's support is dying.

Maybe you are hard coding path.
Was This Post Helpful? 1
  • +
  • -

#3 Shane Hudson  Icon User is offline

  • D.I.C Technophile
  • member icon

Reputation: 343
  • View blog
  • Posts: 1,286
  • Joined: 06-December 09

Re: W7/XP compatibility and VB6.0

Posted 29 October 2011 - 04:54 AM

I agree with Adam, .net is nearly a decade old now (if not already)... VB6 was a horrid language then and it still is now. The difference now is that it is barely supported. I am not a fan of vb.net but if you want to do VB, you really should start writing in vb.net!
Was This Post Helpful? 0
  • +
  • -

#4 Rhymer  Icon User is offline

  • D.I.C Regular

Reputation: 23
  • View blog
  • Posts: 282
  • Joined: 21-April 09

Re: W7/XP compatibility and VB6.0

Posted 01 November 2011 - 12:42 PM

Well, since it didn't cost me anything (I got it from work), it looks like I will have to move on to the newer platform. Is 'Express' the same as .net? I tried the Express 2008? but I'm so stuck in my ways the IDE/command set just was kind of foreign. This dog will have to learn a new trick.
Was This Post Helpful? 0
  • +
  • -

#5 MATTtheSEAHAWK  Icon User is offline

  • D.I.C Addict
  • member icon

Reputation: 137
  • View blog
  • Posts: 782
  • Joined: 11-September 10

Re: W7/XP compatibility and VB6.0

Posted 02 November 2011 - 04:15 PM

Well express is just the edition of the IDE you use. And it and .Net are two totally different things. .Net is the framework and express is what I just said. But yes, you should DEFINITELY move to .Net.
Was This Post Helpful? 0
  • +
  • -

Page 1 of 1