DIC inserting bold tags into URL

Page 1 of 1

6 Replies - 1137 Views - Last Post: 17 January 2012 - 11:25 AM

#1 Frinavale  Icon User is offline

  • D.I.C Addict
  • member icon

Reputation: 203
  • View blog
  • Posts: 776
  • Joined: 03-June 10

DIC inserting bold tags into URL

Posted 13 January 2012 - 09:47 AM

I posted a link to some MSDN documentation on a class as a reference to support my answer in a thread and was surprised when the OP commented that the link didn't work. Upon looking into the problem I noticed that DIC is entering bold HTML tags into the URL which is making the link invalid.

Here is the post where I created the link to the documentation:

It's post #5 in original thread

The link that I was trying to post was to the BindingExpression Class.
This is the link (in it's correct form):
http://msdn.microsoft.com /en-us/library/system.windows.data.bindingexpression%28v=VS.85%29.aspx

This is the resulting link:
http://msdn.microsoft.com/en-us/library/system.windows.data.bindingexpression%28v=VS.85%29.aspx


The actual link as it is modified by DIC:
Link Example

-Frinny

This post has been edited by Frinavale: 13 January 2012 - 12:52 PM


Is This A Good Question/Topic? 0
  • +

Replies To: DIC inserting bold tags into URL

#2 smohd  Icon User is offline

  • Critical Section
  • member icon


Reputation: 1820
  • View blog
  • Posts: 4,627
  • Joined: 14-March 10

Re: DIC inserting bold tags into URL

Posted 13 January 2012 - 09:59 AM

That is the known bug, in the word expression it enters those tags, I think there is no available solution by now but user can copy that link to a browser and remove those entered tags by himself
Was This Post Helpful? 0
  • +
  • -

#3 Curtis Rutland  Icon User is offline

  • (╯□)╯︵ (~ .o.)~
  • member icon


Reputation: 4577
  • View blog
  • Posts: 8,019
  • Joined: 08-June 10

Re: DIC inserting bold tags into URL

Posted 13 January 2012 - 10:29 AM

That's correct. It injects it into all instances of "expression", you just don't see most of it because it's invisible in HTML. Unfortunately, it shows up in <pre> blocks and URLs. There is no known fix for this at the time, but it is a well-known issue.
Was This Post Helpful? 0
  • +
  • -

#4 Frinavale  Icon User is offline

  • D.I.C Addict
  • member icon

Reputation: 203
  • View blog
  • Posts: 776
  • Joined: 03-June 10

Re: DIC inserting bold tags into URL

Posted 13 January 2012 - 12:50 PM

Thanks :)
Was This Post Helpful? 0
  • +
  • -

#5 #define  Icon User is offline

  • Duke of Err
  • member icon

Reputation: 1432
  • View blog
  • Posts: 4,968
  • Joined: 19-February 09

Re: DIC inserting bold tags into URL

Posted 13 January 2012 - 06:57 PM

Substuting %70 for p.

BindingExpression Class Documentation.
Was This Post Helpful? 1
  • +
  • -

#6 Frinavale  Icon User is offline

  • D.I.C Addict
  • member icon

Reputation: 203
  • View blog
  • Posts: 776
  • Joined: 03-June 10

Re: DIC inserting bold tags into URL

Posted 17 January 2012 - 11:10 AM

Thanks for the advise #define :)
Was This Post Helpful? 0
  • +
  • -

#7 skyhawk133  Icon User is offline

  • Head DIC Head
  • member icon

Reputation: 1877
  • View blog
  • Posts: 20,284
  • Joined: 17-March 01

Re: DIC inserting bold tags into URL

Posted 17 January 2012 - 11:25 AM

This is one of those bugs that I've had a TON of people look in to. Server side, software side, everything I can think of and it's probably some weird ass line of code burried in the forum software that nobody can find.
Was This Post Helpful? 0
  • +
  • -

Page 1 of 1