2 Replies - 2252 Views - Last Post: 21 January 2012 - 10:01 PM

#1 thatgoogleguy  Icon User is offline

  • D.I.C Head

Reputation: 1
  • View blog
  • Posts: 76
  • Joined: 26-May 11

suexec policy violation 500 error?

Posted 20 January 2012 - 08:41 AM

I randomly received a 500 error:

Quote

The server encountered an unexpected condition which prevented it from fulfilling the request.
The script had an error or it did not produce any output. If there was an error, you should be able to see it in the error log.

The hosting provider is Bizland (horrible) I'm the web developer for a client and have never received this message. Anyone know how to fix this? I was told it was a permission error, but all my permissions are properly set. Majority are set to 755/644. I'm running Joomla! 1.5.25

Is This A Good Question/Topic? 0
  • +

Replies To: suexec policy violation 500 error?

#2 Lemur  Icon User is offline

  • Pragmatism over Dogma
  • member icon


Reputation: 1383
  • View blog
  • Posts: 3,515
  • Joined: 28-November 09

Re: suexec policy violation 500 error?

Posted 20 January 2012 - 04:32 PM

Remember what permissions actually are now. You may have a script that needs execution that you have a 644 on.

Now, let's take a look at the basics of permissions. Each number corresponds to Owner, Group, and World. They are all binary triplets, like so:
----RWX
O - 000
G - 000
W - 000

000 - None (0)
001 - Execute Only (1)
010 - Write Only (2)
011 - Write and Execute (3)
100 - Read Only (4)
101 - Read and Execute (5)
110 - Read and Write (6)
111 - All (7)

Now, a 4 would be read only and a 5 would be read and execute. Make SURE your permissions are correct, especially on directories which always need to be executable on *nix platforms.
Was This Post Helpful? 0
  • +
  • -

#3 thatgoogleguy  Icon User is offline

  • D.I.C Head

Reputation: 1
  • View blog
  • Posts: 76
  • Joined: 26-May 11

Re: suexec policy violation 500 error?

Posted 21 January 2012 - 10:01 PM

It seems that my host disabled my CGI support due to mail abuse for sending out a large number of newsletters. I've since used cron to delay the sending of bulk mail. After a short discussion with a support specialist things were cleared up. If you're having this problem I suggest checking your file permissions or talking with your hosting provider.
Was This Post Helpful? 0
  • +
  • -

Page 1 of 1