6 Replies - 869 Views - Last Post: 31 March 2012 - 10:24 PM Rate Topic: -----

#1 MansoorBaig  Icon User is offline

  • New D.I.C Head

Reputation: 0
  • View blog
  • Posts: 1
  • Joined: 29-March 12

Hi, I am a newbie in learning VB6.

Posted 29 March 2012 - 10:12 AM

Hi, I feel someone can help me.
I am using vb6, in windows 7, 64 bit.

I find that every control i use on form doesnt drag with mouse smoothly ?
Such as button, text box, etc.

Could anyone help ?
Is This A Good Question/Topic? 0
  • +

Replies To: Hi, I am a newbie in learning VB6.

#2 Martyr2  Icon User is offline

  • Programming Theoretician
  • member icon

Reputation: 4332
  • View blog
  • Posts: 12,127
  • Joined: 18-April 07

Re: Hi, I am a newbie in learning VB6.

Posted 29 March 2012 - 02:49 PM

Welcome to Dream.In.Code MansoorBaig! I think you may want to be asking this question in the VB6 forum. So I have moved it there.

As for your question, the reason it may not be "smooth" is because you have the "Snap to grid" feature on? This causes all elements you drag to snap to a layout grid on the form. This causes a slightly "choppy" type of movement as it is snapping to various points as you drag/resize the control.

The feature can be controlled under Tools > Options >General Tab > uncheck 'Align controls to grid'.

:)
Was This Post Helpful? 0
  • +
  • -

#3 BobRodes  Icon User is offline

  • Your Friendly Local Curmudgeon
  • member icon

Reputation: 574
  • View blog
  • Posts: 2,989
  • Joined: 19-May 09

Re: Hi, I am a newbie in learning VB6.

Posted 29 March 2012 - 03:00 PM

That's one of the things. The other is that using VB6 with Windows 7 causes the screen to refresh really slowly when you're dragging controls around, so it's hard to position them on the screen. Microsoft probably did this on purpose. :)
Was This Post Helpful? 0
  • +
  • -

#4 maj3091  Icon User is offline

  • D.I.C Lover
  • member icon

Reputation: 300
  • View blog
  • Posts: 1,771
  • Joined: 26-March 09

Re: Hi, I am a newbie in learning VB6.

Posted 29 March 2012 - 11:29 PM

You can get around this on win7 by doing the following.

Find the VB6.exe file and right-click and select properties.

Select the Compatibility tab.

Set compatibility mode to Window XP SP3.

Check: Disable Visual Themes, Disable Desktop Composition, Disable Display Scaling on high DPI Settings.

If you do that, you will find it's smooth again.
Was This Post Helpful? 0
  • +
  • -

#5 BobRodes  Icon User is offline

  • Your Friendly Local Curmudgeon
  • member icon

Reputation: 574
  • View blog
  • Posts: 2,989
  • Joined: 19-May 09

Re: Hi, I am a newbie in learning VB6.

Posted 30 March 2012 - 07:57 AM

I'm gonna try that when I get home, maj.
Was This Post Helpful? 0
  • +
  • -

#6 maj3091  Icon User is offline

  • D.I.C Lover
  • member icon

Reputation: 300
  • View blog
  • Posts: 1,771
  • Joined: 26-March 09

Re: Hi, I am a newbie in learning VB6.

Posted 31 March 2012 - 02:24 AM

Let me know if it works for you! :)
Was This Post Helpful? 0
  • +
  • -

#7 KabaloKaNe  Icon User is offline

  • New D.I.C Head

Reputation: 0
  • View blog
  • Posts: 4
  • Joined: 29-March 12

Re: Hi, I am a newbie in learning VB6.

Posted 31 March 2012 - 10:24 PM

View Postmaj3091, on 29 March 2012 - 11:29 PM, said:

You can get around this on win7 by doing the following.

Find the VB6.exe file and right-click and select properties.

Select the Compatibility tab.

Set compatibility mode to Window XP SP3.

Check: Disable Visual Themes, Disable Desktop Composition, Disable Display Scaling on high DPI Settings.

If you do that, you will find it's smooth again.


Thanks. That solved the lag problem.
Was This Post Helpful? 0
  • +
  • -

Page 1 of 1