1 Replies - 374 Views - Last Post: 05 June 2012 - 07:16 AM Rate Topic: -----

#1 nK0de  Icon User is offline

  • Catch me As Exception
  • member icon

Reputation: 205
  • View blog
  • Posts: 823
  • Joined: 21-December 11

Cannot log in to phpMyAdmin even after configuration

Posted 05 June 2012 - 06:25 AM

I just set up WAMP server again after formatting my PC recently. My port 80 was already in use so I changed the following lines in the Apache's httpd.conf file to make use of the port number 8080.

Posted Image

Then I changed MySQL's root password to abc123 using the MySQL console. Everything is fine up to this point.

Then I configured the phpMyAdmin's setup script (config.inc file) as follows (through the browser using the GUI). And I saved the configurations.

<?php
/*
 * Generated configuration file
 * Generated by: phpMyAdmin 3.4.10.1 setup script
 * Date: Tue, 05 Jun 2012 12:42:11 +0000
 */

/* Servers configuration */
$i = 0;

/* Server: localhost [1] */
$i++;
$cfg['Servers'][$i]['verbose'] = '';
$cfg['Servers'][$i]['host'] = 'localhost';
$cfg['Servers'][$i]['port'] = 8080;
$cfg['Servers'][$i]['socket'] = '';
$cfg['Servers'][$i]['connect_type'] = 'tcp';
$cfg['Servers'][$i]['extension'] = 'mysqli';
$cfg['Servers'][$i]['auth_type'] = 'cookie';
$cfg['Servers'][$i]['user'] = 'root';
$cfg['Servers'][$i]['password'] = 'abc123';

/* End of servers configuration */

$cfg['blowfish_secret'] = '4fcdfe94a0e6c7.79135356';
$cfg['DefaultLang'] = 'en';
$cfg['ServerDefault'] = 1;
$cfg['UploadDir'] = '';
$cfg['SaveDir'] = '';
?>



But still I can't log in to phpMyAdmin even when I give the correct user credentials. It doesn't give me any error messages. Just takes a really long time loading and goes to a blank page with a URL like this.
http://localhost:808...8c2ed12a9c4e61f

I don't know what else to do. Is there a step I'm missing out on? Any help/suggestion would be greatly appreciated.

Thank you.

This post has been edited by nK0de: 05 June 2012 - 06:26 AM


Is This A Good Question/Topic? 0
  • +

Replies To: Cannot log in to phpMyAdmin even after configuration

#2 nK0de  Icon User is offline

  • Catch me As Exception
  • member icon

Reputation: 205
  • View blog
  • Posts: 823
  • Joined: 21-December 11

Re: Cannot log in to phpMyAdmin even after configuration

Posted 05 June 2012 - 07:16 AM

Got it! The port number here $cfg['Servers'][$i]['port'] = 8080; is not the port for the localhost. It is the MySQL's port number. Which should be left blank as the default setting. I didn' know that before. Everything's working fine now.
Was This Post Helpful? 0
  • +
  • -

Page 1 of 1