app_code class not defined on production server

My app_code class work on developement but not on production server

Page 1 of 1

1 Replies - 6519 Views - Last Post: 24 May 2007 - 05:43 AM Rate Topic: -----

#1 petermitch  Icon User is offline

  • New D.I.C Head

Reputation: 0
  • View blog
  • Posts: 2
  • Joined: 24-May 07

app_code class not defined on production server

Posted 24 May 2007 - 03:03 AM

I have developed an application using Visual Web Developer 2005 Express Edition. There is some shared code in a Class1.vb file in the app_code directory in a class called 'clsGSFW'. This works fine in the developement environment but when I ftp the site to the production server and run it I get 'Type 'clsGSFW' is not defined' when the declaration code 'Dim cs As New clsGSFW' is encountered.

The server is running the rest of the application OK and I can't find any reference to such a problem in MSDN.

Any ideas?

Is This A Good Question/Topic? 0
  • +

Replies To: app_code class not defined on production server

#2 petermitch  Icon User is offline

  • New D.I.C Head

Reputation: 0
  • View blog
  • Posts: 2
  • Joined: 24-May 07

Re: app_code class not defined on production server

Posted 24 May 2007 - 05:43 AM

Sorted it. while the server has .Net 2 installed and running the application was set to use 1.1 in IIS.

Easy really.

Regards

Peter


View Postpetermitch, on 24 May, 2007 - 03:03 AM, said:

I have developed an application using Visual Web Developer 2005 Express Edition. There is some shared code in a Class1.vb file in the app_code directory in a class called 'clsGSFW'. This works fine in the developement environment but when I ftp the site to the production server and run it I get 'Type 'clsGSFW' is not defined' when the declaration code 'Dim cs As New clsGSFW' is encountered.

The server is running the rest of the application OK and I can't find any reference to such a problem in MSDN.

Any ideas?

Was This Post Helpful? 0
  • +
  • -

Page 1 of 1