4 Replies - 626 Views - Last Post: 28 August 2012 - 06:49 PM

#1 portfoliobuilder  Icon User is offline

  • New D.I.C Head

Reputation: 0
  • View blog
  • Posts: 4
  • Joined: 28-August 12

Developed application not displaying feeds

Posted 28 August 2012 - 03:17 PM

I followed the tutorial at http://www.ingeniumb...der-in-android/ to make a RSS Reader for Android. The tutorial works, but I want to feed articles from another website whose tutorials I am starting to get into. All I did was change the feed address in the "xmlparsemain.java" file to the feed address of the site I want to follow articles from. This does not cause any errors in the app, but the app does not display the articles from the site I am trying to follow. Any idea of what I am missing? This is both a for fun app, and a learning app for me. I just began Android development.

I attached the project so that you can see what I mean. If you change the feed site URL back to "http:feeds.feedburner.com/theappleblog" the application works. But I do not want these articles to come through.Attached File  RssFeedReader.zip (96.42K)
Number of downloads: 32

Is This A Good Question/Topic? 0
  • +

Replies To: Developed application not displaying feeds

#2 Mina-no-Hime  Icon User is offline

  • D.I.C Head

Reputation: 98
  • View blog
  • Posts: 176
  • Joined: 23-August 12

Re: Developed application not displaying feeds

Posted 28 August 2012 - 05:12 PM

I'm fairly certain that the problem lies with the feed you are attempting to read. It doesn't seem to be a properly-formatted RSS XML document.

Compare the two by looking at the source at the two addresses:
http://feeds.feedbur...om/theappleblog <-- Properly-formatted RSS XML document
http://feeds.feedbur...eAppDevelopment <-- Not.
Was This Post Helpful? 0
  • +
  • -

#3 portfoliobuilder  Icon User is offline

  • New D.I.C Head

Reputation: 0
  • View blog
  • Posts: 4
  • Joined: 28-August 12

Re: Developed application not displaying feeds

Posted 28 August 2012 - 05:40 PM

If this is the case, my next question is how do I get the correct feed address to the mobile blog I want to follow? The one I get from the RSS subscription is the one I posted (Feed Link).

Or are you telling me this is not in my control? I would have to tell the site developer to change his feed format?
Was This Post Helpful? 0
  • +
  • -

#4 portfoliobuilder  Icon User is offline

  • New D.I.C Head

Reputation: 0
  • View blog
  • Posts: 4
  • Joined: 28-August 12

Re: Developed application not displaying feeds

Posted 28 August 2012 - 06:16 PM

Problem solved, thank you!
Was This Post Helpful? 0
  • +
  • -

#5 macosxnerd101  Icon User is online

  • Self-Trained Economist
  • member icon




Reputation: 10780
  • View blog
  • Posts: 40,141
  • Joined: 27-December 08

Re: Developed application not displaying feeds

Posted 28 August 2012 - 06:49 PM

Moved to Android.
Was This Post Helpful? 0
  • +
  • -

Page 1 of 1