2 Replies - 265 Views - Last Post: 28 September 2012 - 01:32 PM

#1 PixelBit  Icon User is offline

  • D.I.C Head

Reputation: 6
  • View blog
  • Posts: 233
  • Joined: 17-July 11

WordPress completely destroys layout, for no apparent reason. [SOLVED]

Posted 28 September 2012 - 12:37 PM

Ok so I coded a website in html and css, go to convert it to a wordpress them, the ONLY thing I changed was the linking to the stylesheet through wordpress (I didn't even split it up into header footer and content) and it completely blew up on me. From this: http://jamalantonio....dpress/test.php to this: http://jamalantonio....ting/wordpress/

I have no idea why this is happening, there is no reason that I see for it. I mean, it is finding the style sheet as it is styles, just somethings are broken. Any help?

Cheers,
Jamal.

This post has been edited by PixelBit: 28 September 2012 - 01:50 PM


Is This A Good Question/Topic? 0
  • +

Replies To: WordPress completely destroys layout, for no apparent reason. [SOLVED]

#2 Atli  Icon User is offline

  • D.I.C Lover
  • member icon

Reputation: 3718
  • View blog
  • Posts: 5,989
  • Joined: 08-June 10

Re: WordPress completely destroys layout, for no apparent reason. [SOLVED]

Posted 28 September 2012 - 01:07 PM

The URL to the stylesheet, as it is in the page you linked to, is:

http://localhost/tes...press/style.css

Note the "localhost" part. That certainly won't work on a live page.


Also, going over other resources in the page, the URLs for most of them are broken.
Was This Post Helpful? 0
  • +
  • -

#3 PixelBit  Icon User is offline

  • D.I.C Head

Reputation: 6
  • View blog
  • Posts: 233
  • Joined: 17-July 11

Re: WordPress completely destroys layout, for no apparent reason. [SOLVED]

Posted 28 September 2012 - 01:32 PM

View PostAtli, on 28 September 2012 - 01:07 PM, said:

The URL to the stylesheet, as it is in the page you linked to, is:

http://localhost/tes...press/style.css

Note the "localhost" part. That certainly won't work on a live page.


Also, going over other resources in the page, the URLs for most of them are broken.


Hmmm, the url for it is set automatically by wordpress. Also nothing else was changed the urls haven't changed, so I don't know why they would just break. So can you see any styling on the wordpress page? For me it styles everything except the whole header is broken for some bizarre reason, even the nav is gone, and the slider is broken.

OK, fixed it apparently wp requires you to put <?php echo get_template_directory_uri(); ?>/ in front of all the paths to files, it doesn't go to the url that the file is in by default or something...

This post has been edited by PixelBit: 28 September 2012 - 01:50 PM

Was This Post Helpful? 0
  • +
  • -

Page 1 of 1