4 Replies - 1566 Views - Last Post: 03 October 2012 - 06:57 PM

#1 Tanrou  Icon User is offline

  • New D.I.C Head

Reputation: 0
  • View blog
  • Posts: 6
  • Joined: 30-September 12

Simple form issue

Posted 02 October 2012 - 05:08 PM

<html>
 <form action="mainprogram.php" method="post">
Please define your modifer below.<br>
If you want a negative modifier, type a "-" before your modifer.<br>
 Amount: <input type="text" name="modifier"><br>
 <input type="submit"  name="submitmodifier">
 </form>
</html>



That code snippet for some reason won't pass along the value of modifier to mainprogram.php. It was working previously and cease working for an unkown reason. Any suggestions? I made sure the problem was with this and not mainprogram.php by switching the method from post to get and checking the URL bar.

Thanks!

Is This A Good Question/Topic? 0
  • +

Replies To: Simple form issue

#2 Bort  Icon User is offline

  • Ill-informed Mongoloid
  • member icon

Reputation: 414
  • View blog
  • Posts: 3,023
  • Joined: 18-September 06

Re: Simple form issue

Posted 03 October 2012 - 02:57 AM

Should the <br>'s not be <br /> ?
Was This Post Helpful? 0
  • +
  • -

#3 Tanrou  Icon User is offline

  • New D.I.C Head

Reputation: 0
  • View blog
  • Posts: 6
  • Joined: 30-September 12

Re: Simple form issue

Posted 03 October 2012 - 08:16 AM

View PostBort, on 03 October 2012 - 02:57 AM, said:

Should the <br>'s not be <br /> ?


No, the <br> is acceptable in HTML5. It might be a bit deprecated.
Was This Post Helpful? 0
  • +
  • -

#4 Utael  Icon User is offline

  • D.I.C Head

Reputation: 55
  • View blog
  • Posts: 210
  • Joined: 12-December 11

Re: Simple form issue

Posted 03 October 2012 - 01:18 PM

Throw it into w3c and see what it says.

This post has been edited by Dormilich: 03 October 2012 - 10:59 PM

Was This Post Helpful? 0
  • +
  • -

#5 Tanrou  Icon User is offline

  • New D.I.C Head

Reputation: 0
  • View blog
  • Posts: 6
  • Joined: 30-September 12

Re: Simple form issue

Posted 03 October 2012 - 06:57 PM

This, for unkown reasons and without any edits, began working again today. Thanks for the replies!
Was This Post Helpful? 0
  • +
  • -

Page 1 of 1