12 Replies - 7765 Views - Last Post: 10 December 2012 - 08:53 PM

#1 hwoarang69  Icon User is offline

  • D.I.C Head

Reputation: -1
  • View blog
  • Posts: 171
  • Joined: 23-October 12

xampp apache wont start

Posted 09 December 2012 - 09:24 PM

i just download xampp control panel v3.1.3 3.1.0. i run it as admin and it open. but when i click start apache, it crashes and give me errors:
[EXCEPTION] Access violation at address 005ABEFE in module xampp-control.exe Read of address 00000042.


than, a window pop up with another error:

exception EAccessViolation in module xampp-control.exe at 001ABEFE. Access violation at adress 005ABEFE in module 'xampp-control.exe'. read of adress 00000042.


i have not idea what to do.

i uploaded a screen shot too.

Attached image(s)

  • Attached Image


Is This A Good Question/Topic? 0
  • +

Replies To: xampp apache wont start

#2 raghav.naganathan  Icon User is offline

  • Perfectly Squared ;)
  • member icon

Reputation: 408
  • View blog
  • Posts: 1,440
  • Joined: 14-September 12

Re: xampp apache wont start

Posted 09 December 2012 - 09:58 PM

Well, that is probably because you aren't running the control panel with admin privileges.

regards,
Raghav
Was This Post Helpful? 1
  • +
  • -

#3 hwoarang69  Icon User is offline

  • D.I.C Head

Reputation: -1
  • View blog
  • Posts: 171
  • Joined: 23-October 12

Re: xampp apache wont start

Posted 09 December 2012 - 10:13 PM

is "admin privileges" when you right click and click "run as admin"? if yes, than i am.

also i was search and they were talking about config.ini.php. so i looked it up online but it same as what they have online.



config.ini.php

<?php
/*
 * This is needed for cookie based authentication to encrypt password in
 * cookie
 */
$cfg['blowfish_secret'] = 'xampp'; /* YOU SHOULD CHANGE THIS FOR A MORE SECURE COOKIE AUTH! */

/*
 * Servers configuration
 */
$i = 0;

/*
 * First server
 */
$i++;

/* Authentication type and info */
$cfg['Servers'][$i]['auth_type'] = 'config';
$cfg['Servers'][$i]['user'] = 'root';
$cfg['Servers'][$i]['password'] = '';
$cfg['Servers'][$i]['extension'] = 'mysql';
$cfg['Servers'][$i]['AllowNoPassword'] = true;
$cfg['Lang'] = '';

/* Bind to the localhost ipv4 address and tcp */
$cfg['Servers'][$i]['host'] = '127.0.0.1';
$cfg['Servers'][$i]['connect_type'] = 'tcp';

/* User for advanced features */
$cfg['Servers'][$i]['controluser'] = 'pma';
$cfg['Servers'][$i]['controlpass'] = '';

/* Advanced phpMyAdmin features */
$cfg['Servers'][$i]['pmadb'] = 'phpmyadmin';
$cfg['Servers'][$i]['bookmarktable'] = 'pma_bookmark';
$cfg['Servers'][$i]['relation'] = 'pma_relation';
$cfg['Servers'][$i]['table_info'] = 'pma_table_info';
$cfg['Servers'][$i]['table_coords'] = 'pma_table_coords';
$cfg['Servers'][$i]['pdf_pages'] = 'pma_pdf_pages';
$cfg['Servers'][$i]['column_info'] = 'pma_column_info';
$cfg['Servers'][$i]['history'] = 'pma_history';
$cfg['Servers'][$i]['designer_coords'] = 'pma_designer_coords';
$cfg['Servers'][$i]['tracking'] = 'pma_tracking';
$cfg['Servers'][$i]['userconfig'] = 'pma_userconfig';
$cfg['Servers'][$i]['recent'] = 'pma_recent';
$cfg['Servers'][$i]['table_uiprefs'] = 'pma_table_uiprefs';

/*
 * End of servers configuration
 */

?>

This post has been edited by hwoarang69: 09 December 2012 - 10:17 PM

Was This Post Helpful? 0
  • +
  • -

#4 raghav.naganathan  Icon User is offline

  • Perfectly Squared ;)
  • member icon

Reputation: 408
  • View blog
  • Posts: 1,440
  • Joined: 14-September 12

Re: xampp apache wont start

Posted 09 December 2012 - 10:18 PM

Ok, now once you click on start in apache, go to your browser and type localhost/

regards,
Raghav
Was This Post Helpful? 1
  • +
  • -

#5 hwoarang69  Icon User is offline

  • D.I.C Head

Reputation: -1
  • View blog
  • Posts: 171
  • Joined: 23-October 12

Re: xampp apache wont start

Posted 09 December 2012 - 10:20 PM

if i click apache the xampp control panel crashes and it doesnt start. so i cant go to localhost/. it just say:

Oops! Google Chrome could not connect to localhost
Was This Post Helpful? 0
  • +
  • -

#6 raghav.naganathan  Icon User is offline

  • Perfectly Squared ;)
  • member icon

Reputation: 408
  • View blog
  • Posts: 1,440
  • Joined: 14-September 12

Re: xampp apache wont start

Posted 09 December 2012 - 10:31 PM

Well, what is the port number that you are using for connecting to apache?

regards,
Raghav
Was This Post Helpful? 1
  • +
  • -

#7 hwoarang69  Icon User is offline

  • D.I.C Head

Reputation: -1
  • View blog
  • Posts: 171
  • Joined: 23-October 12

Re: xampp apache wont start

Posted 09 December 2012 - 10:39 PM

iam not 100% sure how to check but i went to:
xampp/apache/conf/httpd.conf

than searched listen:
and i got this:

#Listen 0.0.0.0:80
#Listen [::]:80
Listen 80

Was This Post Helpful? 0
  • +
  • -

#8 raghav.naganathan  Icon User is offline

  • Perfectly Squared ;)
  • member icon

Reputation: 408
  • View blog
  • Posts: 1,440
  • Joined: 14-September 12

Re: xampp apache wont start

Posted 09 December 2012 - 10:58 PM

Ok, so your port is correct...basically port 80 is for web servers. Are you sure you are not running IIS on the same port?

regards,
Raghav
Was This Post Helpful? 1
  • +
  • -

#9 hwoarang69  Icon User is offline

  • D.I.C Head

Reputation: -1
  • View blog
  • Posts: 171
  • Joined: 23-October 12

Re: xampp apache wont start

Posted 09 December 2012 - 11:07 PM

do you know how can i check if iam running IIS on same port?

i tried typing this in web:

http://localhost:80

and i got nothing

This post has been edited by hwoarang69: 09 December 2012 - 11:09 PM

Was This Post Helpful? 0
  • +
  • -

#10 hwoarang69  Icon User is offline

  • D.I.C Head

Reputation: -1
  • View blog
  • Posts: 171
  • Joined: 23-October 12

Re: xampp apache wont start

Posted 09 December 2012 - 11:14 PM

ok i have not idea what happened but its working now.
Was This Post Helpful? 0
  • +
  • -

#11 raghav.naganathan  Icon User is offline

  • Perfectly Squared ;)
  • member icon

Reputation: 408
  • View blog
  • Posts: 1,440
  • Joined: 14-September 12

Re: xampp apache wont start

Posted 09 December 2012 - 11:17 PM

Well, I shall tell you how to do that.

First,go to the comand line prompt and enter the command:

netstat -o -n -a

You'll get a somewhat long list of numbers. In that list, you need to look for the entry under "local address" for either 0.0.0.0:80 or 127.0.0.1:80

regards,
Raghav
Was This Post Helpful? 1
  • +
  • -

#12 hwoarang69  Icon User is offline

  • D.I.C Head

Reputation: -1
  • View blog
  • Posts: 171
  • Joined: 23-October 12

Re: xampp apache wont start

Posted 10 December 2012 - 01:27 PM

thanks alot for the help
Was This Post Helpful? 0
  • +
  • -

#13 raghav.naganathan  Icon User is offline

  • Perfectly Squared ;)
  • member icon

Reputation: 408
  • View blog
  • Posts: 1,440
  • Joined: 14-September 12

Re: xampp apache wont start

Posted 10 December 2012 - 08:53 PM

Most welcome...glad you could solve your problem :)

regards,
Raghav
Was This Post Helpful? 0
  • +
  • -

Page 1 of 1