9 Replies - 1247 Views - Last Post: 12 January 2013 - 12:56 PM

#1 Dictator_Rich  Icon User is offline

  • New D.I.C Head

Reputation: 0
  • View blog
  • Posts: 21
  • Joined: 29-March 12

I cannot locate my app when I compile it with the andrioid emulator.

Posted 11 January 2013 - 01:27 PM

I am teaching myself how to make Android apps using Eclipse (Java EE IDE). I've pretty much been following this guy's tutorial: http://www.youtube.c...arO-mw&index=10 (feel free to recommend me a better tutorial if you have one in mind). So far, everything was going good until I tried to compile the program. Now, the emulator (or android virtual device, whatever you wanna call it) works just fine. However, I can't seem to locate my app anywhere. When I click on the circle (mine does look a bit different than the one in the tutorial), it takes me to a screen with a bunch of apps, but I don't see mine. I know that the app is somewhere in the emulator, because it says this on the console (the name of the app is "yo". It's just a hello world program with 2 buttons that don't do anything):

[2013-01-11 15:04:29 - yo] Uploading yo.apk onto device 'emulator-5554'
[2013-01-11 15:04:29 - yo] Installing yo.apk...
[2013-01-11 15:06:19 - yo] Success!
[2013-01-11 15:06:19 - yo] \yo\bin\yo.apk installed on device
[2013-01-11 15:06:19 - yo] Done!

Also, I set it up so that it runs on lower versions of Andriod, despite the fact that I'm using 4.2 for the emulator, so I doubt the version has anything to do with it. Can someone please point me in the right direction, and help me locate the app? Thank you! And sorry if I posted this thread in the wrong spot, I didn't know where else to post it. Mods, feel free to move it wherever if it's in the wrong spot.

Is This A Good Question/Topic? 0
  • +

Replies To: I cannot locate my app when I compile it with the andrioid emulator.

#2 blackcompe  Icon User is offline

  • D.I.C Lover
  • member icon

Reputation: 1151
  • View blog
  • Posts: 2,529
  • Joined: 05-May 05

Re: I cannot locate my app when I compile it with the andrioid emulator.

Posted 11 January 2013 - 02:01 PM

Moved to Android forums.

Did you thoroughly check the apps menu? If I remember correctly, either the Eclipse launcher should fire up the app in the emulator immediately or you have to find your app in the apps menu. I'd suggest following along with the official getting started tutorial.
Was This Post Helpful? 0
  • +
  • -

#3 Dictator_Rich  Icon User is offline

  • New D.I.C Head

Reputation: 0
  • View blog
  • Posts: 21
  • Joined: 29-March 12

Re: I cannot locate my app when I compile it with the andrioid emulator.

Posted 11 January 2013 - 02:39 PM

Thank you, I will check out that tutorial. I did thoroughly check the app menu, and there is nothing that even remotely resembles my app. I think I might be better off just uninstalling everything, and redoing everything with the getting started tutorial.
Was This Post Helpful? 0
  • +
  • -

#4 blackcompe  Icon User is offline

  • D.I.C Lover
  • member icon

Reputation: 1151
  • View blog
  • Posts: 2,529
  • Joined: 05-May 05

Re: I cannot locate my app when I compile it with the andrioid emulator.

Posted 11 January 2013 - 02:40 PM

Quote

Thank you, I will check out that tutorial. I did thoroughly check the app menu, and there is nothing that even remotely resembles my app. I think I might be better off just uninstalling everything, and redoing everything with the getting started tutorial.


No problem. Yeah, that tutorial is solid. I followed it with no problems.
Was This Post Helpful? 0
  • +
  • -

#5 farrell2k  Icon User is offline

  • D.I.C Lover
  • member icon

Reputation: 822
  • View blog
  • Posts: 2,529
  • Joined: 29-July 11

Re: I cannot locate my app when I compile it with the andrioid emulator.

Posted 11 January 2013 - 03:50 PM

make sure this is intent filter in your manifest for your main acivity:

<intent-filter >
        <action android:name="android.intent.action.MAIN" />
        <category android:name="android.intent.category.LAUNCHER" />
</intent-filter>



Your app will not execute or show up in the main menu without it.
Was This Post Helpful? 1
  • +
  • -

#6 blackcompe  Icon User is offline

  • D.I.C Lover
  • member icon

Reputation: 1151
  • View blog
  • Posts: 2,529
  • Joined: 05-May 05

Re: I cannot locate my app when I compile it with the andrioid emulator.

Posted 11 January 2013 - 03:59 PM

Quote

make sure this is intent filter in your manifest for your main acivity:


<intent-filter >

        <action android:name="android.intent.action.MAIN" />

        <category android:name="android.intent.category.LAUNCHER" />

</intent-filter>



Your app will not execute or show up in the main menu without it.


Dictator_Rich: Things like that could actually be the problem. The author may forget to leave out important tidbits or perhaps you're using a newer version of the platform that uses code that wasn't previously required. Did you trying running Android 3 on the emulator? After all, that's what the tutorial uses.

This post has been edited by blackcompe: 11 January 2013 - 04:00 PM

Was This Post Helpful? 1
  • +
  • -

#7 Dictator_Rich  Icon User is offline

  • New D.I.C Head

Reputation: 0
  • View blog
  • Posts: 21
  • Joined: 29-March 12

Re: I cannot locate my app when I compile it with the andrioid emulator.

Posted 11 January 2013 - 04:43 PM

hmm, I actually didn't have that, but it's too late now, I already started to reinstall everything. I had a feeling it had something to do with the version I was using.
Was This Post Helpful? 0
  • +
  • -

#8 Dictator_Rich  Icon User is offline

  • New D.I.C Head

Reputation: 0
  • View blog
  • Posts: 21
  • Joined: 29-March 12

Re: I cannot locate my app when I compile it with the andrioid emulator.

Posted 12 January 2013 - 11:55 AM

I followed that tutorial, and now I'm getting this error:

[2013-01-12 13:49:53 - MyFirstApp] Performing com.example.myfirstapp.MainActivity activity launch
[2013-01-12 13:49:53 - MyFirstApp] Automatic Target Mode: launching new emulator with compatible AVD 'devicee'
[2013-01-12 13:49:53 - MyFirstApp] Launching a new emulator with Virtual Device 'devicee'
[2013-01-12 13:49:53 - Emulator] emulator: ERROR: no search paths found in this AVD's configuration.
[2013-01-12 13:49:53 - Emulator] Weird, the AVD's config.ini file is malformed. Try re-creating it.
[2013-01-12 13:49:53 - Emulator]


When I try to create the android virtual device, the OK button stays disabled, even when I fill everything out. I tried clicking "Repair device", but then I got that error. What am I doing wrong this time? Also, I should note that I did not do this part of the tutorial because the "Welcome to Android Development" window never appeared:

"In the "Welcome to Android Development" window that appears, select Use existing SDKs.
Browse and select the location of the Android SDK directory you recently downloaded and unpacked.
Click Next."
Was This Post Helpful? 0
  • +
  • -

#9 Dictator_Rich  Icon User is offline

  • New D.I.C Head

Reputation: 0
  • View blog
  • Posts: 21
  • Joined: 29-March 12

Re: I cannot locate my app when I compile it with the andrioid emulator.

Posted 12 January 2013 - 12:20 PM

I actually just got it working on my actual phone, but can't get the emulator on my computer to work. Ehh, I guess I really don't need it to work on my computer anymore, but I'm still curious why I can't get it working for the life of me.

This post has been edited by Dictator_Rich: 12 January 2013 - 12:22 PM

Was This Post Helpful? 0
  • +
  • -

#10 blackcompe  Icon User is offline

  • D.I.C Lover
  • member icon

Reputation: 1151
  • View blog
  • Posts: 2,529
  • Joined: 05-May 05

Re: I cannot locate my app when I compile it with the andrioid emulator.

Posted 12 January 2013 - 12:56 PM

Have you tried googling the error message? Here's one of the top results. Usually it's better to google the relevant part of the error to get any results at all.

This post has been edited by blackcompe: 12 January 2013 - 12:59 PM

Was This Post Helpful? 0
  • +
  • -

Page 1 of 1