5 Replies - 1447 Views - Last Post: 31 January 2013 - 02:15 PM

#1 tools  Icon User is offline

  • D.I.C Head

Reputation: 1
  • View blog
  • Posts: 68
  • Joined: 26-September 12

The value for the useBean class attribute view.IndexView is invalid

Posted 31 January 2013 - 11:12 AM

Hey I am trying to make a JSP site for the first time, and I have the trouble as you can see in the topic heading.
But I can't see me mistake, my index.jsp looks like that, and yes I hav checked the package path

<%@ page import language="java" import="org.core.view.*" %>
<jsp:useBean id="indexview" class="org.core.view.IndexView" scope="session" />
<!DOCTYPE html>
<html>
<head>
<meta charset="UTF-8">
<title>test</title>
</head>
<body>
	<header>
		<!-- <h1><%= indexview.getTitle() %></h1>-->
		<h3>Open source, development, Linux, OS X & BSD</h3>
	</header>
	<div>
	 Hello!  The time is now <%= new java.util.Date() %>
	</div>
	<footer>
		&copy; 2010 - 2013 
	</footer>
</body>
</html>



Is This A Good Question/Topic? 0
  • +

Replies To: The value for the useBean class attribute view.IndexView is invalid

#2 blackcompe  Icon User is offline

  • D.I.C Lover
  • member icon

Reputation: 1152
  • View blog
  • Posts: 2,530
  • Joined: 05-May 05

Re: The value for the useBean class attribute view.IndexView is invalid

Posted 31 January 2013 - 11:55 AM

What exactly is supposed to happen that is not happening? Are you getting an exception message? If so, what is it?

This post has been edited by blackcompe: 31 January 2013 - 11:57 AM

Was This Post Helpful? 0
  • +
  • -

#3 tools  Icon User is offline

  • D.I.C Head

Reputation: 1
  • View blog
  • Posts: 68
  • Joined: 26-September 12

Re: The value for the useBean class attribute view.IndexView is invalid

Posted 31 January 2013 - 11:58 AM

I get the: 505: The Value For The UseBean Class Attribute View.IndexView Is Invalid
Was This Post Helpful? 0
  • +
  • -

#4 blackcompe  Icon User is offline

  • D.I.C Lover
  • member icon

Reputation: 1152
  • View blog
  • Posts: 2,530
  • Joined: 05-May 05

Re: The value for the useBean class attribute view.IndexView is invalid

Posted 31 January 2013 - 12:48 PM

You need to provide more information. How about posting the class definitions and describing the project layout? Furthermore, have you researched the error message? What steps have you taken to fix it? There are numerous Google results for "UseBean Class Attribute Is Invalid".
Was This Post Helpful? 0
  • +
  • -

#5 tools  Icon User is offline

  • D.I.C Head

Reputation: 1
  • View blog
  • Posts: 68
  • Joined: 26-September 12

Re: The value for the useBean class attribute view.IndexView is invalid

Posted 31 January 2013 - 01:10 PM

No I do not get an error code, besides what I provided, I follow this guide: http://www.jsptut.com/Forms.jsp the class?
package org.core.view;

public class IndexView extends View{
	
	public IndexView(String title){
		super(title);
	}
}

package org.core.view;

public class View {
	
	private String title;
	
	protected View(String title){
		this.title = title;
	}

	public String getTitle() {
		return title;
	}

	public void setTitle(String title) {
		this.title = title;
	}
	

}




And I use TomEE as Server and Eclipse Juno as IDE, and yes I have tried google. But I have not been able to find an answer to my question. Since I have no error nor exception so...

This post has been edited by tools: 31 January 2013 - 01:11 PM

Was This Post Helpful? 0
  • +
  • -

#6 tools  Icon User is offline

  • D.I.C Head

Reputation: 1
  • View blog
  • Posts: 68
  • Joined: 26-September 12

Re: The value for the useBean class attribute view.IndexView is invalid

Posted 31 January 2013 - 02:15 PM

it was the construtor header:
public IndexView(String title){
06
        super(title);
07
    }



Was This Post Helpful? 0
  • +
  • -

Page 1 of 1