3 Replies - 304 Views - Last Post: 06 February 2013 - 03:03 PM Rate Topic: -----

#1 krakatoa  Icon User is offline

  • New D.I.C Head

Reputation: 0
  • View blog
  • Posts: 30
  • Joined: 04-October 12

problem with .sdf database

Posted 06 February 2013 - 01:14 PM

Hello guys. I'll try to explain my problem. I have program where you entering people contacts and storing then into .sdf database. Im inserting some data directly from server explorer and other data when I'm running a program. Everything works and i see all data when I'm starting program again. But when I try to look data in server explorer (Show Table Data) all data which was stored running a program is gone and only data which was inserted directly exists. It happens with all my programs, this is just a one of the examples.

Is This A Good Question/Topic? 0
  • +

Replies To: problem with .sdf database

#2 tlhIn`toq  Icon User is offline

  • Please show what you have already tried when asking a question.
  • member icon

Reputation: 5436
  • View blog
  • Posts: 11,649
  • Joined: 02-June 10

Re: problem with .sdf database

Posted 06 February 2013 - 01:30 PM

This is while you are debugging in Visual Studio, right?
I'm pretty sure that's normal when debugging. The actual database file only exists during the life of the debug. - but I don't do a lot of this type of database work: I normally run a MySQL database that is completely independent of Visual Studio.
Was This Post Helpful? 0
  • +
  • -

#3 krakatoa  Icon User is offline

  • New D.I.C Head

Reputation: 0
  • View blog
  • Posts: 30
  • Joined: 04-October 12

Re: problem with .sdf database

Posted 06 February 2013 - 01:38 PM

Not only when I'm debugging when i stop debug and start again I have all data everytime unless I press Show Table Data in server explorer
Was This Post Helpful? 0
  • +
  • -

#4 pharylon  Icon User is offline

  • D.I.C Head

Reputation: 40
  • View blog
  • Posts: 83
  • Joined: 01-September 12

Re: problem with .sdf database

Posted 06 February 2013 - 03:03 PM

View Postkrakatoa, on 06 February 2013 - 01:38 PM, said:

Not only when I'm debugging when i stop debug and start again I have all data everytime unless I press Show Table Data in server explorer

What he's saying is that is normal when debugging. When you start the debugger, it builds an instance if the database that goes away as soon as you stop debugging.

When you actually compile and publish it and run it outside of Visual Studio, it should work.
Was This Post Helpful? 0
  • +
  • -

Page 1 of 1