0 Replies - 1226 Views - Last Post: 14 February 2013 - 01:51 PM

#1 BobRodes  Icon User is offline

  • Your Friendly Local Curmudgeon
  • member icon

Reputation: 574
  • View blog
  • Posts: 2,989
  • Joined: 19-May 09

Having trouble stepping through code in jsp pages, using maven, tomcat

Posted 14 February 2013 - 01:51 PM

Problem: If I start local tomcat server using Windows services and then navigate to my app's opening page (login.jsp), the page shows. If I start the server through Eclipse, it starts ok, but the page gives an Error 404. My theory is that Eclipse is looking in the wrong folder for the web page, but I can't see where it's looking.

Backstory: I'm rying to debug jsp pages in an existing web app that uses tomcat and Maven. Can't do that in maven AFAIK, so I've been attempting to set it up in Eclipse. (I will cheerfully abandon Eclipse if I can step through jsp code another way.) So far, I've used the m2e plugin to import our existing Maven-based application into Eclipse. I got the existing tomcat server installed in Eclipse (after first installing the Web Tools Platform), and was able to get it to start. This is where I have the problem I've described above.

Stuff I've tried that doesn't help: Changed "use workspace metadata" to "use tomcat installation" (don't need to see the welcome page). Tried "use custom location" and put in what I think is the server path. Tried navigating to the "project name" (localhost:8080/ui) in the browser.

TIA

p. s. Sorry if this is the wrong forum. If so, please feel free to move me.

This post has been edited by BobRodes: 14 February 2013 - 01:51 PM


Is This A Good Question/Topic? 0
  • +

Page 1 of 1