Dream.In.Code + CloudFlare

  • (5 Pages)
  • +
  • 1
  • 2
  • 3
  • 4
  • Last »

65 Replies - 7647 Views - Last Post: 30 April 2013 - 06:32 PM

#16 skyhawk133  Icon User is offline

  • Head DIC Head
  • member icon

Reputation: 1858
  • View blog
  • Posts: 20,275
  • Joined: 17-March 01

Re: Dream.In.Code + CloudFlare

Posted 30 March 2013 - 07:21 PM

I haven't been able to replicate the fast reply bug at all. I can't think of any reason it would randomly redirect you to the homepage/forum index when you hit post.

Has this been happening as frequently since we moved to the new servers a few weeks ago?
Was This Post Helpful? 0
  • +
  • -

#17 tlhIn`toq  Icon User is offline

  • Please show what you have already tried when asking a question.
  • member icon

Reputation: 5316
  • View blog
  • Posts: 11,361
  • Joined: 02-June 10

Re: Dream.In.Code + CloudFlare

Posted 31 March 2013 - 06:36 AM

Not *as* frequently, but still happens. I do notice that it may not happen at all one day, and 3 times the next day.
Was This Post Helpful? 0
  • +
  • -

#18 tlhIn`toq  Icon User is offline

  • Please show what you have already tried when asking a question.
  • member icon

Reputation: 5316
  • View blog
  • Posts: 11,361
  • Joined: 02-June 10

Re: Dream.In.Code + CloudFlare

Posted 31 March 2013 - 07:37 AM

I just had it happen on this page:
http://www.dreaminco...ected-with-sql/
three times. When I would hit [POST] I was taken to the forums/index.php page

HItting back on the browser doesn't solve it.
Clicking the title of the thread causes the page to reload.
then I pasted the copied text in again, and hit [POST]
This time it was accepted. I also noticed that modi_123 had a post appear at the same time as mine.

So maybe this is an issue when two different users are posting at the same time??
Was This Post Helpful? 0
  • +
  • -

#19 tlhIn`toq  Icon User is offline

  • Please show what you have already tried when asking a question.
  • member icon

Reputation: 5316
  • View blog
  • Posts: 11,361
  • Joined: 02-June 10

Re: Dream.In.Code + CloudFlare

Posted 31 March 2013 - 08:03 AM

View Postskyhawk133, on 31 March 2013 - 08:47 AM, said:

And this ONLY Happens from the Fast Reply? Not the full editor?


Hmmm.... Thinking.... I can't say I ever recall it happening from the full editor. Not saying that it hasn't... But 95% of the replies are from the fast editor. Full editor only gets opened for uploading images. So it might just be too small of a sampling to be significant.
Was This Post Helpful? 0
  • +
  • -

#20 jon.kiparsky  Icon User is offline

  • Pancakes!
  • member icon


Reputation: 7294
  • View blog
  • Posts: 12,138
  • Joined: 19-March 11

Re: Dream.In.Code + CloudFlare

Posted 31 March 2013 - 08:08 AM

There's an easy way to test this, of course.

(posted from full editor)
Was This Post Helpful? 0
  • +
  • -

#21 jon.kiparsky  Icon User is offline

  • Pancakes!
  • member icon


Reputation: 7294
  • View blog
  • Posts: 12,138
  • Joined: 19-March 11

Re: Dream.In.Code + CloudFlare

Posted 31 March 2013 - 11:19 AM

This is a test posting from the fast reply.
Was This Post Helpful? 0
  • +
  • -

#22 tlhIn`toq  Icon User is offline

  • Please show what you have already tried when asking a question.
  • member icon

Reputation: 5316
  • View blog
  • Posts: 11,361
  • Joined: 02-June 10

Re: Dream.In.Code + CloudFlare

Posted 31 March 2013 - 11:25 AM

This is a simultaneous Fast Replay test between Jon and tlhIn`toq.

This is a fast reply while Jon has the full editor open.

Well - So much for the obvious things. Looks like it is going to be some kind of server issue beyond what we can test on our own.
Was This Post Helpful? 0
  • +
  • -

#23 andrewsw  Icon User is online

  • Fire giant boob nipple gun!
  • member icon

Reputation: 2886
  • View blog
  • Posts: 9,588
  • Joined: 12-December 12

Re: Dream.In.Code + CloudFlare

Posted 31 March 2013 - 01:01 PM

I keep getting "Error 504 Gateway Time Out", from both the Fast Reply and Reply options.
Was This Post Helpful? 0
  • +
  • -

#24 tlhIn`toq  Icon User is offline

  • Please show what you have already tried when asking a question.
  • member icon

Reputation: 5316
  • View blog
  • Posts: 11,361
  • Joined: 02-June 10

Re: Dream.In.Code + CloudFlare

Posted 31 March 2013 - 01:06 PM

View Postandrewsw, on 31 March 2013 - 02:01 PM, said:

I keep getting "Error 504 Gateway Time Out", from both the Fast Reply and Reply options.


yet you were able to reply... ????
Was This Post Helpful? 0
  • +
  • -

#25 jon.kiparsky  Icon User is offline

  • Pancakes!
  • member icon


Reputation: 7294
  • View blog
  • Posts: 12,138
  • Joined: 19-March 11

Re: Dream.In.Code + CloudFlare

Posted 31 March 2013 - 01:11 PM


Was This Post Helpful? 0
  • +
  • -

#26 andrewsw  Icon User is online

  • Fire giant boob nipple gun!
  • member icon

Reputation: 2886
  • View blog
  • Posts: 9,588
  • Joined: 12-December 12

Re: Dream.In.Code + CloudFlare

Posted 31 March 2013 - 01:18 PM

View PosttlhIn`toq, on 31 March 2013 - 08:06 PM, said:

View Postandrewsw, on 31 March 2013 - 02:01 PM, said:

I keep getting "Error 504 Gateway Time Out", from both the Fast Reply and Reply options.


yet you were able to reply... ????

Not always, I exaggerated. I meant "fairly frequently". I posted with my own ..idiom.

This post has been edited by andrewsw: 31 March 2013 - 01:22 PM

Was This Post Helpful? 0
  • +
  • -

#27 tlhIn`toq  Icon User is offline

  • Please show what you have already tried when asking a question.
  • member icon

Reputation: 5316
  • View blog
  • Posts: 11,361
  • Joined: 02-June 10

Re: Dream.In.Code + CloudFlare

Posted 31 March 2013 - 02:00 PM

View PosttlhIn`toq, on 31 March 2013 - 08:37 AM, said:

I just had it happen on this page:
http://www.dreaminco...ected-with-sql/
three times. When I would hit [POST] I was taken to the forums/index.php page

HItting back on the browser doesn't solve it.
Clicking the title of the thread causes the page to reload.
then I pasted the copied text in again, and hit [POST]
This time it was accepted. I also noticed that modi_123 had a post appear at the same time as mine.

So maybe this is an issue when two different users are posting at the same time??


1558 hrs Houston Time (maybe that helps look up other events in the logs):
Just happened again on this thread:
http://www.dreaminco...9&#entry1829349
Was This Post Helpful? 0
  • +
  • -

#28 Martyr2  Icon User is offline

  • Programming Theoretician
  • member icon

Reputation: 4189
  • View blog
  • Posts: 11,863
  • Joined: 18-April 07

Re: Dream.In.Code + CloudFlare

Posted 31 March 2013 - 06:07 PM

I have only ever noticed the bug on fast reply, never full reply. It happens a bit less than last time, but with the randomness I am forced to always do a copy all before hitting post.
Was This Post Helpful? 0
  • +
  • -

#29 skyhawk133  Icon User is offline

  • Head DIC Head
  • member icon

Reputation: 1858
  • View blog
  • Posts: 20,275
  • Joined: 17-March 01

Re: Dream.In.Code + CloudFlare

Posted 31 March 2013 - 06:10 PM

Just looking at the form code, the only difference is the encoding type, one is multi-part (full editor) and fast reply doesn't specify. Both submit to index.php. I'll have to look more closely at the hidden fields to see if they're the same.

Does it happen after several replies? First reply of the day? Totally random? In one browser more often than another? When the javascript doesn't fully load?
Was This Post Helpful? 0
  • +
  • -

#30 CharlieMay  Icon User is offline

  • This space intentionally left blank
  • member icon

Reputation: 1533
  • View blog
  • Posts: 4,919
  • Joined: 25-September 09

Re: Dream.In.Code + CloudFlare

Posted 01 April 2013 - 04:12 AM

while posting this response. I received the capcha prompt. Post went through on successful entry of capcha. My first entry for today in case that matters.
Was This Post Helpful? 0
  • +
  • -

  • (5 Pages)
  • +
  • 1
  • 2
  • 3
  • 4
  • Last »