1 Replies - 3944 Views - Last Post: 05 April 2013 - 11:14 AM

#1 uncles  Icon User is offline

  • New D.I.C Head

Reputation: 1
  • View blog
  • Posts: 24
  • Joined: 30-November 08

My Gaming site

Posted 05 April 2013 - 10:33 AM

Hello, the following site is my gaming test site: http://agesofuo.comule.com/
Im trying really hard to copy enjin, if you don't know what enjin is, its a hosting company that gives you templates and forums for a monthly fee, which im trying to get away from. Here is my old site im trying to move from that is enjin: http://tenacitygaming.com
Im a designer and not too savy on where to find modules so any suggestions would be great on improving my website!

This post has been edited by uncles: 05 April 2013 - 10:40 AM


Is This A Good Question/Topic? 0
  • +

Replies To: My Gaming site

#2 modi123_1  Icon User is online

  • Suitor #2
  • member icon



Reputation: 8910
  • View blog
  • Posts: 33,420
  • Joined: 12-June 08

Re: My Gaming site

Posted 05 April 2013 - 11:14 AM

I do enjoy the new site's look. I think the coloring is pretty solid though and through, and the layout is easy on the eyes...

Now.. the things I have issue with - first it's all in flash. Not a favorite of mine.
Second the forced sound on page load is annoying.
Third the perpetual lense flare that happens all the time is annoying.
The mouse over the icons as they jump/spin/move was initially amusing, but darn annoying.
Fifth the main body video is horribly pixelated.
The 'splash' on the 'reviews', 'previews', rows of menus is super annoying after the first "huh.. that's quaint".
The menus - when clicked do they stay green?
Eighth - the "Game.Port 2009 Privacy Policy" looks like a button and not a footer. Why not put it at the bottom of the menu links near the footer?
Speaking of those footer links - why do they work and not the top ones?
Tenth - your 'sign in' button's neighbor is blank.
Was This Post Helpful? 0
  • +
  • -

Page 1 of 1