2 Replies - 609 Views - Last Post: 09 June 2013 - 01:36 PM Rate Topic: -----

#1 jon.kiparsky  Icon User is online

  • Pancakes!
  • member icon


Reputation: 7996
  • View blog
  • Posts: 13,694
  • Joined: 19-March 11

Question regarding ruby 1.9.3 install

Posted 08 June 2013 - 04:44 PM

Quick question about my install from a total roob noob: I noticed today that ruby --version reports 1.9.3 (as expected) but the rubylibdir is pointing to 1.8, and not to 1.9 (which exists and has contents). Is there some arcane reason why this might be the case, or is this likely to indicate a botched installation?
Is This A Good Question/Topic? 0
  • +

Replies To: Question regarding ruby 1.9.3 install

#2 Martyr2  Icon User is offline

  • Programming Theoretician
  • member icon

Reputation: 4421
  • View blog
  • Posts: 12,286
  • Joined: 18-April 07

Re: Question regarding ruby 1.9.3 install

Posted 09 June 2013 - 09:02 AM

How did you install Ruby and what OS are you using? Did you follow some guide and copy paste some config commands or something? Just asking. :)

This post has been edited by Martyr2: 09 June 2013 - 11:13 AM

Was This Post Helpful? 0
  • +
  • -

#3 jon.kiparsky  Icon User is online

  • Pancakes!
  • member icon


Reputation: 7996
  • View blog
  • Posts: 13,694
  • Joined: 19-March 11

Re: Question regarding ruby 1.9.3 install

Posted 09 June 2013 - 01:36 PM

That's the trouble - I don't remember exactly how I did the install. This is on ubuntu, so I might have used apt0get (that would seem the sensible thing) but I have no conscious memory of it, in any case.
I suppose the sensible thing would be to clean and reinstall and see what happens - I was just curious to know if there was some jiggery-pokery going on that I was unaware of.

Am I safe in assuming that a standard 1.9.3 installation points to the 1.9 libraries? (This seems like a "duh", but you never know)

This post has been edited by jon.kiparsky: 09 June 2013 - 01:36 PM

Was This Post Helpful? 0
  • +
  • -

Page 1 of 1