1 Replies - 229 Views - Last Post: 10 July 2014 - 07:26 PM

#1 jon.kiparsky  Icon User is offline

  • Pancakes!
  • member icon


Reputation: 7562
  • View blog
  • Posts: 12,680
  • Joined: 19-March 11

Raspbian on qemu - can get login prompt, but can't login

Posted 09 October 2013 - 12:08 PM

I'm trying to emulate a Raspberry Pi on either my mac or my laptop (Ubuntu, 12.04) using qemu.

I've used the instructions here and here, and I can get the virtual OS to boot up to the login prompt, but when I log in with the default password (pi/raspberry) it displays the standard Linux identification ("Linux (none) 3.2.0 #1 etc") and Debian disclaimers ("ABSOLUTELY NO WARRANTY" and all that) prints a warning ("This Raspberry Pi has not been fully configured, please run raspi-config"). It then returns me to the login prompt.

Note: the instructions cited claim that I should be booting into a root shell - this does not happen.

(similar results on both platforms, if it matters)

If anyone has any suggestions, I'm all ears.
Thanks!

Is This A Good Question/Topic? 0
  • +

Replies To: Raspbian on qemu - can get login prompt, but can't login

#2 Valek  Icon User is offline

  • The Real Skynet
  • member icon

Reputation: 542
  • View blog
  • Posts: 1,713
  • Joined: 08-November 08

Re: Raspbian on qemu - can get login prompt, but can't login

Posted 10 July 2014 - 07:26 PM

View Postjon.kiparsky, on 09 October 2013 - 03:08 PM, said:

Note: the instructions cited claim that I should be booting into a root shell - this does not happen.


Indeed. That is what the init=/bin/bash part of the kernel parameters is supposed to do for you.

Can you post the command(s) you are using to start it, please?
Was This Post Helpful? 0
  • +
  • -

Page 1 of 1