3 Replies - 596 Views - Last Post: 24 October 2013 - 07:38 PM Rate Topic: -----

#1 heaphyg  Icon User is offline

  • D.I.C Head

Reputation: 4
  • View blog
  • Posts: 75
  • Joined: 30-August 13

Ruby 2.0 and Rails 4.x

Posted 19 October 2013 - 09:22 PM

I am trying to download ruby 2.0. I managed to get 1.9.3 through the RailsBridge install fest online. I don't understand all the compiling stuff that I keep seeing on ruby websites regarding the acquisition of ruby 2.0 . In addition I have been instructed that if I type gem install rails into terminal that this will update my rails application from 3.2x to 4.x. When I type this command into terminal absolutely nothing happens. I would appreciate any assistance regarding these issues. Thank you for your time.

Is This A Good Question/Topic? 0
  • +

Replies To: Ruby 2.0 and Rails 4.x

#2 Lemur  Icon User is offline

  • Pragmatism over Dogma
  • member icon



Reputation: 1335
  • View blog
  • Posts: 3,398
  • Joined: 28-November 09

Re: Ruby 2.0 and Rails 4.x

Posted 22 October 2013 - 07:54 PM

What OS are you running? Chances are Windows, and if that's the case you're in for a very very difficult time. If you want to learn rails I would highly suggest getting a virtual machine running Linux Mint.

There are a number of nasty bugs in Ruby Windows that seem to crop up sporadically. Now as to the reason, I would say it's that most gem writers do not take non-unix OS builds seriously when considering compatibility. This being said, I tried to make Windows work with it before but the amount of pain involved is quite frankly not ever worth it.
Was This Post Helpful? 0
  • +
  • -

#3 heaphyg  Icon User is offline

  • D.I.C Head

Reputation: 4
  • View blog
  • Posts: 75
  • Joined: 30-August 13

Re: Ruby 2.0 and Rails 4.x

Posted 23 October 2013 - 11:25 PM

I am using a mac version 10.7
Was This Post Helpful? 0
  • +
  • -

#4 Lemur  Icon User is offline

  • Pragmatism over Dogma
  • member icon



Reputation: 1335
  • View blog
  • Posts: 3,398
  • Joined: 28-November 09

Re: Ruby 2.0 and Rails 4.x

Posted 24 October 2013 - 07:38 PM

Steps:



That gets the entire thing set up. Make SURE to watch what RVM says at the end about sourcing.

It installs git, z shell with oh my z shell (great for working with git), ruby, and rails.
Was This Post Helpful? 1
  • +
  • -

Page 1 of 1