1 Replies - 5862 Views - Last Post: 28 October 2013 - 05:30 AM

#1 mannava  Icon User is offline

  • New D.I.C Head

Reputation: 0
  • View blog
  • Posts: 1
  • Joined: 28-October 13

Apache not starting in XAMPP control panel v3.2.1

Posted 28 October 2013 - 04:56 AM

5:11:13 PM [main] Initializing Control Panel
5:11:13 PM [main] Windows Version: Windows 7 Professional 64-bit
5:11:13 PM [main] XAMPP Version: 1.8.3
5:11:13 PM [main] Control Panel Version: 3.2.1 [ Compiled: May 7th 2013 ]
5:11:13 PM [main] Running with Administrator rights - good!
5:11:13 PM [main] XAMPP Installation Directory: "c:\xampp\"
5:11:13 PM [main] Checking for prerequisites
5:11:13 PM [main] All prerequisites found
5:11:13 PM [main] Initializing Modules
5:11:13 PM [Apache] Problem detected!
5:11:13 PM [Apache] Port 80 in use by "Unable to open process" with PID 4!
5:11:13 PM [Apache] Apache WILL NOT start without the configured ports free!
5:11:13 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
5:11:13 PM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
5:11:13 PM [Apache] Problem detected!
5:11:13 PM [Apache] Port 443 in use by "Unable to open process" with PID 4!
5:11:13 PM [Apache] Apache WILL NOT start without the configured ports free!
5:11:13 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
5:11:13 PM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
5:11:13 PM [main] The Tomcat module is disabled
5:11:13 PM [main] Starting Check-Timer
5:11:13 PM [main] Control Panel Ready
5:11:22 PM [Apache] Problem detected!
5:11:22 PM [Apache] Port 80 in use by "Unable to open process" with PID 4!
5:11:22 PM [Apache] Apache WILL NOT start without the configured ports free!
5:11:22 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
5:11:22 PM [Apache] or reconfigure Apache and the Control Panel to listen on a different port
5:11:22 PM [Apache] Problem detected!
5:11:22 PM [Apache] Port 443 in use by "Unable to open process" with PID 4!
5:11:22 PM [Apache] Apache WILL NOT start without the configured ports free!
5:11:22 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
5:11:22 PM [Apache] or reconfigure Apache and the Control Panel to listen on a different port

I am getting such error when I am trying to start the apache where as mysql and filezilla are able to start.

Is This A Good Question/Topic? 0
  • +

Replies To: Apache not starting in XAMPP control panel v3.2.1

#2 Atli  Icon User is online

  • D.I.C Lover
  • member icon

Reputation: 3636
  • View blog
  • Posts: 5,759
  • Joined: 08-June 10

Re: Apache not starting in XAMPP control panel v3.2.1

Posted 28 October 2013 - 05:30 AM

Moved to the Web Servers & Hosting forum. This is not a PHP problem.


The [Apache] sections there are pretty clear about what the problem is:

Quote

5:11:22 PM [Apache] Port 80 in use by "Unable to open process" with PID 4!
5:11:22 PM [Apache] Port 443 in use by "Unable to open process" with PID 4!


The ports Apache is configured to use are already in use. Given that both 80 and 443 seem to be in use already, I would guess you have another HTTP server already running on your computer? Perhaps another Apache server or IIS?

Skype has also been known to use port 80, but I'm not sure about 443. If you have Skype installed, try turning it off and see if that helps. If it does, you can configure Skype to use different ports. (Or configure Apache to use different ports.)
Was This Post Helpful? 0
  • +
  • -

Page 1 of 1