1 Replies - 602 Views - Last Post: 15 December 2013 - 01:33 PM

#1 hdr  Icon User is offline

  • D.I.C Head
  • member icon

Reputation: 5
  • View blog
  • Posts: 154
  • Joined: 15-December 08

PC-BSD would not load KDE after reboot.

Posted 26 November 2013 - 08:53 PM

The problem here is that my friends and I are required to install and configure PC-BSD on a computer to act as a server as part of our coursework. The problem is that after we configured PC-BSD to become a web and mail server (which we referred to the BSD Handbook) at my friend's house, we turned it off and carted the computer to our University lab.

Once we got there, however, it appears that the PC-BSD is unable to load KDE. We were still able to start X Windows, and I've tried removing and reinstalling KDE, but for some reason PC-BSD will not load KDE.

We've reinstalled and re-configured PC-BSD twice, but it will not load KDE after we've restarted the computer. We've reinstalled PC-BSD again without any modifications, and so far, it is able to run and load KDE correctly.

Does anyone have any suggestions on why it happened and is there anyway to prevent it from happening again?

PS: I've asked the PC-BSD forums as well for solutions but have yet to receive a reply. The server in question is with my friend at the moment, and should you need any screenshots or error messages, I'll get back to him about it.

Is This A Good Question/Topic? 0
  • +

Replies To: PC-BSD would not load KDE after reboot.

#2 g-weebens  Icon User is offline

  • New D.I.C Head
  • member icon

Reputation: 2
  • View blog
  • Posts: 39
  • Joined: 28-December 10

Re: PC-BSD would not load KDE after reboot.

Posted 15 December 2013 - 01:33 PM

You will need to find the [file]init[/file] for the [file]kdm(4)[/file] which should be in [file]/usr/local[/file] or [file]/usr/local/kde4[/file] depending on the build configuration.
1. Start the system in single user mode.
2. [cmd] mount -rw / [/cmd] and other file systems.
3. [cmd] locate kdm|grep /usr/local|less[/cmd] and look for the [file]init[/file] setting.
4. [cmd] /path/to/kdm/init restart {or onestart}[/cmd]
Was This Post Helpful? 0
  • +
  • -

Page 1 of 1