6 Replies - 5019 Views - Last Post: 10 January 2014 - 04:14 AM

#1 kentlucky  Icon User is offline

  • D.I.C Head

Reputation: 4
  • View blog
  • Posts: 74
  • Joined: 20-June 12

Strange word in my comment thread

Posted 27 November 2013 - 09:50 PM

Hi guyz!

I figure out that when someone post a comment in my site, there are something strange words in their comments. I tried to post a comment but it seems okay. Please go to this link to see the problem.
Any help would be accepted.

Thanks
Is This A Good Question/Topic? 0
  • +

Replies To: Strange word in my comment thread

#2 astonecipher  Icon User is offline

  • Major DIC Head
  • member icon

Reputation: 705
  • View blog
  • Posts: 3,036
  • Joined: 03-December 12

Re: Strange word in my comment thread

Posted 02 December 2013 - 02:50 PM

The link goes to a hosting site. What is showing?
Was This Post Helpful? 0
  • +
  • -

#3 kentlucky  Icon User is offline

  • D.I.C Head

Reputation: 4
  • View blog
  • Posts: 74
  • Joined: 20-June 12

Re: Strange word in my comment thread

Posted 10 January 2014 - 12:36 AM

Hello please go to this link to see the strange words in the comments. I hope that any one here can help me to fix my site.. thank you.
Was This Post Helpful? 0
  • +
  • -

#4 astonecipher  Icon User is offline

  • Major DIC Head
  • member icon

Reputation: 705
  • View blog
  • Posts: 3,036
  • Joined: 03-December 12

Re: Strange word in my comment thread

Posted 10 January 2014 - 01:05 AM

What code do you have for the comments? I am thinking it maybe a character type issue. I bet if you search those character groups they define letters.
Was This Post Helpful? 0
  • +
  • -

#5 kentlucky  Icon User is offline

  • D.I.C Head

Reputation: 4
  • View blog
  • Posts: 74
  • Joined: 20-June 12

Re: Strange word in my comment thread

Posted 10 January 2014 - 01:16 AM

I use wordpress platform for this.
Was This Post Helpful? 0
  • +
  • -

#6 Atli  Icon User is offline

  • D.I.C Lover
  • member icon

Reputation: 3719
  • View blog
  • Posts: 5,991
  • Joined: 08-June 10

Re: Strange word in my comment thread

Posted 10 January 2014 - 03:05 AM

Looking at the source of the page, it looks like something is doing some very strange HTML entity conversion to these comments, and failing to do so properly. Look at this line from one of the comments, as read in the source. (It will look different in a browser, where the valid entities are rendered as text.)
I seriousl&​#1091; love yοur site.. Gr&​#101;at c&X6F;l&​#1086;rs &​amp;


Here we have three different types of HTML entities, &​#1091; (decimal value for "y"), ο (Greek, lower-case "o"), and &X6F;, which I presume is meant to be &​#X6F; (hex value for a normal, lower-case "o").

Why it's only encoding these seemingly random letters, and why it's doing so in so many different ways, makes no sense. Nor do I know why it fails to properly encode the third version correctly, causing the display error you are seeing.

If you didn't code this yourself, my guess would be that one of your plugins is faulty, or two or more plugins are somehow incompatible and are causing this effect when combined. Either way, try disabling plugins to see if the problem stops appearing.
Was This Post Helpful? 0
  • +
  • -

#7 kentlucky  Icon User is offline

  • D.I.C Head

Reputation: 4
  • View blog
  • Posts: 74
  • Joined: 20-June 12

Re: Strange word in my comment thread

Posted 10 January 2014 - 04:14 AM

Thank you so much for the effort in giving me information about the problem in my blog site. This is a wordpress site so I didn't code it my self. I will try to disable my plugins.
Was This Post Helpful? 0
  • +
  • -

Page 1 of 1