Unable to start debugging on the web server.

Unable to start debugging on the web server. The web server is not co

Page 1 of 1

4 Replies - 73825 Views - Last Post: 22 February 2010 - 09:31 AM Rate Topic: -----

#4 Thapa  Icon User is offline

  • New D.I.C Head

Reputation: 2
  • View blog
  • Posts: 25
  • Joined: 24-September 07

Re: Unable to start debugging on the web server.

Post icon  Posted 01 October 2007 - 07:13 PM

Hi i am trying to run my friend Program in my machine which has got following in one solution:-
his program got
Data Access Layer
Business Layer
Web Service
And interface





I have copied program file and Services file to my wwwroot and again provided the reference to different Layer as required. but when i Build the solution there is no error message but when i tried to run it i got following Message:-

Error message is "Unable to start debugging on the web server. The web server is not configured correctly."

to over come this error i removed the web service and created another one and again add reference and make a change as required in interface layer but still i got same error! I am looking forward if some one can Help me to over come this Problem!

Regards

This post has been edited by PsychoCoder: 01 October 2007 - 09:13 PM

Was This Post Helpful? 1

#13 PsychoCoder  Icon User is offline

  • Google.Sucks.Init(true);
  • member icon

Reputation: 1639
  • View blog
  • Posts: 19,853
  • Joined: 26-July 07

Re: Unable to start debugging on the web server.

Posted 01 October 2007 - 09:12 PM

That has nothing to do with the web service, it has to do with the web server, meaning remote debugging isn't enabled, or you don't have permissions for it, on the server thats hosting your site, or the ASP.Net application hasn't been set as a web application

You can try enabling remote debugging in the web.config, to do that

  • Open the web.config file
    • Y ou cannot access the file remotely using a Web browser due to built-in IIS & .Net security

  • Look for the <compilation> tag. This marks the beginning of the <compilation> section.
  • Inside the <compilation> tag, you will create the debug attribute
    • Attributes are case sensitive, so be sure to specify "debug", not "Debug" or "DEBUG."

  • Set debug to true, like in the example below

<configuration>
	<system.web>
		<compilation defaultLanguage="VB" debug="true">
   ...
   ...
   ...




To make sure your web site is registered as a web application try the following:

  • Open the IIS admin app.
  • Right click on your app's directory (/virtual dir) and select Properties.
  • On the Directory tab, under Application Settings, next to Application Name there will be a 'Create' button - click it. Once the dir has been registered as a web app then this button will say 'Remove'.
  • Click Apply (or OK).


One last thing, you need to enable debugging for your web application, to do this:

  • Go to Internet Information Services
  • Right mouse click on your project directory
  • Go to the ASP.NET tab
  • Click the Edit Configuration button
  • Select the Application Tab
  • Check the 'Enable Debugging' checkbox

Hope this helps :)
Was This Post Helpful? 1

#14 jairosoft  Icon User is offline

  • New D.I.C Head

Reputation: 1
  • View blog
  • Posts: 1
  • Joined: 06-May 08

Re: Unable to start debugging on the web server.

Posted 06 May 2008 - 11:01 AM

Thanks for your help. I am having the same problem. Like you suggested, I made sure the website directory was configured correctly using the IIS manager and going into the properties of each website directory. I have checked that the web directory is
configured correctly (so that a remove button is showing), and I have made sure that Integrated Windows Authentication is check marked, and in the the ASP.NET tab, I have made sure that "enable debugging" is checked, and I have made sure that the web.config file for each website says debug="true" where it should go. So everything seems to be configured correctly, but still, I get the error message that says "Unable to start debugging on the web server. The web server is not configured correctly. . . ." If I run one of my websites without debugging (ctrl-F5) then it doesn't want to display. One of those error pages comes up.

I don't know what could have caused this, I recall that this has been like this since I downloaded a website that I had created and uploaded on another computer, and so when I went to run it in VS 2008, it was saying that this website was already precompiled, (but I had previously replaced the precompiled pages with regular pages, as far as I can tell). So maybe there were some leftover precompiled files somewhere that I overlooked.

Anyway, the error message is happening to all the other website that I have on my wwwroot directory and it wasn't doing that before. Help.
Was This Post Helpful? 1

#15 standardkannan  Icon User is offline

  • New D.I.C Head

Reputation: 0
  • View blog
  • Posts: 1
  • Joined: 08-October 09

Re: Unable to start debugging on the web server.

Posted 08 October 2009 - 11:32 PM

Hi,
i got solution from here, i hope this helpful for u

http://www.onlineato...web-server.aspx
Was This Post Helpful? 0
  • +
  • -

#16 Guest_MArk*


Reputation:

Re: Unable to start debugging on the web server.

Posted 22 February 2010 - 09:31 AM

following PsychoCoder's second suggestion is what actually solved the issue for me. Apparently enabling debugging was all I had left pending.

Thanks

enable debugging for your web application, do this:


1. Go to Internet Information Services

2. Right mouse click on your project directory

3. Go to the ASP.NET tab

4. Click the Edit Configuration button

5. Select the Application Tab

6. Check the 'Enable Debugging' checkbox
Was This Post Helpful? 0

Page 1 of 1