Cannot connect to Apache webserver

You are not authorized to view this page error 403 forbidden

Page 1 of 1

6 Replies - 4874 Views - Last Post: 10 October 2007 - 09:14 AM

#1 Teisi  Icon User is offline

  • New D.I.C Head

Reputation: 0
  • View blog
  • Posts: 1
  • Joined: 09-October 07

Cannot connect to Apache webserver

Posted 09 October 2007 - 02:22 AM

I'm trying to connect to my apache webserver. And I get the following error

You are not authorized to view this page
You might not have permission to view this directory or page using the credentials you supplied. Error 403 - forbidden.

May someone advise me on the changes I should make in the httpd.conf file.
Thanx
Is This A Good Question/Topic? 0
  • +

Replies To: Cannot connect to Apache webserver

#2 Thorian  Icon User is offline

  • Pirate Medic
  • member icon

Reputation: 22
  • View blog
  • Posts: 5,904
  • Joined: 06-June 02

Re: Cannot connect to Apache webserver

Posted 09 October 2007 - 07:41 AM

I am going to move this over to software but I will also leave a refferal link here. it would probally get more hits from a Apachie administrator over there.

Sorry I only know a bit of websphere
Was This Post Helpful? 0
  • +
  • -

#3 MorphiusFaydal  Icon User is offline

  • D.I.C Lover
  • member icon

Reputation: 43
  • View blog
  • Posts: 1,376
  • Joined: 12-May 05

Re: Cannot connect to Apache webserver

Posted 09 October 2007 - 06:16 PM

Make sure all the files are owned by the apache user.
Was This Post Helpful? 0
  • +
  • -

#4 no2pencil  Icon User is offline

  • Toubabo Koomi
  • member icon

Reputation: 5178
  • View blog
  • Posts: 26,870
  • Joined: 10-May 07

Re: Cannot connect to Apache webserver

Posted 09 October 2007 - 08:03 PM

View PostTeisi, on 9 Oct, 2007 - 02:22 AM, said:

I'm trying to connect to my apache webserver. And I get the following error



Inside of the httpd.conf, what do you show for the following two settings?

   DocumentRoot /var/www/html/directory
   DirectoryIndex index.htm



Assuming you are running a *nix OS, what are the permissions for the directory & files?
Was This Post Helpful? 0
  • +
  • -

#5 MorphiusFaydal  Icon User is offline

  • D.I.C Lover
  • member icon

Reputation: 43
  • View blog
  • Posts: 1,376
  • Joined: 12-May 05

Re: Cannot connect to Apache webserver

Posted 09 October 2007 - 09:20 PM

I have:

DirectoryIndex index.html index.htm index.php



I just checked, and, for some reason, I have no DocumentRoot defined. However, httpd is reading out of /var/www/localhost/htdocs/

And everything in that dir is owned by user 'apache', group 'apache' (the same user and group that I have httpd running under), with file perms of 644 (unless otherwise changed, like for phpBB2 and Gallery2 dirs)
Was This Post Helpful? 0
  • +
  • -

#6 no2pencil  Icon User is offline

  • Toubabo Koomi
  • member icon

Reputation: 5178
  • View blog
  • Posts: 26,870
  • Joined: 10-May 07

Re: Cannot connect to Apache webserver

Posted 10 October 2007 - 03:54 AM

View PostMorphiusFaydal, on 9 Oct, 2007 - 09:20 PM, said:

I have:

DirectoryIndex index.html index.htm index.php



I just checked, and, for some reason, I have no DocumentRoot defined. However, httpd is reading out of /var/www/localhost/htdocs/

DocumentRoot /var/www/localhost/htdocs/
DirectoryIndex index.html index.htm index.php



httpd -k restart


Or if you use the initd script to bring it down & restart it, either way.
Was This Post Helpful? 0
  • +
  • -

#7 MorphiusFaydal  Icon User is offline

  • D.I.C Lover
  • member icon

Reputation: 43
  • View blog
  • Posts: 1,376
  • Joined: 12-May 05

Re: Cannot connect to Apache webserver

Posted 10 October 2007 - 09:14 AM

View Postno2pencil, on 10 Oct, 2007 - 05:54 AM, said:

View PostMorphiusFaydal, on 9 Oct, 2007 - 09:20 PM, said:

I have:

DirectoryIndex index.html index.htm index.php



I just checked, and, for some reason, I have no DocumentRoot defined. However, httpd is reading out of /var/www/localhost/htdocs/

DocumentRoot /var/www/localhost/htdocs/
DirectoryIndex index.html index.htm index.php



httpd -k restart


Or if you use the initd script to bring it down & restart it, either way.



Yeah, I know. I'm not worried though. :)
Was This Post Helpful? 0
  • +
  • -

Page 1 of 1