2 Replies - 443 Views - Last Post: 22 July 2014 - 04:38 PM

#1 Wildamos2  Icon User is offline

  • New D.I.C Head

Reputation: 0
  • View blog
  • Posts: 1
  • Joined: 22-July 14

Can not get thank you page to load

Posted 22 July 2014 - 03:08 PM

I have tried several time with various text but can not get the Thank you page to load after the form is sent. The Form information sends alright.
<FORM method= "post" action="http://www.bizland.com/scripts/formemail.bml">
  <INPUT TYPE="hidden" name="subject" VALUE="send / Information Request">
  <INPUT type="hidden" name="my_email" value="http://www.sammymbrown2016@aol.com">
  <INPUT type="hidden" name="redirect" value="thankyou01.html">
  <INPUT TYPE="hidden" name="order" VALUE="
        Yrfirstname,Yrlastname,Yrmaillingaddress,Yrcity,Yrstate,Yrzip,Yremailaddress,
        bestphone,bestdaytocall,sun,mon,tue,wed,thur,fri,sat,besttimetocall,poisitionone,poisitiontwo,poisitionthree,poisitionfour,poisitionfive,Comments,">
  <P>]  I have checked and rechecked the thank you page name checked the upper and lower case and it is all lower case. The ending html is: [<P>
  </TABLE>
  <P>
  <P>
  
    <TABLE CELLPADDING="2" ALIGN="left">
      <TR>
	<TD>&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;
	&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;
	  <INPUT TYPE=submit name="sendto" value="Send"></TD>
	<TD>&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;
	  &nbsp;&nbsp;&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;
	  &nbsp;&nbsp; &nbsp; &nbsp; &nbsp;</TD>
	<TD>
	  <INPUT TYPE=reset></TD>
      </TR>
    </TABLE>
  
  <P>
  <P>
  <P>
  <P>
</FORM>
<p>

I would appreciate any help and suggestions.
Thank You

This post has been edited by macosxnerd101: 22 July 2014 - 03:11 PM
Reason for edit:: Please use code tags


Is This A Good Question/Topic? 0
  • +

Replies To: Can not get thank you page to load

#2 Martyr2  Icon User is offline

  • Programming Theoretician
  • member icon

Reputation: 4333
  • View blog
  • Posts: 12,128
  • Joined: 18-April 07

Re: Can not get thank you page to load

Posted 22 July 2014 - 03:56 PM

The hidden field with the redirect will not cause it to redirect. This would only work if you controlled the script you submitted the form to and then could read that field and do the redirect. But my guess here is that you don't control that script you are submitting to. Let me know if I am wrong about that.

If you don't control that script, then you are left with a few options for submitting this form. You could try a javascript submit and then do the redirect or perhaps you could see if there is a way that the person who controls the server side script can take a redirect parameter for you.

As for other things of note, what is with all the non breaking spaces (&nbsp characters)? Remember you have CSS for styling things including padding and alignment.

:)
Was This Post Helpful? 0
  • +
  • -

#3 astonecipher  Icon User is offline

  • Major DIC Head
  • member icon

Reputation: 670
  • View blog
  • Posts: 2,946
  • Joined: 03-December 12

Re: Can not get thank you page to load

Posted 22 July 2014 - 04:38 PM

Looks like you are delving into a reseller account. I would show the server-side code that would show the thank you page.
Was This Post Helpful? 0
  • +
  • -

Page 1 of 1