1 Replies - 755 Views - Last Post: 22 February 2016 - 08:56 AM

#1 chrylag  Icon User is offline

  • D.I.C Head

Reputation: 0
  • View blog
  • Posts: 61
  • Joined: 06-September 15

Standard MonoGame Project wont build

Posted 21 February 2016 - 10:48 AM

Hey there.

I already posted this problem in a german forum but there weren't any helpful answers, so I am asking here now.

I installed MonoGame 3.4, Visual Studio Community 2015 with Update 1 and XNA 4.0 on Windows 10.
But the Standard MonoGame Project for Windows wont build.
It keeps telling me there might be a reference missing, because the 'Xna namespace' could Not be found (I am Not on this machine, so I can't copy the exact message right now).

I tried to add it manually but I am not able to find it on my system, even after I installed XNA 4.0.
The Microsoft.Xna namespace / Assembly / Reference I mean.

I thought the assembly reference would be included in MonoGame.

Any suggestions?

Thanks in advance!

This post has been edited by chrylag: 21 February 2016 - 10:49 AM


Is This A Good Question/Topic? 0
  • +

Replies To: Standard MonoGame Project wont build

#2 dican  Icon User is offline

  • New D.I.C Head

Reputation: 0
  • View blog
  • Posts: 1
  • Joined: 22-February 16

Re: Standard MonoGame Project wont build

Posted 22 February 2016 - 08:56 AM

Hi chrylag,
I'm not sure if it works for you but I got the same issue recently. Also I used Xamarin instead of VS.
To get a working (open GL) project with that I need to add WindowsGL to the used packages and copy a SDL2.dll close to the exe file.
As far as I know (I'm new to MG) the MG version 3.4 has some problems with building a working project by itself. You might check out the newest version at github.
Was This Post Helpful? 0
  • +
  • -

Page 1 of 1