2 Replies - 325 Views - Last Post: 19 August 2016 - 07:28 PM

#1 AmericanPi  Icon User is offline

  • New D.I.C Head

Reputation: -5
  • View blog
  • Posts: 14
  • Joined: 30-July 16

Help me with Lua? just installing...sort of

Posted 19 August 2016 - 05:37 PM

i didn't know where else to post this. SRY. but i am stuck and this is general i think.
I - sudo apt-get install lua5.3 - ok no problem.
I write a HW program - Print ("Hello Super Brian!") - ok no problem.

But THEN Tux tells me - "The program 'lua' can be found in the following packages
* lua5.2
* lua5.1
* lua50"

not ok, problem


I ran lua [filename.lua] from the directory where i saved the text.

I feel like this ones on the tip off my tongue!


Is This A Good Question/Topic? 0
  • +

Replies To: Help me with Lua? just installing...sort of

#2 AmericanPi  Icon User is offline

  • New D.I.C Head

Reputation: -5
  • View blog
  • Posts: 14
  • Joined: 30-July 16

Re: Help me with Lua? just installing...sort of

Posted 19 August 2016 - 06:21 PM

I wish i knew how to edit my posts

ok it's working now..
first i
sudo apt-get install liblua5.3-dev


then i figured let me try and specify the version when i run the program
so i
lua5.3 [filename].lua

then it worked.

now i don't know if running that library command fetched any missing packages (don't know what that means - do explain)
or i could've included the version from the beginning and been ok.

thanks for any views and replies.

Was This Post Helpful? 0
  • +
  • -

#3 Skydiver  Icon User is offline

  • Code herder
  • member icon

Reputation: 5929
  • View blog
  • Posts: 20,272
  • Joined: 05-May 12

Re: Help me with Lua? just installing...sort of

Posted 19 August 2016 - 07:28 PM

Moving to Software Support...
Was This Post Helpful? 0
  • +
  • -

Page 1 of 1