1 Replies - 700 Views - Last Post: 14 September 2017 - 12:29 PM

#1 flex567  Icon User is offline

  • New D.I.C Head

Reputation: 0
  • View blog
  • Posts: 1
  • Joined: 30-July 17

Code won't run in Qtspim

Posted 30 July 2017 - 05:33 AM

This is the code that I try to run:
#
# Demo
#
# Filename: LoadImmidiate
#
        .data
        
        .text
        
        #Load some registers
        li  $t0, 0x0        #Load Immediate
        li  $t1, 0x1        #Load Immediate
        
        
        #Exit the program
        li  $v0, 10
        syscall 



This is the error that I get, I don't know why this error hapens?
Memory and registers cleared

SPIM Version 9.1.18 of January 3, 2017
Copyright 1990-2017 by James Larus.
All Rights Reserved.
SPIM is distributed under a BSD license.
See the file README for a full copyright notice.
QtSPIM is linked to the Qt library, which is distributed under the GNU Lesser General Public License version 3 and version 2.1.
Exception occurred at PC=0x00000000
  Bad address in text read: 0x00000000
Attempt to execute non-instruction at 0x80000180



Is This A Good Question/Topic? 0
  • +

Replies To: Code won't run in Qtspim

#2 turboscrew  Icon User is offline

  • D.I.C Lover
  • member icon

Reputation: 152
  • View blog
  • Posts: 1,032
  • Joined: 03-April 12

Re: Code won't run in Qtspim

Posted 14 September 2017 - 12:29 PM

From spim manual:

Quote

For example, all instructions in a program are stored in memory starting at address 0x00400000.

Was This Post Helpful? 0
  • +
  • -

Page 1 of 1