3 Replies - 105 Views - Last Post: 06 October 2017 - 08:26 PM

#1 Transistor  Icon User is offline

  • New D.I.C Head

Reputation: 0
  • View blog
  • Posts: 42
  • Joined: 20-November 13

XML Bold text

Posted 06 October 2017 - 04:55 PM

Hi,

I'm loading an xml file in actionscript 2 and all is good. It loads in what I need.
Now in the the xml file I need some of the text in bold but I'm not sure how to do this in
xml. I'm fairly new to xml.

The data from the xml file goes in to a dynamic textbox in flash.

Here is an example of what I have in the xml file. What I need to be bold is Topic 1 -,Topic 2 -, Topic 3 -, Topic 4 -
just that part not the text after it.

<?xml version="1.0"?>
<syllabus>

<learning_object>
<tlo_1>Title one</tlo_1>
<tlo_2> Title two</tlo_2>
<elo> 
Topic 1   First topic
Topic 2 - Second topic
Topic 3 - Third Topic
Topic 4 - Fourth Topic 
</elo>
</learning_object>

</syllabus>




Thanks

Is This A Good Question/Topic? 0
  • +

Replies To: XML Bold text

#2 Martyr2  Icon User is offline

  • Programming Theoretician
  • member icon

Reputation: 5073
  • View blog
  • Posts: 13,697
  • Joined: 18-April 07

Re: XML Bold text

Posted 06 October 2017 - 04:59 PM

Put them in <b> tags? <strong> might work too. Whatever flash will accept. But the standard tags should work. Just make sure you always nest tags properly in XML.
Was This Post Helpful? 0
  • +
  • -

#3 Transistor  Icon User is offline

  • New D.I.C Head

Reputation: 0
  • View blog
  • Posts: 42
  • Joined: 20-November 13

Re: XML Bold text

Posted 06 October 2017 - 05:11 PM

Ok I tried <b> and then replaced <b></b> with <strong> </strong>
and either way when load in displayed in flash the text says null.


	<elo>

	<b> Topic 1 </b>   First topic

	Topic 2 - Second topic

	Topic 3 - Third Topic

	Topic 4 - Fourth Topic

	</elo>






Was This Post Helpful? 0
  • +
  • -

#4 Transistor  Icon User is offline

  • New D.I.C Head

Reputation: 0
  • View blog
  • Posts: 42
  • Joined: 20-November 13

Re: XML Bold text

Posted 06 October 2017 - 08:26 PM

Ok looks like I got it working. Guess I was missing a few things like CDATA in the xml and setting the text to .htmlText in flash.

Thanks!
Was This Post Helpful? 0
  • +
  • -

Page 1 of 1