can't connect to localhost:8500

downloaded ColdFusion 8 the developer edition...

Page 1 of 1

9 Replies - 5225 Views - Last Post: 15 February 2008 - 07:09 PM Rate Topic: -----

#1 parenteau  Icon User is offline

  • New D.I.C Head
  • member icon

Reputation: 0
  • View blog
  • Posts: 36
  • Joined: 12-February 08

can't connect to localhost:8500

Posted 13 February 2008 - 04:31 PM

I can't read .cfm files in my browser locally cause it doesn't seem to be using ColdFusion....
I have googled all over and can't seem to figure out what the problem is...
does anyone here know what to do?
Is This A Good Question/Topic? 0
  • +

Replies To: can't connect to localhost:8500

#2 Nykc  Icon User is offline

  • Gentleman of Leisure
  • member icon

Reputation: 726
  • View blog
  • Posts: 8,638
  • Joined: 14-September 07

Re: can't connect to localhost:8500

Posted 13 February 2008 - 06:13 PM

Do you have a local environment setup?

The CF docs or any of the CF books will cover these in great depth.

This post has been edited by nykc: 13 February 2008 - 06:16 PM

Was This Post Helpful? 0
  • +
  • -

#3 parenteau  Icon User is offline

  • New D.I.C Head
  • member icon

Reputation: 0
  • View blog
  • Posts: 36
  • Joined: 12-February 08

Re: can't connect to localhost:8500

Posted 13 February 2008 - 07:56 PM

View Postnykc, on 13 Feb, 2008 - 06:13 PM, said:

Do you have a local environment setup?

The CF docs or any of the CF books will cover these in great depth.


yes... it installed and then stopped at the second part of the installation. I uninstalled and reinstalled....
it said something about manually configuring the web servers... they only talk about doing that in Windows and Unix on the Adobe site....
or at least that was all I could find. I have now been trying to test everything on a directory I setup on the remote server...
a bit more of a hassle but at least I am getting the job done.

Thanks.
Was This Post Helpful? 0
  • +
  • -

#4 Nykc  Icon User is offline

  • Gentleman of Leisure
  • member icon

Reputation: 726
  • View blog
  • Posts: 8,638
  • Joined: 14-September 07

Re: can't connect to localhost:8500

Posted 13 February 2008 - 08:12 PM

Update this post sometime tommorow. I can do more research on it from work since we use ColdFusion servers. Of course unless you figure it out or someone else is able to help.

Thanks,
Was This Post Helpful? 0
  • +
  • -

#5 parenteau  Icon User is offline

  • New D.I.C Head
  • member icon

Reputation: 0
  • View blog
  • Posts: 36
  • Joined: 12-February 08

Re: can't connect to localhost:8500

Posted 14 February 2008 - 04:30 PM

View Postnykc, on 13 Feb, 2008 - 08:12 PM, said:

Update this post sometime tommorow. I can do more research on it from work since we use ColdFusion servers. Of course unless you figure it out or someone else is able to help.

Thanks,


Figured I would give this another shot to see if anybody has had this problem before....
Was This Post Helpful? 0
  • +
  • -

#6 skyhawk133  Icon User is offline

  • Head DIC Head
  • member icon

Reputation: 1868
  • View blog
  • Posts: 20,280
  • Joined: 17-March 01

Re: can't connect to localhost:8500

Posted 14 February 2008 - 04:33 PM

Wait, you say they only talk about configuring the web server on windows and unix.... are you using another platform?


CF 8 should have a built in web server option that let's you run the developer edition locally without IIS or Apache. Were you ever prompted for that option?
Was This Post Helpful? 0
  • +
  • -

#7 parenteau  Icon User is offline

  • New D.I.C Head
  • member icon

Reputation: 0
  • View blog
  • Posts: 36
  • Joined: 12-February 08

Re: can't connect to localhost:8500

Posted 14 February 2008 - 04:53 PM

View Postskyhawk133, on 14 Feb, 2008 - 04:33 PM, said:

Wait, you say they only talk about configuring the web server on windows and unix.... are you using another platform?


CF 8 should have a built in web server option that let's you run the developer edition locally without IIS or Apache. Were you ever prompted for that option?



I am on a mac running OS X. I loaded the developer edition after watching a tutorial very similar to the one you posted... but it was for a mac. Anyway I installed it to use as a solo server or local... the first option on the three I could check. I put in the passwords and such to enable RDS and for the Administrator... and then, it installed. It stopped and had the done button available, no previous button was accessible and I couldn't check the box to load the admin panel... also it didn't auto start. I manually started CF and it said it was running, but I still could not connect to localhost:8500 .... the installer left me with a message to manually configure web servers... I am lost at this point cause when I search Adobe Knowlage base, live docs, and etc... I have not been able to solve this one. Whoooo... the sweat is dripping from my brow after that one!
Was This Post Helpful? 0
  • +
  • -

#8 skyhawk133  Icon User is offline

  • Head DIC Head
  • member icon

Reputation: 1868
  • View blog
  • Posts: 20,280
  • Joined: 17-March 01

Re: can't connect to localhost:8500

Posted 14 February 2008 - 04:54 PM

Man, I wish I had more experience with CF on a Mac. Dang.
Was This Post Helpful? 0
  • +
  • -

#9 parenteau  Icon User is offline

  • New D.I.C Head
  • member icon

Reputation: 0
  • View blog
  • Posts: 36
  • Joined: 12-February 08

Re: can't connect to localhost:8500

Posted 15 February 2008 - 06:27 PM

OH Yeah!!!! It turns out that Adobe hasn't caught up with Leopard. When configuring the install of Coldfusion 8 on OS X 10.5 and up (as self contained server for development only)... You have to start Coldfusion in the Terminal manually:
type: sudo /Applications/ColdFusion8/bin/ColdFusion start
Then enter system password.

Then open the CF Launcher and Run the Webserver Connector Utility.
Setup Apache:

config dir = /etc/Apache2
Advanced --> binary = /usr/sbin/httpd
Advanced --> server control script = /usr/sbin/apachectl

After these settings are saved.... you have to manually stop Coldfusion in the Terminal:
type: sudo /Applications/ColdFusion8/bin/ColdFusion stop

Then replace the mod_jrun22.so file in /Applications/ColdFusion8/runtime/lib/wsconfig/1
you can download the appropriately compiled mod file here: http://www.scottpink...d_jrun22_64.zip

Now Apache needs to be restarted. I did this by going into system preferences/file sharing/ uncheck and then recheck web sharing.
Restart coldfusion.

And That Is It!!! localhost:8500 is on and I am now running coldfusion!
There were a couple of threads on this in several different places. Different people got around this issue differently according to the configuration desires... but this is how it worked for me. I reinstalled and dumped the program sooooo many times over the past two days that I really could not stand it anymore... the thought of someone being able to get around it really drove me to this one. I am sure Adobe will come out with a fix soon... but if this helps anybody out there... Here is my journal / contribution.
Now it is time to fix all the other things I am having problems with in learning Coldfusion.

Cheers!
Michael Parenteau
Was This Post Helpful? 0
  • +
  • -

#10 Nykc  Icon User is offline

  • Gentleman of Leisure
  • member icon

Reputation: 726
  • View blog
  • Posts: 8,638
  • Joined: 14-September 07

Re: can't connect to localhost:8500

Posted 15 February 2008 - 07:09 PM

Nice, and you posted the solution. You should type that up in a tutorial and submit it for future mac users.
Was This Post Helpful? 0
  • +
  • -

Page 1 of 1