Page 1 of 1

Manually assign a Drive letter to a USB drive Rate Topic: -----

#1 no2pencil  Icon User is offline

  • Toubabo Koomi
  • member icon

Reputation: 5246
  • View blog
  • Posts: 27,062
  • Joined: 10-May 07

Posted 05 March 2008 - 09:29 PM

Manually ssign a Drive letter to a USB drive
Why?
On this computer, I have been battling the fact that I can't use my iPod or thumb drive on any of the USB ports.

My 1st thought was everything was locked down. However I hear the beep when I plug devices in (front & back ports).

Since this is something I've had to look up I figured I'd post this in the Tutorials section for all Dream In Code members to see.

There are a bunch of drives mapped on this machine, C through J, & then some more latter!
They are mapped using the DOS command net use in a batch file that runs at startup.

The problem is, Windows is auto assigning F: to the USB device, even though it's in use elsewhere!

The solution is to map the USB drive to somewhere else and here's how that's done:

Open an explorer window, and right-click "My Computer", then select "Manage"

On the left-hand side, locate "Storage".
Under that will be "Disk Management"... select that.

This will show your computers drives and partitions.

Locate & right-click the USB drive you have installed, then select "Change Drive Letter and Paths..."

On the dialog box, find & select "Change..." then select your drive letter of choice from the combo box and press OK.

You'll get a warning message, but you can ignore it. Nothing is running off that USB device since it won't map correctly! You are back to the Disk Management dialog now, and your newly selected drive letter is showing for your USB drive. Close this dialog, & you're done.

If you now uninstall the USB drive, and then reinstall it, it will come back up as the same drive letter as you assigned.

Is This A Good Question/Topic? 0
  • +

Replies To: Manually assign a Drive letter to a USB drive

#2 LovePanda  Icon User is offline

  • New D.I.C Head

Reputation: 0
  • View blog
  • Posts: 1
  • Joined: 05-June 08

Posted 05 June 2008 - 05:56 AM

A simpler solution is to ensure there is a gap between the letters used to map network drives and the letters of your local drives.

That way any and all USB devices will always be assigned a drive letter correctly.
Was This Post Helpful? 0
  • +
  • -

#3 polymath  Icon User is offline

  • D.I.C Addict
  • member icon

Reputation: 52
  • View blog
  • Posts: 670
  • Joined: 04-April 08

Posted 19 June 2008 - 07:18 AM

Or you can just SUBST everything yourself...I love windows.
Was This Post Helpful? 0
  • +
  • -

#4 Guest_Bob*


Reputation:

Posted 26 May 2010 - 02:53 PM

Did all that and my only option is to delete the partition. Everything else is greyed out.

This post has been edited by no2pencil: 31 January 2011 - 08:30 PM
Reason for edit:: Removed quote of previous post.

Was This Post Helpful? 0

#5 Guest_Jared*


Reputation:

Posted 23 January 2011 - 04:23 AM

Same for me! All greyed out! Anyone know why? I did a manual way that I found elsewhere and assigned a drive letter, but then I wasn't permitted to access the drive anyway!

This post has been edited by no2pencil: 31 January 2011 - 08:30 PM
Reason for edit:: Removed quote of previous post.

Was This Post Helpful? 0

#6 no2pencil  Icon User is offline

  • Toubabo Koomi
  • member icon

Reputation: 5246
  • View blog
  • Posts: 27,062
  • Joined: 10-May 07

Posted 31 January 2011 - 08:32 PM

In order to use the tutorial & change a drive letter assignment on a drive/partition, then the drive/partition must already have a drive letter assignment. Since you say that the only option that you have is delete, does your usb device have a drive letter assigned to it?

My only assumption here is that the partition table became corrupt & Windows is requiring you to reformat the drive. Please understand the purpose of this tutorial is to change the drive letter, not recreate a partition table.
Was This Post Helpful? 0
  • +
  • -

Page 1 of 1