Linux - Not shutting down or rebooting properly

Ubuntu 7.10 Gutsy, Dual Install with Vista

  • (2 Pages)
  • +
  • 1
  • 2

22 Replies - 1336 Views - Last Post: 29 March 2008 - 09:22 PM

#1 Nykc  Icon User is offline

  • Gentleman of Leisure
  • member icon

Reputation: 729
  • View blog
  • Posts: 8,642
  • Joined: 14-September 07

Linux - Not shutting down or rebooting properly

Posted 15 March 2008 - 07:08 PM

I have Ubuntu set up on this laptop as a dual boot. The problem I am encountering, and this problem has been the same since day one is that when I go to reboot or shut down Linux it will go to a black screen then hang...

The hard disk still spins. I also have Windows Vista installed and have no issues rebooting or shutting down,

Now Instead of using the GUI in Linux to shut down and restart I also tried doing this through the terminal using.

sudo reboot 
and it is also getting hung up.

Usually I can find solutions to my problems via the Ubuntu forums, and yet for this issue they don't seem to be very helpful.

Has anyone experienced a similiar issue, or can someone shine some light on the issue as to how I can fix it.

My Linux expertise is novice. Actually speak slow and clearly as I have A.D.D and will be more than likely thinking about why I still can't get my VB issue resolved. ;)

Is This A Good Question/Topic? 0
  • +

Replies To: Linux - Not shutting down or rebooting properly

#2 MorphiusFaydal  Icon User is offline

  • D.I.C Lover
  • member icon

Reputation: 43
  • View blog
  • Posts: 1,376
  • Joined: 12-May 05

Re: Linux - Not shutting down or rebooting properly

Posted 15 March 2008 - 08:45 PM

ACPI issues! It's gotta be.

Where's it hanging? Like... What's do, in detail?
Was This Post Helpful? 0
  • +
  • -

#3 no2pencil  Icon User is offline

  • Admiral Fancy Pants
  • member icon

Reputation: 5348
  • View blog
  • Posts: 27,305
  • Joined: 10-May 07

Re: Linux - Not shutting down or rebooting properly

Posted 15 March 2008 - 08:48 PM

View PostNykc, on 15 Mar, 2008 - 07:08 PM, said:

sudo reboot 
and it is also getting hung up.

What happens if you issue the three finger salute while it's hung up?
Can you manually issue the shutdown command?
sudo shutdown now -r


I doubt that'll do anything different, but it's worth a shot to say we've tried that.
Was This Post Helpful? 0
  • +
  • -

#4 Nykc  Icon User is offline

  • Gentleman of Leisure
  • member icon

Reputation: 729
  • View blog
  • Posts: 8,642
  • Joined: 14-September 07

Re: Linux - Not shutting down or rebooting properly

Posted 15 March 2008 - 08:52 PM

View PostMorphiusFaydal, on 15 Mar, 2008 - 11:45 PM, said:

ACPI issues! It's gotta be.

Where's it hanging? Like... What's do, in detail?


When I initiate the shutdown, Linux goes off, and then screen goes black as if it is just waiting for the hard disk to stop running.. this never happens, it is hanging there both with the reboot and shutdown process.

I even went into the grub and put reboot = h after the kernel command in the grub as suggested in another forum, this did not work either.
Was This Post Helpful? 0
  • +
  • -

#5 Nykc  Icon User is offline

  • Gentleman of Leisure
  • member icon

Reputation: 729
  • View blog
  • Posts: 8,642
  • Joined: 14-September 07

Re: Linux - Not shutting down or rebooting properly

Posted 15 March 2008 - 08:58 PM

View Postno2pencil, on 15 Mar, 2008 - 11:48 PM, said:

View PostNykc, on 15 Mar, 2008 - 07:08 PM, said:

sudo reboot 
and it is also getting hung up.

What happens if you issue the three finger salute while it's hung up?
Can you manually issue the shutdown command?
sudo shutdown now -r


I doubt that'll do anything different, but it's worth a shot to say we've tried that.


Well this actually worked. It rebooted my laptop however I guess it doesn't explain what is hanging it up. Or how come that is working and not sudo reboot.

This post has been edited by Nykc: 15 March 2008 - 09:33 PM

Was This Post Helpful? 0
  • +
  • -

#6 aj32  Icon User is offline

  • D.I.C Addict
  • member icon

Reputation: 30
  • View blog
  • Posts: 577
  • Joined: 30-August 07

Re: Linux - Not shutting down or rebooting properly

Posted 15 March 2008 - 08:59 PM

View PostNykc, on 15 Mar, 2008 - 10:08 PM, said:

I have Ubuntu set up on this laptop as a dual boot. The problem I am encountering, and this problem has been the same since day one is that when I go to reboot or shut down Linux it will go to a black screen then hang...


Wow, I can't believe Linux is actually giving you problems! :P :lol:
Maybe you should install Ubuntu security patch 90847552 Bug Fix for Shutdown Problems? :P (sorry, just had to through that one back at you! ;) )

This post has been edited by aj32: 15 March 2008 - 09:02 PM

Was This Post Helpful? 0
  • +
  • -

#7 MorphiusFaydal  Icon User is offline

  • D.I.C Lover
  • member icon

Reputation: 43
  • View blog
  • Posts: 1,376
  • Joined: 12-May 05

Re: Linux - Not shutting down or rebooting properly

Posted 15 March 2008 - 09:02 PM

View PostNykc, on 15 Mar, 2008 - 10:52 PM, said:

View PostMorphiusFaydal, on 15 Mar, 2008 - 11:45 PM, said:

ACPI issues! It's gotta be.

Where's it hanging? Like... What's do, in detail?


When I initiate the shutdown, Linux goes off, and then screen goes black as if it is just waiting for the hard disk to stop running.. this never happens, it is hanging there both with the reboot and shutdown process.

I even went into the grub and put reboot = h after the kernel command in the grub as suggested in another forum, this did not work either.

What does it say on screen right before the screen goes black?
Was This Post Helpful? 0
  • +
  • -

#8 Nykc  Icon User is offline

  • Gentleman of Leisure
  • member icon

Reputation: 729
  • View blog
  • Posts: 8,642
  • Joined: 14-September 07

Re: Linux - Not shutting down or rebooting properly

Posted 15 March 2008 - 09:03 PM

lol - I had a feeling this would be coming, rofl.

My first real issue with Linux,

I guess what is making it so ironic is that Vista (the OS I despise, has not given me a single problem. I have had two minor issues with Ubuntu. The code::blocks issue, which was just a minor configuration issue. And this reboot issue.
Was This Post Helpful? 0
  • +
  • -

#9 Nykc  Icon User is offline

  • Gentleman of Leisure
  • member icon

Reputation: 729
  • View blog
  • Posts: 8,642
  • Joined: 14-September 07

Re: Linux - Not shutting down or rebooting properly

Posted 15 March 2008 - 09:35 PM

I just got to thinking, in my grub file I reset the boot preference to make Linux the number 1 choice and haven't rebooted since. Could this have been a problem. When I installed Ubuntu as a dual boot, Ubuntu by default is loaded first. I changed it to make Vista the top selection. I wonder if that was the problem?

--Update: I just rebooted successfully using the GUI power button on the desktop. So apparently the problem lies within the Grub file. The question now would be, why is this breaking when I had windows set to be the default choice?

This post has been edited by Nykc: 15 March 2008 - 09:41 PM

Was This Post Helpful? 0
  • +
  • -

#10 MorphiusFaydal  Icon User is offline

  • D.I.C Lover
  • member icon

Reputation: 43
  • View blog
  • Posts: 1,376
  • Joined: 12-May 05

Re: Linux - Not shutting down or rebooting properly

Posted 15 March 2008 - 10:11 PM

Post your menu.lst.

And no, changing the default wouldn't mess up the reboot like that.
Was This Post Helpful? 0
  • +
  • -

#11 Nykc  Icon User is offline

  • Gentleman of Leisure
  • member icon

Reputation: 729
  • View blog
  • Posts: 8,642
  • Joined: 14-September 07

Re: Linux - Not shutting down or rebooting properly

Posted 15 March 2008 - 10:31 PM

# menu.lst - See: grub(8), info grub, update-grub(8)
#			grub-install(8), grub-floppy(8),
#			grub-md5-crypt, /usr/share/doc/grub
#			and /usr/share/doc/grub-doc/.

## default num
# Set the default entry to the entry number NUM. Numbering starts from 0, and
# the entry number 0 is the default if the command is not used.
#
# You can specify 'saved' instead of a number. In this case, the default entry
# is the entry saved with the command 'savedefault'.
# WARNING: If you are using dmraid do not use 'savedefault' or your
# array will desync and will not let you boot your system.
default		0

## timeout sec
# Set a timeout, in SEC seconds, before automatically booting the default entry
# (normally the first entry defined).
timeout		10

## hiddenmenu
# Hides the menu by default (press ESC to see the menu)
#hiddenmenu

# Pretty colours
#color cyan/blue white/blue

## password ['--md5'] passwd
# If used in the first section of a menu file, disable all interactive editing
# control (menu entry editor and command-line)  and entries protected by the
# command 'lock'
# e.g. password topsecret
#	  password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/
# password topsecret

#
# examples
#
# title		Windows 95/98/NT/2000
# root		(hd0,0)
# makeactive
# chainloader	+1
#
# title		Linux
# root		(hd0,1)
# kernel	/vmlinuz root=/dev/hda2 ro
#

#
# Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST

### BEGIN AUTOMAGIC KERNELS LIST
## lines between the AUTOMAGIC KERNELS LIST markers will be modified
## by the debian update-grub script except for the default options below

## DO NOT UNCOMMENT THEM, Just edit them to your needs

## ## Start Default Options ##
## default kernel options
## default kernel options for automagic boot options
## If you want special options for specific kernels use kopt_x_y_z
## where x.y.z is kernel version. Minor versions can be omitted.
## e.g. kopt=root=/dev/hda1 ro
##	  kopt_2_6_8=root=/dev/hdc1 ro
##	  kopt_2_6_8_2_686=root=/dev/hdc2 ro
# kopt=root=UUID=e3a77a24-902c-4935-a2a5-23f6eddfe5ce ro

## Setup crashdump menu entries
## e.g. crashdump=1
# crashdump=0

## default grub root device
## e.g. groot=(hd0,0)
# groot=(hd0,5)

## should update-grub create alternative automagic boot options
## e.g. alternative=true
##	  alternative=false
# alternative=true

## should update-grub lock alternative automagic boot options
## e.g. lockalternative=true
##	  lockalternative=false
# lockalternative=false

## additional options to use with the default boot option, but not with the
## alternatives
## e.g. defoptions=vga=791 resume=/dev/hda5
# defoptions=quiet splash locale=en_US

## should update-grub lock old automagic boot options
## e.g. lockold=false
##	  lockold=true
# lockold=false

## Xen hypervisor options to use with the default Xen boot option
# xenhopt=

## Xen Linux kernel options to use with the default Xen boot option
# xenkopt=console=tty0

## altoption boot targets option
## multiple altoptions lines are allowed
## e.g. altoptions=(extra menu suffix) extra boot options
##	  altoptions=(recovery) single
# altoptions=(recovery mode) single

## controls how many kernels should be put into the menu.lst
## only counts the first occurence of a kernel, not the
## alternative kernel options
## e.g. howmany=all
##	  howmany=7
# howmany=all

## should update-grub create memtest86 boot option
## e.g. memtest86=true
##	  memtest86=false
# memtest86=true

## should update-grub adjust the value of the default booted system
## can be true or false
# updatedefaultentry=false

## should update-grub add savedefault to the default options
## can be true or false
# savedefault=false

## ## End Default Options ##

title		Ubuntu 7.10, kernel 2.6.22-14-generic
root		(hd0,5)
kernel		/boot/vmlinuz-2.6.22-14-generic root=UUID=e3a77a24-902c-4935-a2a5-23f6eddfe5ce ro quiet splash locale=en_US 
initrd		/boot/initrd.img-2.6.22-14-generic
quiet

title		Ubuntu 7.10, kernel 2.6.22-14-generic (recovery mode)
root		(hd0,5)
kernel		/boot/vmlinuz-2.6.22-14-generic root=UUID=e3a77a24-902c-4935-a2a5-23f6eddfe5ce ro single
initrd		/boot/initrd.img-2.6.22-14-generic

title		Ubuntu 7.10, memtest86+
root		(hd0,5)
kernel		/boot/memtest86+.bin
quiet

### END DEBIAN AUTOMAGIC KERNELS LIST

# This is a divider, added to separate the menu items below from the Debian
# ones.
title		Other operating systems:
root


# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/sda3
title		Windows Vista
root		(hd0,2)
savedefault	
makeactive
chainloader	+1


## This entry automatically added by the Debian installer for a non-linux OS
## on /dev/sda5
##title		Microsoft Windows XP Embedded
##root		(hd0,4)
##savedefault
##makeactive
##chainloader	+1


I made 1 change to the menu.lst file. Where it says default, it was set to 4. I re-edited so it said default = 0 which is how it initially was when I installed Linux.

This post has been edited by Nykc: 15 March 2008 - 10:33 PM

Was This Post Helpful? 0
  • +
  • -

#12 MorphiusFaydal  Icon User is offline

  • D.I.C Lover
  • member icon

Reputation: 43
  • View blog
  • Posts: 1,376
  • Joined: 12-May 05

Re: Linux - Not shutting down or rebooting properly

Posted 16 March 2008 - 09:41 AM

Well, 4 would point to your Vista install. I don't see anything that would mess up the the reboot sequence.

Can you tell me what it says on screen right before it goes to the black screen?
Was This Post Helpful? 0
  • +
  • -

#13 Nykc  Icon User is offline

  • Gentleman of Leisure
  • member icon

Reputation: 729
  • View blog
  • Posts: 8,642
  • Joined: 14-September 07

Re: Linux - Not shutting down or rebooting properly

Posted 16 March 2008 - 10:16 AM

It acts like it wants to shut down normally. It closes any applications that are running and goes black as if it were shutting down. Then you can actually hear the hard disk speed up.

No messages, nothing.. Just a normal shutdown sequence. (well at least it appears to be.)
Was This Post Helpful? 0
  • +
  • -

#14 MorphiusFaydal  Icon User is offline

  • D.I.C Lover
  • member icon

Reputation: 43
  • View blog
  • Posts: 1,376
  • Joined: 12-May 05

Re: Linux - Not shutting down or rebooting properly

Posted 16 March 2008 - 10:58 AM

Try turning "ACPI Aware OS" odd in your BIOS.
Was This Post Helpful? 0
  • +
  • -

#15 Nykc  Icon User is offline

  • Gentleman of Leisure
  • member icon

Reputation: 729
  • View blog
  • Posts: 8,642
  • Joined: 14-September 07

Re: Linux - Not shutting down or rebooting properly

Posted 29 March 2008 - 08:22 AM

Ok time for a quick *Bump* I plugged my laptop back in and the problem is happening on linux again. The WiFi light stays on as if telling me in Range even though I am using the LAN connection right now. I don't know if this is the cause or not. It apparently is working when I am running off battery power but not when I am plugged in.

Morphius - I ran through the BIOS and pardon the noobish question but I didn't see that particular option.

I tried sudo reboot again and it doesn't reboot that way either.

I been heavily searching the Ubuntu forums and some people were suggesting adding acpi noacpi to the kernel line with little success.

This post has been edited by Nykc: 29 March 2008 - 08:39 AM

Was This Post Helpful? 0
  • +
  • -

  • (2 Pages)
  • +
  • 1
  • 2