Error::EACCES with Mongrel

Mongrel dies with permission denied

Page 1 of 1

1 Replies - 2325 Views - Last Post: 07 July 2008 - 02:06 AM Rate Topic: -----

#1 jeromir  Icon User is offline

  • New D.I.C Head

Reputation: 0
  • View blog
  • Posts: 1
  • Joined: 26-June 08

Error::EACCES with Mongrel

Post icon  Posted 07 July 2008 - 01:50 AM

Hi all,

I am interested in learning Ruby (package: InstantRails). I installed the instantRails package with no problems. But when I want to start the Mongrel_rails from the InstantRails menu Mongrel dies with error::EACCES. This is obviously a question of acces rules (permission denied). Can anyone tell me where to make which changes in order to get Mongrel and Ruby running (environment: Windows XP) ?

Here are the error messages which can be seen after trying to start Mongrel_rails from the command line:
C:\Entwicklung\InstantRails-2.0-win\rails_apps\demo_app>mongrel_rails start
** Starting Mongrel listening at 0.0.0.0:3000
C:/Entwicklung/InstantRails-2.0-win/ruby/lib/ruby/gems/1.8/gems/mongrel-1.1.2-x8
6-mswin32/bin/../lib/mongrel/tcphack.rb:13:in `listen': Permission denied - list
en(2) (Errno::EACCES)
		from C:/Entwicklung/InstantRails-2.0-win/ruby/lib/ruby/gems/1.8/gems/mon
grel-1.1.2-x86-mswin32/bin/../lib/mongrel/tcphack.rb:13:in `initialize'
		from C:/Entwicklung/InstantRails-2.0-win/ruby/lib/ruby/gems/1.8/gems/mon
grel-1.1.2-x86-mswin32/bin/../lib/mongrel.rb:93:in `new'
		from C:/Entwicklung/InstantRails-2.0-win/ruby/lib/ruby/gems/1.8/gems/mon
grel-1.1.2-x86-mswin32/bin/../lib/mongrel.rb:93:in `initialize'
		from C:/Entwicklung/InstantRails-2.0-win/ruby/lib/ruby/gems/1.8/gems/mon
grel-1.1.2-x86-mswin32/bin/../lib/mongrel/configurator.rb:139:in `new'
		from C:/Entwicklung/InstantRails-2.0-win/ruby/lib/ruby/gems/1.8/gems/mon
grel-1.1.2-x86-mswin32/bin/../lib/mongrel/configurator.rb:139:in `listener'
		from C:/Entwicklung/InstantRails-2.0-win/ruby/lib/ruby/gems/1.8/gems/mon
grel-1.1.2-x86-mswin32/bin/mongrel_rails:99:in `cloaker_'
		from C:/Entwicklung/InstantRails-2.0-win/ruby/lib/ruby/gems/1.8/gems/mon
grel-1.1.2-x86-mswin32/bin/../lib/mongrel/configurator.rb:50:in `call'
		from C:/Entwicklung/InstantRails-2.0-win/ruby/lib/ruby/gems/1.8/gems/mon
grel-1.1.2-x86-mswin32/bin/../lib/mongrel/configurator.rb:50:in `initialize'
		from C:/Entwicklung/InstantRails-2.0-win/ruby/lib/ruby/gems/1.8/gems/mon
grel-1.1.2-x86-mswin32/bin/mongrel_rails:84:in `new'
		from C:/Entwicklung/InstantRails-2.0-win/ruby/lib/ruby/gems/1.8/gems/mon
grel-1.1.2-x86-mswin32/bin/mongrel_rails:84:in `run'
		from C:/Entwicklung/InstantRails-2.0-win/ruby/lib/ruby/gems/1.8/gems/mon
grel-1.1.2-x86-mswin32/bin/../lib/mongrel/command.rb:212:in `run'
		from C:/Entwicklung/InstantRails-2.0-win/ruby/lib/ruby/gems/1.8/gems/mon
grel-1.1.2-x86-mswin32/bin/mongrel_rails:281
		from C:/Entwicklung/InstantRails-2.0-win/ruby/bin/mongrel_rails:19:in `l
oad'
		from C:/Entwicklung/InstantRails-2.0-win/ruby/bin/mongrel_rails:19



Thanks in advance for your help !
Jeromir

Is This A Good Question/Topic? 0
  • +

Replies To: Error::EACCES with Mongrel

#2 MitkOK  Icon User is offline

  • D.I.C Regular
  • member icon

Reputation: 32
  • View blog
  • Posts: 403
  • Joined: 09-August 07

Re: Error::EACCES with Mongrel

Posted 07 July 2008 - 02:06 AM

I don't know how it's done with Instant Rails, but why don't you install Ruby, and then Rails gem which comes with WEBrick server ? If you want Mongrel, get it after that using rubygems.

This post has been edited by MitkOK: 07 July 2008 - 02:07 AM

Was This Post Helpful? 0
  • +
  • -

Page 1 of 1