Data not being added to database

Registration

  • (2 Pages)
  • +
  • 1
  • 2

19 Replies - 1560 Views - Last Post: 29 August 2008 - 07:48 PM Rate Topic: -----

#16 Decypher  Icon User is offline

  • D.I.C Regular

Reputation: 2
  • View blog
  • Posts: 400
  • Joined: 28-June 08

Re: Data not being added to database

Posted 29 August 2008 - 01:08 PM

I'm gettin somewhere

'Field 'Shooting Experience' doesn't have a default value'

That hasn't happened before



ok good news or bad news?

The good news is I would like to say thank you to everyone who helped me as I now have a working register form

HOWEVER,

when the password gets encrypted it saves as a very long number/letter phrase any suggestions?

This post has been edited by Decypher: 29 August 2008 - 01:07 PM

Was This Post Helpful? 0
  • +
  • -

#17 Mcbazzo  Icon User is offline

  • D.I.C Head

Reputation: 0
  • View blog
  • Posts: 72
  • Joined: 29-August 08

Re: Data not being added to database

Posted 29 August 2008 - 01:11 PM

if anyone has msn add me tozzy@live.co.uk
Was This Post Helpful? 0
  • +
  • -

#18 CTphpnwb  Icon User is offline

  • D.I.C Lover
  • member icon

Reputation: 2834
  • View blog
  • Posts: 9,740
  • Joined: 08-August 08

Re: Data not being added to database

Posted 29 August 2008 - 01:17 PM

View PostDecypher, on 29 Aug, 2008 - 12:42 PM, said:

Ok the problem I think has to do with:

<form action="<?php echo $_SERVER['PHP_SELF']; ?>" method="post">

but I'm unsure what is wrong...

This always works for me:
<form action="<?php echo $php_self ?>" method="post">

Was This Post Helpful? 0
  • +
  • -

#19 Mcbazzo  Icon User is offline

  • D.I.C Head

Reputation: 0
  • View blog
  • Posts: 72
  • Joined: 29-August 08

Re: Data not being added to database

Posted 29 August 2008 - 01:29 PM

Sorry to be a pain :blink: , but does anyone know anything about wamp because I got told to use it, however I can't work it. I cannot put codes in and when I do so how do I veiw the outcome of them? :S
Was This Post Helpful? 0
  • +
  • -

#20 JBrace1990  Icon User is offline

  • D.I.C Addict
  • member icon

Reputation: 109
  • View blog
  • Posts: 760
  • Joined: 09-March 08

Re: Data not being added to database

Posted 29 August 2008 - 07:48 PM

Mcbazzo, GO TO YOUR OWN THREAD!

yes Decypher, if you're using MD5 or SHA-1, you need to do the exact same thing to your password when you login, otherwise they won't match.

A good way to make a password is to go with sha1(strtolower($username).$password), which certain forums use... MD5 is good enough for most parts though =)
Was This Post Helpful? 0
  • +
  • -

  • (2 Pages)
  • +
  • 1
  • 2