3 Replies - 2674 Views - Last Post: 19 February 2009 - 09:44 PM Rate Topic: -----

#1 cecilchamp  Icon User is offline

  • New D.I.C Head

Reputation: 1
  • View blog
  • Posts: 3
  • Joined: 19-February 09

Setting up Northwnd database in CF Administrator

Post icon  Posted 19 February 2009 - 01:32 AM

I have the following items set up in the ColdFusion administrator for the data source:

CF Data Source Name: Northwind
Database: C:\SQL Server 2000 Sample Databases\Northwnd.MDF
Server: 127.0.0.1
Port: 1433

I used the name of the SQL Server, but that didn't work either: "texas-pc"

Of course, this is a SQL Server driver.

I keep getting an error stating that "Login failed". Everything I've read says not to put in a User Name or Password.

I am using ColdFusion 8 Developer Edition on my local Windows Vista Business workstation.

Attached File(s)


This post has been edited by cecilchamp: 19 February 2009 - 01:33 AM


Is This A Good Question/Topic? 1

Replies To: Setting up Northwnd database in CF Administrator

#2 sansclue  Icon User is offline

  • D.I.C Regular

Reputation: 29
  • View blog
  • Posts: 316
  • Joined: 21-November 07

Re: Setting up Northwnd database in CF Administrator

Posted 19 February 2009 - 05:43 PM

View Postcecilchamp, on 19 Feb, 2009 - 12:32 AM, said:

I have the following items set up in the ColdFusion administrator for the data source:

CF Data Source Name: Northwind
Database: C:\SQL Server 2000 Sample Databases\Northwnd.MDF
Server: 127.0.0.1
Port: 1433

I used the name of the SQL Server, but that didn't work either: "texas-pc"

Of course, this is a SQL Server driver.

I keep getting an error stating that "Login failed". Everything I've read says not to put in a User Name or Password.

I am using ColdFusion 8 Developer Edition on my local Windows Vista Business workstation.


The "Database Name" should should be the name registered with sql server. IIRC it is "Northwind".
http://www.databasej...28-4-3-img1.jpg

CF Data Source Name: Northwind
Database: Northwind
Server: 127.0.0.1
Port: 1433

I don't know about Vista specifically, but usually the login information depends on what type of credentials you want to use to connect to the database.

- SQL Server Authentication
- Windows Authentication

Leaving the username and password means you want to use windows authentication. For SQL authentication you supply a valid login/passwwrd defined in the database itself. For example "sa" is a sql login. (Though obviously "sa" is not recommended for use on a production server)

There are a few settings that need to be configured/enabled to connect to a database, but some depend on which type of authentication you are using.

1. First did you try all of the troubleshooting tips here?
http://livedocs.adob...ADV_MJS_11.html

2. Are you able to connect using SQL Server Authentication (ie using a sql login/password)?

3. What version of SQL 2000 (including SP). I seem to recall there were some issues with 2000 that were resolved by applying either SP 3 or 4.
Was This Post Helpful? 0
  • +
  • -

#3 cecilchamp  Icon User is offline

  • New D.I.C Head

Reputation: 1
  • View blog
  • Posts: 3
  • Joined: 19-February 09

Re: Setting up Northwnd database in CF Administrator

Posted 19 February 2009 - 09:38 PM

I am using SQL Server 2005 Developer Edition.

I don't know why this worked today, but it did. I used windows authentication yersterday and today and now it passes. It shows OK for the status.

I don't understand why it is working today.

Thanks for your reply and references.

Cecil

View Postsansclue, on 19 Feb, 2009 - 04:43 PM, said:

View Postcecilchamp, on 19 Feb, 2009 - 12:32 AM, said:

I have the following items set up in the ColdFusion administrator for the data source:

CF Data Source Name: Northwind
Database: C:\SQL Server 2000 Sample Databases\Northwnd.MDF
Server: 127.0.0.1
Port: 1433

I used the name of the SQL Server, but that didn't work either: "texas-pc"

Of course, this is a SQL Server driver.

I keep getting an error stating that "Login failed". Everything I've read says not to put in a User Name or Password.

I am using ColdFusion 8 Developer Edition on my local Windows Vista Business workstation.


The "Database Name" should should be the name registered with sql server. IIRC it is "Northwind".
http://www.databasej...28-4-3-img1.jpg

CF Data Source Name: Northwind
Database: Northwind
Server: 127.0.0.1
Port: 1433

I don't know about Vista specifically, but usually the login information depends on what type of credentials you want to use to connect to the database.

- SQL Server Authentication
- Windows Authentication

Leaving the username and password means you want to use windows authentication. For SQL authentication you supply a valid login/passwwrd defined in the database itself. For example "sa" is a sql login. (Though obviously "sa" is not recommended for use on a production server)

There are a few settings that need to be configured/enabled to connect to a database, but some depend on which type of authentication you are using.

1. First did you try all of the troubleshooting tips here?
http://livedocs.adob...ADV_MJS_11.html

2. Are you able to connect using SQL Server Authentication (ie using a sql login/password)?

3. What version of SQL 2000 (including SP). I seem to recall there were some issues with 2000 that were resolved by applying either SP 3 or 4.

Was This Post Helpful? 0
  • +
  • -

#4 sansclue  Icon User is offline

  • D.I.C Regular

Reputation: 29
  • View blog
  • Posts: 316
  • Joined: 21-November 07

Re: Setting up Northwnd database in CF Administrator

Posted 19 February 2009 - 09:44 PM

I am not sure what changed, but I am glad you got it working.

From what I remember sql 2005 (express edition) has a few gotchas. So for any future readers, this entry has a good list of the some of the more common setup problems and how to resolve them.

http://www.mattwoodw...1B1BFC7D1D9A44C
Was This Post Helpful? 0
  • +
  • -

Page 1 of 1