4 Replies - 570 Views - Last Post: 06 March 2009 - 10:01 AM

#1 J-a-y  Icon User is offline

  • New D.I.C Head

Reputation: 1
  • View blog
  • Posts: 34
  • Joined: 09-February 09

IE Problem

Posted 27 February 2009 - 09:03 AM

Here's the site:
http://www.elmwoodpress.net/

Here's the problem:

Posted Image

The problem is the cursor recognizes the image rather than the background of the dropdown list. This problem only occurs when there is an image behind the dropdown list. It only happens in IE(of course) and I thought z-index would have been an easy solution, but has proven to be unsuccessful so far. I could be using it in the wrong div, but idk. I'm sure someone has a solution.

The reason this is a problem is because i want the dropdown to disappear when you mouse off the dropdown list. I have the code which works perfect in firefox and chrome, but not IE. I left that code out because when you try and hover over the links it freaks out because it thinks you mouse off when you really don't. Any suggestions? The css is here: http://www.elmwoodpr...common/home.css

Thanks

Jay

Is This A Good Question/Topic? 0
  • +

Replies To: IE Problem

#2 codyisairplane  Icon User is offline

  • New D.I.C Head

Reputation: 0
  • View blog
  • Posts: 20
  • Joined: 14-February 09

Re: IE Problem

Posted 27 February 2009 - 10:43 PM

Maybe remove the "Alternate Text"'s?
Was This Post Helpful? 0
  • +
  • -

#3 J-a-y  Icon User is offline

  • New D.I.C Head

Reputation: 1
  • View blog
  • Posts: 34
  • Joined: 09-February 09

Re: IE Problem

Posted 03 March 2009 - 12:16 PM

It doesn't matter whether the alternate text is there or not. The link isn't recognized unless you hover over the text. I want to be able to hover over the box behind the text like in firefox and chrome. I'll post an example when i get home from vacation.
Was This Post Helpful? 0
  • +
  • -

#4 gregwhitworth  Icon User is offline

  • Tired.
  • member icon

Reputation: 219
  • View blog
  • Posts: 1,605
  • Joined: 20-January 09

Re: IE Problem

Posted 04 March 2009 - 09:56 PM

Ok Bud,

First off, let me say that I messed with every concievable solution, from z-index with A.P. to clearing floats. It was kind of funny, if you deleted the image - the issue still remains. So what it comes down to is IE doesn't like block elements over floating elements. Thus the floating element get's precedents over the block element.

Anyways, the work around. Throw your image into a div as a background, and bam it works fine in IE. Now granted I had all of the Li's on the menu at a z-index of 2 and the div absolute positioned with a z-index of 1. I didn't try it floating.

Anyways, good luck and thanks for the challenge.
Was This Post Helpful? 1
  • +
  • -

#5 J-a-y  Icon User is offline

  • New D.I.C Head

Reputation: 1
  • View blog
  • Posts: 34
  • Joined: 09-February 09

Re: IE Problem

Posted 06 March 2009 - 10:01 AM

Thanks greg, ill try it out
Was This Post Helpful? 0
  • +
  • -

Page 1 of 1