BR and P tags not doing their jobs of creating blank spaces?

Both break and paragraph tags stopped working for a reason unknown to

Page 1 of 1

6 Replies - 987 Views - Last Post: 08 March 2009 - 09:52 PM

#1 Cokemonkey11  Icon User is offline

  • New D.I.C Head

Reputation: 0
  • View blog
  • Posts: 10
  • Joined: 05-March 09

BR and P tags not doing their jobs of creating blank spaces?

Posted 05 March 2009 - 07:42 PM

gal-cont.php:


<p>
	Character Art [High Poly]<br />


	<a href="img/gb/character-high/axe-hp-sculpt.png" rel="gb_imageset[character-high]" title="Axe High Poly Sculpt">
		<img src="img/gb/character-high/axe-hp-sculpt.png" height="150" class="galcont" />
	</a>

	<a href="img/gb/character-high/cube-wip2.png" rel="gb_imageset[character-high]" title="Cube Work in Progress 2">
		<img src="img/gb/character-high/cube-wip2.png" height="150" class="galcont" />
	</a>

	<a href="img/gb/character-high/guardian-wip4.png" rel="gb_imageset[character-high]" title="Guardian Work in Progress 4">
		<img src="img/gb/character-high/guardian-wip4.png" height="150" class="galcont" />
	</a>

	<a href="img/gb/character-high/old-person.png" rel="gb_imageset[character-high]" title="Old Person">
		<img src="img/gb/character-high/old-person.png" height="150" class="galcont" />
	</a>

	<a href="img/gb/character-high/sword-sculpt5.png" rel="gb_imageset[character-high]" title="Sword Sculpt 5">
		<img src="img/gb/character-high/sword-sculpt5.png" height="150" class="galcont" />
	</a>
</p>

<p>
	Character Art [Low Poly]<br />

	<a href="img/gb/character-low/anatomy-render-1.png" rel="gb_imageset[character-low]" title="Anatomy Render 5">
		<img src="img/gb/character-low/anatomy-render-1.png" height="150" class="galcont"" />
	</a>

	<a href="img/gb/character-low/axe-low-poly-1-normal.png" rel="gb_imageset[character-low]" title="Axe Low Poly 1 Normal">
		<img src="img/gb/character-low/axe-low-poly-1-normal.png" height="150" class="galcont" />
	</a>

	<a href="img/gb/character-low/character-low-poly-2.png" rel="gb_imageset[character-low]" title="Character Low Poly 2">
		<img src="img/gb/character-low/character-low-poly-2.png" height="150" class="galcont" />
	</a>

	<a href="img/gb/character-low/combat-armor-lp-render-5.png" rel="gb_imageset[character-low]" title="Combat Armor Low Poly Render 5">
		<img src="img/gb/character-low/combat-armor-lp-render-5.png" height="150" class="galcont" />
	</a>
</p>



style.css:


body{

	background-color: #000000;

	background-image: url('img/bg.png');

	background-repeat: no-repeat;

	background-position: center;

	color: #000000;

	font-size: 12px;

	text-align: center;

}



img{

	border: 0px;

	display: block;

}



img.middle1{

	display: block;

	margin-left: 250px;

	margin-right: auto;

	float: left;

}



img.middle{

	display: block;

   	margin-left: auto;

		margin-right: auto;

	float: left;

}



*{

	margin: 0;

	padding: 0;

	border: 0px;

}



div.top{

	background-image: url('img/top.png');

	width: 1000px;

	text-align: center;

	padding: 0px;

	margin-left: auto;

	margin-right: auto;

	height: 248px;

}



div.menu{

	height: 344px;

	width: 264px;

	background-image: url('img/menu.png');

}



div.con{

	width: 1000px;

	border: 0px;

	text-align: center;

	padding: 0px;

	margin-left: auto;

	margin-right: auto;

}



div.left{

	background-image: url('img/left.png');

	width: 264px;

	padding: 0px;

	float: left;

	height: 752px;

}


div.midl{

	width: 617px;

	height: 452px;

	overflow: scroll;

	padding: 0px;

	background-image: url("img/gray.png");

	float: left;

}

.galcont{
	display: inline;
	float: left;
	height: 150px;
}



div.rite{

	background-image: url("img/rbg.png");

	height: 752px;

	width: 119px;

	padding: 0px;

	float: left;

}




Please tell me why I can't get a blank space between the headings on gal-cont.php.

The page currently is here: http://radiantworlds...com/gallery.php

Thanks for any help, and feel free to tell me anything else I'm doing wrong.

Is This A Good Question/Topic? 0
  • +

Replies To: BR and P tags not doing their jobs of creating blank spaces?

#2 bsaunders  Icon User is offline

  • D.I.C Addict

Reputation: 44
  • View blog
  • Posts: 571
  • Joined: 18-January 09

Re: BR and P tags not doing their jobs of creating blank spaces?

Posted 06 March 2009 - 06:15 AM

Why are you making images block-level elements?
Was This Post Helpful? 0
  • +
  • -

#3 Cokemonkey11  Icon User is offline

  • New D.I.C Head

Reputation: 0
  • View blog
  • Posts: 10
  • Joined: 05-March 09

Re: BR and P tags not doing their jobs of creating blank spaces?

Posted 06 March 2009 - 08:42 PM

It allows me to stack images on the left bar vertically.

And removing it did not fix the problem.
Was This Post Helpful? 0
  • +
  • -

#4 gregwhitworth  Icon User is offline

  • Tired.
  • member icon

Reputation: 219
  • View blog
  • Posts: 1,604
  • Joined: 20-January 09

Re: BR and P tags not doing their jobs of creating blank spaces?

Posted 07 March 2009 - 02:12 PM

I never use the '*' hack, but from my understanding of it - doesn't it apply that setting to everything?

If so you are turning the margin and padding off of everything. Make it more direct:

You have:
*{

	margin: 0;

	padding: 0;

	border: 0px;

}



Change this to:

#divName p {
   margin: 5;
	padding: 6;}


Like I said, I don't use the * hack so this maybe totally off base. But you should still try not to use hacks anyways. I would say to delete that and go from there.

Keep me filled in on this:

Greg
Was This Post Helpful? 0
  • +
  • -

#5 sl4ck3r  Icon User is offline

  • D.I.C Regular
  • member icon

Reputation: 11
  • View blog
  • Posts: 285
  • Joined: 22-September 07

Re: BR and P tags not doing their jobs of creating blank spaces?

Posted 07 March 2009 - 02:31 PM

Yea, * applies the styles to EVERYTHING. So that would over ride the padding/margin on the p, headings, etc tags.

View Postgregwhitworth, on 7 Mar, 2009 - 01:12 PM, said:

I never use the '*' hack, but from my understanding of it - doesn't it apply that setting to everything?

If so you are turning the margin and padding off of everything. Make it more direct:

You have:
*{

	margin: 0;

	padding: 0;

	border: 0px;

}



Change this to:

#divName p {
   margin: 5;
	padding: 6;}


Like I said, I don't use the * hack so this maybe totally off base. But you should still try not to use hacks anyways. I would say to delete that and go from there.

Keep me filled in on this:

Greg

Was This Post Helpful? 0
  • +
  • -

#6 Cokemonkey11  Icon User is offline

  • New D.I.C Head

Reputation: 0
  • View blog
  • Posts: 10
  • Joined: 05-March 09

Re: BR and P tags not doing their jobs of creating blank spaces?

Posted 08 March 2009 - 08:57 PM

Removing that block did not fix the problem; I still need a way to make <br /> and <p /> form a line break.
Was This Post Helpful? 0
  • +
  • -

#7 gregwhitworth  Icon User is offline

  • Tired.
  • member icon

Reputation: 219
  • View blog
  • Posts: 1,604
  • Joined: 20-January 09

Re: BR and P tags not doing their jobs of creating blank spaces?

Posted 08 March 2009 - 09:52 PM

Ok then here - start CSS troubleshooting.

comment out ALL CSS, and insert the following at the top:


p {
   padding: 10;}

br {
   padding: 10}




By default p has a margin and a padding, and br automatically create new lines. Somewhere you have 'cascaded' these out. If this at least adds padding to your br's and p's - then uncomment one line at a time until you find the culprit.
Was This Post Helpful? 0
  • +
  • -

Page 1 of 1